Office 2003 files open slowly

I have one machine that is having this issue. Any Office file, .doc, .xls, .ppt. It takes about 30 seconds for the file to open when double clicked on, either from the network or locally on the desktop. If I open the program first, and access the file, by clicking on open, it works fine. I have tried several things. Uninstall/Re-install, repair, enabling ShellDataCaching. I also intsalled the latest service pack for Office SP3. Still no luck. This is happening under all profiles.
Who is Participating?
WincitConnect With a Mentor Author Commented:
The ultimate problem was Koadk easy share software was conflicting.  Unistalled Kodak softwaree and problem disappeared!
WincitAuthor Commented:
I am leaving for the day at 5:00pm, eastern. Thanks in advance.
could be the anti-virus program  or the amount of RAM that machine has.
how much RAM does this machines have?
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

open control panel > printers
look for any old network printers or printers that might be offline and delete them. office apps check the printers before opening the file, and will time out if they are no longer existent.
WincitAuthor Commented:
There is 1 GB of memory in the machine. Also, there are no printers that are offline. The same antivirus program has been on that machine for about a year. I did try disabling it, still the same result. I really don't want to re-image the machine. The office files open slowly even if I copy them to the local hard drive. The only time the files open correctly is if I open word or excel and then open the file using the file menu. This is very odd.
Are you familiar with performance monitor? It should be under control panel -> administrative tools -> performance.

Here is one user guide from the web :

You can also try process monitor :
ok -
time to open = time to load word + time to open document
if word is already loaded then
time to open = time to open document
it will seem quicker using this second metohd of opening word. also once you have opened word it will stay resident for a while.
I would suspect -
1) disk - try  open windows explorer and "right click on Local C drive" and select  
"properties" then select Tools tab and then click on the "check now" button, tick both boxes and click on the "start" button - it will say it can't do it and you need to reboot.  Reboot and wait it will check the disc for problems that slow down thr PC.
2) anti virus - after year its probably senile and needs removing and re-installing as they get bigger and messier all the time. (sorry that's as generous asl I get with anti-virus, espcially Norton )
There is a solution to this on Experts-Exchange already, I can't find it at the moment but these are from other sites with the same process. It is for all office application - word, excel, access etc.
For all files affected, doc, docx, dot, xls, xlsm etc follow the below process.
Click on Start / Control Panel / Folder Options / File Types / Scroll down to .doc / Advanced / click on 'Open' / Edit / deselect DDE / (Ensure that there are quotes around %1 "%1" to prevent a different problem) / OK / Close - retest.

Under "Application used to perform action" you should have something like the following for .doc files:
"C:\Program Files\Microsoft Office\Office\WINWORD.EXE" /n "%1"
Do the same for any other file types affected.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.