Solved

Help with Cisco PIX 501 firewall and BellSouth Netopia Router

Posted on 2009-07-06
3
510 Views
Last Modified: 2012-06-27
Hi I hope someone can help me out!  I have been working on this all day and really need to get it fixed.  I came into work today to find our internet connection down.  Our configuration:
Internet --->  AT&T Netopia Router --->  Cisco PIX 501 Firewall

Everything was fine, nothing has changed on the firewall, but all the configuration information on the DSL router was gone.  I finally figured out (thanks to this great board) how to get the connection back by:
1.  configuring the DSL modem's internal LAN IP Address to be the IP of our internet gateway
2. disabling NAT on the external interface of the DSL modem

From inside everything works fine.  When I go to www.whatismyipaddress.com from the servers it shows the correct IP address.  BUT I can't get any connectivity from the outside into our network.  Here is my config file:

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ZgvTJMp0xk36LtHM encrypted
passwd ZgvTJMp0xk36LtHM encrypted
hostname SRIYA-PIX
domain-name sriyanova.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names        
name 209.59.133.114 JonServer1
name 208.43.75.106 JonServer2
name 74.86.123.138 JonServer3
access-list sriya_splitTunnelAcl permit ip 192.168.0.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168.0.192 255.255.255.224
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 10.50.50.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 10.100.1.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.0.192 255.255.255.224
access-list outside_cryptomap_20 permit ip 192.168.0.0 255.255.255.0 10.50.50.0 255.255.255.0
access-list from_Internet permit icmp any any
access-list from_Internet permit tcp any host 74.188.123.211 eq www
access-list from_Internet permit tcp any host 74.188.123.211 eq ssh
access-list from_Internet permit tcp any host 74.188.123.211 eq https
access-list from_Internet permit tcp host JonServer1 host 74.188.123.211 eq smtp
access-list from_Internet permit tcp host JonServer2 host 74.188.123.211 eq smtp
access-list from_Internet permit tcp host JonServer3 host 74.188.123.211 eq smtp
access-list from_Internet permit tcp any host 74.188.123.211 eq 587
access-list from_Internet permit tcp any host 74.188.123.211 eq 465
access-list from_Internet permit tcp any host 74.188.123.211 eq 993
access-list from_Internet permit tcp any host 74.188.123.211 eq 990
access-list from_Internet permit tcp any host 74.188.123.211 eq imap4
access-list sriya_splitTunnelAcl_1 permit ip 192.168.0.0 255.255.255.0 any
access-list outside_cryptomap_dyn_20_1 permit ip any 192.168.0.192 255.255.255.224
access-list outside_cryptomap_20_1 permit ip 192.168.0.0 255.255.255.0 10.100.1.0 255.255.255.0
access-list outside_cryptomap_40 permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 74.188.123.210 255.255.255.248
ip address inside 192.168.0.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn_dhcp 192.168.0.200-192.168.0.210
pdm location 192.168.0.0 255.255.255.255 inside
pdm location 192.168.0.200 255.255.255.255 inside
pdm location 192.168.0.201 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 outside
pdm location 10.50.50.2 255.255.255.255 outside
pdm location 10.50.50.0 255.255.255.0 outside
pdm location 192.168.0.5 255.255.255.255 inside
pdm location 192.168.0.6 255.255.255.255 inside
pdm location 192.168.0.7 255.255.255.255 inside
pdm location 192.168.0.9 255.255.255.255 inside
pdm location JonServer3 255.255.255.255 outside
pdm location 192.168.0.192 255.255.255.224 outside
pdm location JonServer2 255.255.255.255 outside
pdm location JonServer1 255.255.255.255 outside
pdm location 10.100.1.0 255.255.255.0 outside
pdm location 192.168.10.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
static (inside,outside) 74.188.123.211 192.168.0.6 netmask 255.255.255.255 0 0
access-group from_Internet in interface outside
route outside 0.0.0.0 0.0.0.0 74.188.123.209 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http 192.168.0.200 255.255.255.255 inside
http 192.168.0.0 255.255.255.255 inside
http 192.168.0.201 255.255.255.255 inside
http 192.168.0.7 255.255.255.255 inside
http 192.168.0.5 255.255.255.255 inside
http 192.168.0.9 255.255.255.255 inside
http 192.168.0.0 255.255.255.0 inside
snmp-server host inside 192.168.0.9
snmp-server location Sriya Innovations
snmp-server contact Brooks Carlson
snmp-server community Sriya
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map_1 20 match address outside_cryptomap_dyn_20_1
crypto dynamic-map outside_dyn_map_1 20 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 38.101.228.185
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map_1 20 ipsec-isakmp
crypto map outside_map_1 20 match address outside_cryptomap_20_1
crypto map outside_map_1 20 set peer 38.101.228.162
crypto map outside_map_1 20 set transform-set myset
crypto map outside_map_1 40 ipsec-isakmp
crypto map outside_map_1 40 match address outside_cryptomap_40
crypto map outside_map_1 40 set peer 74.165.25.178
crypto map outside_map_1 40 set transform-set ESP-3DES-MD5
crypto map outside_map_1 65535 ipsec-isakmp dynamic outside_dyn_map_1
crypto map outside_map_1 client authentication LOCAL
crypto map outside_map_1 interface outside
isakmp enable outside
isakmp key ******** address 38.101.228.162 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address 74.165.25.178 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash sha
isakmp policy 1 group 1
isakmp policy 1 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 25 authentication rsa-sig
isakmp policy 25 encryption des
isakmp policy 25 hash sha
isakmp policy 25 group 1
isakmp policy 25 lifetime 86400
isakmp policy 45 authentication pre-share
isakmp policy 45 encryption des
isakmp policy 45 hash md5
isakmp policy 45 group 2
isakmp policy 45 lifetime 86400
vpngroup sriya address-pool vpn_dhcp
vpngroup sriya dns-server 192.168.0.10 192.168.10.1
vpngroup sriya default-domain sriyanova.com
vpngroup sriya split-tunnel sriya_splitTunnelAcl_1
vpngroup sriya idle-time 1800
vpngroup sriya password ********
telnet 0.0.0.0 255.255.255.255 inside
telnet timeout 5
ssh 0.0.0.0 255.255.255.255 outside
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 255.255.255.255 inside
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd address 192.168.0.202-192.168.0.240 inside
dhcpd dns 192.168.0.10 192.168.10.1
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain sriyanova.com
dhcpd enable inside
0
Comment
Question by:bacarlson99
3 Comments
 
LVL 15

Accepted Solution

by:
The_Warlock earned 500 total points
Comment Utility
Can you post the Netopia config?
The problem is more than likely NOT in your pix configuration. Its obviously a routing/AC issue in the netopia. Do you have a static Ip address issued to you or is your service dhcp served?
Let us know.
Thanks.
0
 

Author Comment

by:bacarlson99
Comment Utility
Got it figured out!  The Warlock was absolutely correct, the problem was with the Netopia router.  Under the Security settings there is a Exposed Hosts option.  I had to add all the IP addresses under our range so that routing worked correctly.  Thanks for your help!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now