Connect Nokia E71 to Exchange 2003

Hi,

I have a Nokia e71 mobile phone, I have installed Mail For Exchange version 2.9 on it.I need to connect to my exchange server running on sbs 2003 which I am having problems with. I receive the following error on the nokia: "your account does not have permission to sync with current settings. Contact your administrator". I have tried some troubleshooting, I have connected successfully to another exchange server running on sbs 2008.

I have received other errors depending on which settings I enter into the phone, The error above seems to be coming from the exchage server.

Pablo.

pabgmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

debuggerauCommented:
not sure how we can help..

If you want the error to go, you'll need to help us with the current exchange settings and the settings within the e71..

What kind of authentication, encryption and mobile settings do you have on both?
0
Alan HardistyCo-OwnerCommented:
If you visit https://testexchangeconnectivity.com and run the Activesync test, it should give you some pointers as to the problem and the potential solutions as to why you are having problems.
It took me about 3 hours to get the firs E71 configured and now it is much easier, but the server has to be configured properly, otherwise it will fail every time.
It may be that your account has had Activesync disabled.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pabgmAuthor Commented:
Hi,

I have visited testexchangeconnectiviy.com and tested Exchage active sync, the test failed, I have posted the results (i did not use the auto discover option as I the email domain name is different to the domain name used to access the server as the company website resides on an external webserver with an MX record pointing to the exchange server e.g. email is user@domain.com remote web work place is domain123.com

      Testing Exchange Activesync for host https://eleventhhouse.com.au/Microsoft-Server-Activesync/
       Exchange Activesync test Failed
      Test Steps
       
      Attempting to Resolve the host name eleventhhouse.com.au in DNS.
       Host successfully Resolved
      Additional Details
       IP(s) returned: 165.228.171.138
      Testing TCP Port 443 on host eleventhhouse.com.au to ensure it is listening/open.
       The port was opened successfully.
      Testing SSL Certificate for validity.
       The certificate passed all validation requirements.
      Test Steps
       
      Validating certificate name
       Successfully validated the certificate name
      Additional Details
       Found hostname eleventhhouse.com.au in Certificate Subject Alternative Name entry
      Validating certificate trust for Windows Mobile Devices
       The test passed with some warnings encountered. Please expand additional details.
      Additional Details
       Certificate is only trusted on Windows Mobile 6.0 and later. Windows Mobile 5.0 and 5.0 + MSFP devices will not be able to sync. Root = OU=Starfield Class 2 Certification Authority, O="Starfield Technologies, Inc.", C=US
      Testing certificate date to ensure validity
       Date Validation passed. The certificate is not expired.
      Additional Details
       Certificate is valid: NotBefore = 6/28/2009 11:43:20 PM, NotAfter = 6/28/2010 11:43:20 PM
      Testing Http Authentication Methods for URL https://eleventhhouse.com.au/Microsoft-Server-Activesync/
       Http Authentication Test failed
      Additional Details
       An HTTP 403 forbidden response was received. The response appears to have come from IIS6. Body is: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>You are not authorized to view this page</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">
<STYLE type="text/css">
BODY { font: 8pt/12pt verdana }
H1 { font: 13pt/15pt verdana }
H2 { font: 8pt/12pt verdana }
A:link { color: red }
A:visited { color: maroon }
</STYLE>
</HEAD><BODY><TABLE width=500 border=0 cellspacing=10><TR><TD>

<h1>You are not authorized to view this page</h1>
The Web server you are attempting to reach has a list of IP addresses that are not allowed to access the Web site, and the IP address of your browsing computer is on this list.
<hr>
<p>Please try the following:</p>
<ul>
<li>Contact the Web site administrator if you believe you should be able to view this directory or page.</li>
</ul>
<h2>HTTP Error 403.6 - Forbidden: IP address of the client has been rejected.<br>Internet Information Services (IIS)</h2>
<hr>
<p>Technical Information (for support personnel)</p>
<ul>
<li>Go to <a href="http://go.microsoft.com/fwlink/?linkid=8180">Microsoft Product Support Services</a> and perform a title search for the words <b>HTTP</b> and <b>403</b>.</li>
<li>Open <b>IIS Help</b>, which is accessible in IIS Manager (inetmgr),
and search for topics titled <b>About Security</b>, <b>Limiting Access by IP Address</b>, <b>IP Address Access Restrictions</b>, and <b>About Custom Error Messages</b>.</li>
</ul>

</TD></TR></TABLE></BODY></HTML>
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Alan HardistyCo-OwnerCommented:
You need to turn off IP Address restrictions on the Virtual servers.
Open up IIS.
Expand your default website and the right-click on the OMA Virtual Directory and choose properties.
Click on Directory Security Tab and then on the Edit button under IP Address and domain name restrictions.
You will probably find it is set to denied access.  Choose Granted Access and check the same for the Microsoft-Server-Activesync virtual directory and Exchange Virtual Directory and test again.
0
pabgmAuthor Commented:
Hi,

The directory security settings for OMA were ok, but the Microsoft-Server-ActiveSync had "denied access" set as default with a loop back address and 192.168.30.1 which puzzles me as the LAN IP range is 192.168.1.x.

So now I have a new error on the nokia : Error in exchange server. Try again later

0
Alan HardistyCo-OwnerCommented:
Have you removed the IP Address restrictions?  Not sure what the loop back address you are referring to - is this the IP that was set in the restrictions?
Re-run the Activesync test on https://testexchangeconnectivity.com and post the results please.
0
pabgmAuthor Commented:
They don't rank you Guru for nothing!!!
I ended up testing active sync again with testexchangeconnectivity.com which gave me a different error, the site gave me a link to the microsoft website which had some instructuions on how to fix the problem which had to do with forms based authentication. Here is the link to the MS site that helped me fix the problem.

http://support.microsoft.com/kb/817379

Cheers!!!!

Pablo.
0
Alan HardistyCo-OwnerCommented:
Hey Pablo - glad you got it working.  It can be a PITA (Pain In The A$$) getting the first one going but after that, plain sailing.
Enjoy the Nokia E71 - looks good from what I have seen.
Thanks for the points.
Alan
0
pabgmAuthor Commented:
This was a severe PITA!!!!!  I have been working on this for over a week now and I am glad its over!

This e71 is for one of my clients but I personally have an e71 and think its great, the main thing I like is the low profile, anyway I could ramble on about my phone all morning (12:25 am here in Sydney Australia), need to catch some rest for the day ahead!

Once again thanks!

Pablo Gonzalez.

0
Alan HardistyCo-OwnerCommented:
Go put your feet up and enjoy - I know where you are coming from.  Grab a stubby and sip away!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.