Solved

connect windows 2000 PC to windows 2003 pc without asking password

Posted on 2009-07-06
15
430 Views
Last Modified: 2012-08-14
Experts!

I have a windows 2000 PC which is a member of a domain, I'm accessing the windows 2003 server which  is not a member of domain. I can connect to this pc but  it always ask me a user and password. I want to access this computer without asking any password.


what should i do to make it happen..

i mess with this, i really need your guide and help experts!
0
Comment
Question by:game-master
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +5
15 Comments
 
LVL 23

Expert Comment

by:debuggerau
ID: 24791035
it should only ask you for your password on establishing a new session..

Have you looked at providing anonymous access to the Win2K3 box?
Win2K3 has limited anonymous functionality, so might not be exactly what you need.

I'd prefer to map a drive and authenticate then..
0
 
LVL 13

Author Comment

by:game-master
ID: 24791152


wat i want is even if i establish new session it will not ask
username and password...

0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 24791159
Has this got anything to do with MS SQL Server?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 78

Assisted Solution

by:arnold
arnold earned 100 total points
ID: 24791180
This is a username/password issue and not a windows networking nor SQL issue.
The simple way is to add the windows 2003 server into the domain.
Not really sure what windows 2003 PC you have is it running Vista or is it also XP?

The other option is to add identical username/password in the windows2003 server.
i.e. domain\username with password as pass
you would add a user username with password pass.
0
 
LVL 13

Author Comment

by:game-master
ID: 24791274


the win2003 server is setup for workgroup only...
we dont want to put it on domain...

arnold,
how to add identical username/password?

can u guide me to this?
0
 
LVL 78

Expert Comment

by:arnold
ID: 24791331
Export the username/password from the AD and then add them as local users of the server 2003.
No guarantee that it will work, but you can try.
I.e. your login is domain1\game-master with the password of password.
Add a new user to the server 2003 game-master with the password password.
and then grant this user the access it needs to the resources.
Then from the workstation, access the resource you need.

The alternative is to configure control keymgr.dll  (at the run or command prompt type control keymgr.dll) to store the credentials to access resources on the windows 2003 server.
0
 
LVL 96

Expert Comment

by:Lee W, MVP
ID: 24791382
WHY do you want to keep the machine in a workgroup?  What benefits do you perceive by having it there?

One of the major POINTS to having a domain is to simplify access to network resources - which is what you're asking for.  The only way you will be able to achieve this in some way is to create the user accounts on the server as arnold said and setup the passwords to be identical.  As soon as your user changes his password on the domain though, it will start prompting them again.
0
 
LVL 23

Assisted Solution

by:debuggerau
debuggerau earned 100 total points
ID: 24791495
ok, again, have you tried anonymous access?
http://technet.microsoft.com/en-us/library/cc755781(WS.10).aspx
0
 

Accepted Solution

by:
icmndr earned 200 total points
ID: 24805270
Have you tried mapping a drive to the server and adding alternate credentials (the ones you normally have to provide every time)..

Theoretically if the mapped drive is logged in you won't have to provide details as its already authenticated..

May work..
0
 
LVL 5

Assisted Solution

by:Adam Ray
Adam Ray earned 100 total points
ID: 24810016
To expand on icmdr's answer, you can create a login script on your PC (just create a .bat file and put it in your Start-Up folder) that will map a drive on login, it's fairly fool-proof as long as the user name/password on the W2k3 box aren't changed and the server is online when the the PC logs on.

Note: this is NOT a secure solution as the password is just stored in a plain text file.

Put the following lines in the login script:

net use x: /delete
net use x: \\w2k3-server\share /USER:w2k3-server\username password

(Replacing the w2k3-server, share, username, and password with your own info.  The username/password is the user account info on the w2k3 server.)
0
 
LVL 5

Expert Comment

by:Adam Ray
ID: 24810031
I forgot, icmndr:  I assume you also meant to mention to select the "reconnect at logon" option.  That generally works, but in practice I have noticed that the drive will disconnect from to time -- most often when the server is not available on logon.
0
 
LVL 13

Author Comment

by:game-master
ID: 24892803


i tried to connect the windows 2003 server to windows NT (our domain controller) but
it has an error...they said it is not possible...

can u please guide me to this one...



game-master
0
 
LVL 78

Expert Comment

by:arnold
ID: 24894027
http://www.microsoft.com/windowsserver2003/evaluation/whyupgrade/nt4/coexist.mspx


Who are they?
Are you adding the windows 2003 system as a member server or are you trying to add it as a DC?
You can not add the windows 2003 server as a DC.
Go through the properties of my computer on the windows 2003 server. Select the computer name tag.  Then go through the Network ID wizard to add it into the NT domain.
See if you have the desired result.  (You may need to add a computer account based on the windows 2003 server's name prior to going through the Network ID wizard)

Are there system/application requirements/limitation that prevent you from converting the NT domain into an AD domain (windows 2000 and newer)?
0
 
LVL 1

Expert Comment

by:moosarawahi
ID: 24894217
enable gust account in both machean, give them same password, in win 2003 give gust account the necessary p
 Permeation, try that
0
 
LVL 1

Expert Comment

by:moosarawahi
ID: 24894235

enable gust account in both enable gust account in both machine      , give them same password, in win 2003 give gust account the necessary Permeation, try that
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
In this article we will learn how to fix  “Cannot install SQL Server 2014 Service Pack 2: Unable to install windows installer msi file” error ?
Familiarize people with the process of utilizing SQL Server functions from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Ac…
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question