• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1324
  • Last Modified:

HTTP Error 500.0 - Internal Server Error C:\Program Files (x86)\PHP\php-cgi.exe - The FastCGI process exited unexpectedly

Hi I have installed PHP on my IIS 7 server, but I am unable to get it work (error HTTP Error 500.0 - Internal Server Error  C:\Program Files (x86)\PHP\php-cgi.exe - The FastCGI process exited unexpectedly). Does anyone have the same problem ?
0
majox
Asked:
majox
  • 2
  • 2
2 Solutions
 
lanewayCommented:
This is a very general error and could be caused by many things. Often, it refers to PHP not being installed correctly - I would recommend try to reinstall PHP.
0
 
majoxAuthor Commented:
I have reinstalled it at least 10 times :(
0
 
lanewayCommented:
Have you installed the same package 10 times?
If yes, try a different package.

Have you made any changes to php.ini or it's dlls?
If yes, reinstall again without the changes.

Are you trying only a simple php script (like below)?
If not, try with a simple script.
<?php print "hello world"; ?>

Open in new window

0
 
majoxAuthor Commented:
I have installed another package and configured php.ini with other configuration and it works. Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now