Problems with Active Sync and OWA on single front end/back end Exchange 2003

Originally after following the the set up for a single fe/be Exchange by Petri I would always get a windows logom prompt for OWA instead of the default home page (like what you get in SBS 2003.) I would have to enter domain\user and then pass. Then I would go directly to my inbox instead of seeing a nice GUI for loging in like in SBS 2003 Premium. Not a problem until now...

I currently have a few WM 6.1 users and Iphone  users who can't connect through active sync. I an using a godaddy SSL which I have used for other companies with no problems. I also tried turning on Forms based Auth in ESM which allowed the normal OWA web logon page to appear instead of the logon window that would pop up before, the but the phones srill won't connect (properly.) With one of the WM phones I get the message: Exchange Server reqires a personal cert to logon... with errror code - ox85030027. Thanks for all of your help.
jdcreeceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Visit https://testexchangeconnectivity.com and run the Activesync test.  It should give you a clue as to why it fails and the steps to take to resolve the problem.
Sourabh-ExcahngeCommented:
Hi,
It looks like you are planing to deploy Exchange activesync with Cert base authentication
if that is true please let me know
if it is not the case please go to the properties of Exchange, Microsoft-server-activesync virutal directory in the IIS manager
go to the directory security Tab -- last edit for secure communication -- put the radio button on ignore certificate and do an iisreset this should resolve the issue.

Thanks,
SAM
aslamsurveProject ManagerCommented:
Follow the following KB....http://support.microsoft.com//kb/817379

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

aslamsurveProject ManagerCommented:
Also remove the SSL on Microsoft exchange-oma & Microsoft-server-activesync virtual directories then perform IISRESET
jdcreeceAuthor Commented:
Thanks for the response. I'll get back to it in a couple of hours.
jdcreeceAuthor Commented:
Ran the test (alanhardisty) and followed the KB (aslamsurve) but still getting the same errors. I will play some more...
jdcreeceAuthor Commented:
Turned off accept ssl from client in Microsoft-server-activesync and oma...works like a charm! Thanks! What do I need to check for security wise?
jdcreeceAuthor Commented:
alanhardisty, your answer was good but vague. aslamsurve, your advice was a little better and very accurate but lacked a few critical details. All and all i am very pleased with the results. Thanks!
jdcreeceAuthor Commented:
After reading SAM"s answer I wonder if he was right all along? I will have to test...and if so I guess I owe SAM a pint or two.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.