SMS Provider Error in Configuration Manager 2007 Setup

<07-07-2009 10:41:02> CompileMOFFile: Failed to compile MOF D:\Program Files (x86)\Microsoft
Hi Guys

I have a 64bit 2008 member server ,a remote Windows 2003 R2 server running SQL 2005 SP2 in a Windows 2008 AD. I am trying to install Configuration manager and keep getting the same error.

I have tried setting the SPN using SetSPN and Adsiedit but all to no avail.


ERROR::
Configuration Manager\bin\i386\smsRprt.mof, error -1
<07-07-2009 10:41:02> Setup cannot compile MOF file D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\smsRprt.mof.  Do you want to continue?
<07-07-2009 10:41:02> Setup failed to install SMS Provider.  For more information about this error, see Microsoft Knowledge Base at http://microsoft.com or contact Microsoft Technical Support for further assistance.

Any help would be much appreciated.

Afternoonan
afternoonanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

afternoonanAuthor Commented:
All Services on the SQL box running under the Local Service Account except Integration Service running under NetworkServices

When I reset the SPN I am now getting an error saying the Site Machine Account is not a member of the SQL Machines Local Administrators Account when in fact it is?
0
JonLambertCommented:
Which server are you installing the ConfigMgr provider on to?

The server which you are installing the ConfigMgr provider on to must be in the local admins group of the SQL server, as well as a SysAdmin for the database

Also, check that you have Named Pipes enabled on the SQL server.
0
anubhavsharma18Commented:
Create SPNs
http://support.microsoft.com/default.aspx?scid=kb;EN-US;829868

setspn A MSSQLSvc/[SERVER-NAME]:1433 svc_[server-name]_sqls
setspn A MSSQLSvc/[SERVER-NAME].domain.net:1433 svc_[server-name]_sqls

svc_[server-name]_sqls is SCCM SQL Service  account
[server-name] is the name of the primary site server where the relevant SQL server resides.




0
anubhavsharma18Commented:
setspn -A MSSQLSvc/[SERVER-NAME]:1433 svc_[server-name]_sqls
setspn -A MSSQLSvc/[SERVER-NAME].domain.net:1433 svc_[server-name]_sqls

Replace !! with -
0
JonLambertCommented:
afternoonan has already said that he tried setting the SPN .. if you answer is not already solved, could you make sure you have not set duplicate SPNs by running the followin ldifde command (from http://social.technet.microsoft.com/Forums/en-US/configmgrgeneral/thread/bc4c22f1-d5f5-40aa-b250-4b718ff16ec8 .. i haven't tried this myself, so please check this out for yourself first)

ldifde -f c:\ldifde.txt -t 3268 -d "dc=contoso,dc=com" -l serviceprincipalname -r (serviceprincipalname=MSSQLSvc*) -p subtree (replace contoso and com with your domain)

Please do not follow any advice given (by any of us) blindly, always try and check out what we say to do with in conjunction with your own research.  I believe that the practice of some members of this site to just post commands to run without any explanation why to run them is bad practice for this site!


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.