RDP to 2003r2 x86 Std only works in Console mode.

I have a Windows 2003 R2 server that I can log on directly to the console, RDP in via console, but if I RDP in on a normal RDP Session, it fails.

You're prompted to log in, and the screen changes to blue, like you'd normally expect, but after about a minute of staring at an empty desktop, it simply closes the connection.

There are no errors in the app or system logs.  I enabled Terminal Services, then disabled Terminal Services, but am still having the same problem.  RDP is enabled, and I have rights, but not sure where to go from here.  If I watch Task Manager, I can see the new sessions listed as Active when trying to RDP in, but then they just disappear like the user logged off.
LVL 2
cougar694uAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

leegclystvaleCommented:
Have you allowed your username to log onto TS server through the TS security policy?
0
cougar694uAuthor Commented:
It's in remote admin mode, not in TS mode.  Yes, I have rights to log in.  Other DA's are having the same problem, as well as LA's.
0
skshoupCommented:
What client machines are you connecting from?  XP, Vista, Windows 7, Server 2003?

 You might also want to check your Terminal Services Configuration on the server.  Check Start -> All Programs -> Administrative Tools -> Terminal Services Configuration -> Connections -> RDP-tcp

Right-click and click Properties.

Check the property tabs for that connection...Specifically the Network tab...the default number of connections should be 2...maybe that got changed?
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

cougar694uAuthor Commented:
Client machines = Win2k8r2, Win7, Win2k8, Win2k3r2, Vista, and WinXP.

Yes, the configured max connections is 2.

RDP works, I'm not getting denied, but when NOT in console/admin mode, you supply your credents, then it flashes the Applying Personal Settings, that dialog goes away, the background goes blue like it's loading the profile, then no icons and no task bar.  It sits there for about a minute, then closes the RDP session.

During this time, I can look at Task Manager and it says that session is Active.

Again, nothing in the Event Logs show any errors.

I'm currently RDP'd into the server via console/admin mode and can watch when other users try to RDP in and it fails.
0
skshoupCommented:
Check this out on the permissions side - same place as you were before for the connection properties..this is from Microsoft on how to limit to console only, so maybe you can work this in reverse...

Note the "In the Permissions for Everyone area, click to select the Deny check box to deny permission for Guest Access, and then click OK."  Maybe one of the built-in groups has "Deny" accidentally checked.  Last time I bumped into this...it was a permissions issue.

How to limit the number of remote sessions on a terminal server
To open the Terminal Services Configuration Tool, click Start, point to Administrative Tools, and then click Terminal Services Configuration.
In the console tree, click Connections.
In the right pane, right-click RDP-Tcp, and then click Properties.
On the Network Adapter tab, click to select 1 from the Maximum connections drop-down list.
On the Permissions tab, click Add, type Everyone in the Enter the object names to select (examples) box, click Check Names, and then click OK.
In the Group or user names area, click to select the Everyone group.
In the Permissions for Everyone area, click to select the Deny check box to deny permission for Guest Access, and then click OK.

Note This setting permits only one remote connection and only through the console, also known as session 0. To make a Remote Desktop connection to the server, use the mstsc.exe /console command to connect to the console session of a terminal server on a Windows XP-based computer or on a Windows Server 2003-based computer.
0
cougar694uAuthor Commented:
Found the problem:

Apparently the application that was installed on this server required TS, but the app owner removed TS.  When I reinstalled TS, the application was trying to be launched via TSCC > RDP-Tcp > properties > Environment > Start the following program when the user logs on.  I set that to run initial program specified by user profile and all is well.

I'm guessing that when TS was originally installed, and the app was set up, it worked, but uninstalling TS broke the app because it's a requirement (or was installed under TS prior to it's removal).

If I try to manually launch the app, it dies, thus probably the cause of my headache.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.