Solved

Pix 501 loses VPN tunnel overnight

Posted on 2009-07-07
3
272 Views
Last Modified: 2012-05-07
I have a few stores that have lateley been losing their VPN connections overnight which requires me to restart my Sonicwall 3060 pro at corporate and their DSL modems and Pix 501's in the remote locations to re-sync those tunnels. Over the weekend I created a command prompt on my machine at corporate that sent out infinite ping requests and then that store retained it's connection. I turned that off yesterday and we lost the connection by morning.

Is there something that I can do that forces these connections to stay open?

Here is my config for the pix.
interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxxxxxxxxxxxxx encrypted

passwd xxxxxxxxxxxxxxxxx encrypted

hostname pixfirewall16

domain-name domain.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list pixtosnwl permit ip 192.168.116.0 255.255.255.0 192.168.0.0 255.255.255.0

access-list NONAT permit ip 192.168.116.0 255.255.255.0 192.168.0.0 255.255.255.0

access-list outside_access_in permit tcp any interface outside eq 5900

access-list outside_access_in permit tcp any any eq 5900

access-list outside_access_in permit icmp any any

no pager

logging on

mtu outside 1500

mtu inside 1500

ip address outside aa.bb.cc.dd 255.255.255.252

ip address inside 192.168.116.2 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list NONAT

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface 5900 192.168.0.0 5900 netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 aa.bb.cc.ee 255

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.116.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

tftp-server inside 192.168.0.48 /configs

floodguard enable

crypto ipsec transform-set strong esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 86400

crypto map tosnwl 20 ipsec-isakmp

crypto map tosnwl 20 match address pixtosnwl

crypto map tosnwl 20 set peer aa.bb.cc.ff

crypto map tosnwl 20 set transform-set strong

crypto map tosnwl interface outside

isakmp enable outside

isakmp key xxxxxx address aa.bb.cc.ff netmask 255.255.255.255 no-xauth no-config-mode

isakmp identity address

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash sha

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet 192.168.116.0 255.255.255.0 inside

telnet timeout 60

ssh aa.bb.cc.ff 255.255.255.255 outside

ssh 0.0.0.0 0.0.0.0 outside

ssh aa.bb.cc.ff 255.255.255.255 inside

ssh timeout 60

management-access inside

console timeout 0

terminal width 80

Open in new window

0
Comment
Question by:RidcoDoIT
  • 2
3 Comments
 
LVL 13

Accepted Solution

by:
3nerds earned 500 total points
ID: 24795260
The odd thing in this is that you have to go through all of this work to bring them back up. The general idea of a VPN is that it comes up (usually in less than 1 ping) and is there when it is needed and disconnect when it is not. It sounds like you are loosing half the connection as I have seen a simular problem when the IKE piece become out of sync or drops but the IPSEC portion stays up. Do you know what lifetime values you have set up in your Sonicwall?

You might want to do some show commands and look at the output proior to resetting things next time.

Also i don't normally mess with the ipsec lifetime I usually just leave it at default and you have it set to one day.
crypto ipsec security-association lifetime seconds 86400

It may seem odd but I have had better luck shortening the lifetimes in these situation instead of lengthening them. As the longer they got the more trouble I seemed to run into.

Regards,

3nerds

0
 

Author Comment

by:RidcoDoIT
ID: 24795311
I will try and shorten them to 1 hr and see if that makes any difference. I only put that ipsec lifetime command because I was grasping for straws to figure out what will hold these things open.
0
 
LVL 13

Expert Comment

by:3nerds
ID: 24795385
Let me know if you have any other questions.

an hour might bit a bit on ths short side would allow you to test it. If it is better then push it out like 4-12hours.

Good Luck,

3nerds
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
SSL RA VPN 7 78
Problem pinging RRAS server from outside the network 11 67
Switch requirement for IP Phones 4 25
RDP Sonicwall 8 32
Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now