Clock Always Five Minutes Slow / Windows Server 2008

I'll set my clock to the correct time (double-clicking on system tray icon, from "Date and Time" window i click "Change Date and time", and then i will manually set the time).

The next day i'll log in to the computer and notice the clock is five minutes slow again.

what is going on here? how do i fix this?
LVL 1
braker15Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Is your Windows 2008 server the only server in your network?
0
DCMBSCommented:
The server with the PDC FSMO role acts a time sever for the domain.  Find which DC holds this role and check that it has the correct time.
0
gsnshankarCommented:
This  would be a problem if your system infected with spyware/malware. This is typically because of the amount ofrunning processes that slow down the overall clock speed. As a resultyou could be witnessing what you are. Therefore the first thing I wouldsuggest is to make sure you are free and clear of the spyware/malwareissues.

Now that you have done this, make sure you have the internet enabledtime sync set by double clicking on the clock, click on the INTERNETTIME tab and make sure check-box is enabled and you can then even clickUPDATE NOW. This should take a few seconds but not much more then that.

You can learn more about the internet clock here from the microsoft support pages:

http://support.microsoft.com/kb/830092/en-us

http://support.microsoft.com/kb/307897/en-us

http://support.microsoft.com/kb/830483/en-us



If the lag time increases gradually such that 5  mins, 10 mins, 15 mins.... then it is the CMOS battery fault. Try Changing the battery
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

gsnshankarCommented:
Is your Bios time runs correctly?
0
andrewc2189Commented:
Open command prompt Run/Cmd and type in the command: "net time /set"

This will show where the server is syncing it's time to. As DCMS said this is your PDC by default but I believe could have been changed along the way.
0
IT-Monkey-DaveCommented:
Make sure the PDC FSMO server is getting its time from an accurate reference, like n.pool.ntp.org (where "n" is 0, 1, and/or 2).  Try this link as a starting point for background info: http://technet.microsoft.com/en-us/library/cc816633(WS.10).aspx
0
braker15Author Commented:
Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\>net time /set
System error 53 has occurred.

The network path was not found.


C:\>
0
braker15Author Commented:
gsnshankar:  this server has 8GB of ram and typically is running between one and four virtual machines at a time.... also for some reason random apps will creep up to over 1 gb of ram use (ex: firefox, pidgin (go figure?!), chrome, etc).

0
andrewc2189Commented:
This could be because of a couple network issues. It sounds as if the system is trying to synchronize with the net time but if that fails it reverts to the bios time. That is just a guess though.

I would attempt setting the net time to the Primary Domain Controller and then seeing if it still gives you that error. To set the time to that controller type in the command prompt: "net time \\yourpdchere /set /yes"

After that is done, see if it returns the same network error again. It's possible that the server is simply set to the wrong network address to receive time. If not, it may be a more complicated network issue such as a firewall blocking the time from syncing.
0
Darius GhassemCommented:
If you are running in a domain environment then you need to make sure your DC has the correct time and it using a external time source to update it's own time. Second make sure you run w32tm /resync /rediscover on the server that has the wrong time because net time should not be used in a domain environment.

You can import this reg file into your DC to setup an external time source automatically

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23630502.html

Third make sure your VMs aren't syncing with the local server instead they are syncing through the OS instead of the VM settings.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tigermattCommented:
gsnshankar,

Do you have some sort of 'source' for the point you made regarding spyware slowing down the system clock?
I've never come across that sort of statement before; I'm not saying it's not possible, just that it seems extremely unlikely.

In a Domain Environment, all workstations sync their time with the authenticating DC which authenticated that session. Those DCs then look to the DC holding the PDC Emulator for their time. This maintains a time hierachy and ensures all machines have very little difference in their time configuration. There is *never* any need to set an NTP client on the workstations, because the time service is located via Active Directory on any domain joined machine.

To ensure time is always reliable (and accurate), only the PDC Emulator should ever be configured to synchronize to an external time source.

If your machine is always 5 minutes slow, I would first investigate all your DCs to verify the time is consistent and matching across all of them. Also verify that the time on the DCs is indeed 5 minutes ahead of the time on your workstation.

-Matt
0
andrewc2189Commented:
Sorry if I mislead with the net time comment, I was more concerned with where the server was syncing it's clock and misinterpreted the way to get that done. Braker15 I hope we can get your time issue resolved. As for the programs eating up RAM it is probably unrelated to the issue but we could try to address that separately.
0
gsnshankarCommented:
@ tigermatt

 I have read this point a while ago while surfing and heard such problems may be due to a spyware/virus .  I don't remember exactly.  But here are few links that have discussions about Slow down of system clock due to a spyware/virus attack.

http://www.techsupportforum.com/hardware-support/motherboards-bios-cpu/380715-computer-system-clock-going-slow.html

http://www.geeknewz.com/board/lofiversion/index.php/t3333.html

http://help.lockergnome.com/windows2/System-clock-running-slow--ftopict446993.html

Also I heard that some programs can make system clock run @  a slower speed than the real time.  (such as its one second equals 2 real seconds) . I believe such problems are possible and existing. Is it wrong?


May be the point is unrelated to this problem and if yes, just ask the user to ignore the point.
0
braker15Author Commented:
thank you so much, this is finally fixed!
0
DCMBSCommented:
Many Thanks ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.