Solved

FTP7 : 530 Valid hostname is expected

Posted on 2009-07-07
13
20,903 Views
Last Modified: 2013-11-29
Hi,
I have the exact same issue :

I want to configure multiples FTP sites or Web sites + FTP Publishing using host names (same IP). Everything is set correctly in the DNS, permissions are set on the folders, etc.

When we try to connect to the FTP sites :
530 Valid hostname is expected

Any ideas?
0
Comment
Question by:jhamel2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
13 Comments
 
LVL 20

Expert Comment

by:EndureKona
ID: 24800300
Your host headers are probably not setup correctly.

http://learn.iis.net/page.aspx/320/using-ftp-virtual-host-names/ 
0
 

Author Comment

by:jhamel2
ID: 24814526
Hi,

Thanks for the reply and the link.

Yes my host header is set correcly :

ex:  myhost.mydomain.com

The host is set up correctly in the DNS as well (ping ok).

I try to access by using :  ftp://myhost.mydomain.com

530 Valid hostname is expected

Any ideas?
0
 
LVL 37

Expert Comment

by:meverest
ID: 24836748
Hi,

what username are you supplying to log on to the server?  you need to pass the hostname in the username field, like:

Username: myhost.mydomain.com|myUsername

ftp host headers do not work the same as web host headers, so you can't expect it to work in IE like web sites do,

Cheers!
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 

Author Comment

by:jhamel2
ID: 24836825
Hi,

Im trying to logon the "standard" way by using a FTP client (ex: FileZilla).

Ex:

myhost.mydomain.com
myuser
mypass

I set connection mode to : Active Mode.

"myuser" have the proper rights on the home directory.

What am i doing wrong?

Thanks,
0
 
LVL 37

Accepted Solution

by:
meverest earned 500 total points
ID: 24836948
Hi,

I already said:  "you need to pass the hostname in the username field"

so,...
myhost.mydomain.com
myhost.mydomain.com|myuser
mypass

use the pipe character ('|') as delimiter between the username and hostname.

Cheers,  Mike.
0
 

Author Comment

by:jhamel2
ID: 24839051
Hi,

Ok for the username format but it doesnt even seems to get to the authentication process :

EX: if i enter my host in a browser ftp://myhost.mydomain.com, i immediatly receive the 530 error (No such hostname).

Also, i dont use IIS Manager for permissions. What should be my settings concerning authentication, etc.? (i want to control access with Windows accounts)


Thanks a lot!

0
 
LVL 37

Expert Comment

by:meverest
ID: 24839561
Hi,

that is probably because your browser is attempting to log in anonymously first.  This the error.  You should be able to disable anonymous auth in the browser settings.

cheers.
0
 

Author Comment

by:jhamel2
ID: 24839796
Hi,

Here's my procedure :

1. Create FTP account (from Computer Management, no AD)
2. Set the appropriate permissions on the home folders of the website (d:\inetpub\vhosts\mydomain)
3. Add FTP publishing to the website (FTP7)
4. Set IP address (same as website)
5. Check hostname :  myhost.mydomain.com
6. Specific user (read, write)  (user created at step 1)
7 Allow SSL
8. Finish
9. Restart FTP site, web site.
10 In dos console :  ftp myhost.mydomain.com
11. myuser|myhost.mydomain.com

= 530 Valid hostname is expected.

Just when is was starting to love IIS7 :(

Thanks






ftp "myhost.mydomain.com"
myuser|myhost.mydomain.com
0
 
LVL 37

Expert Comment

by:meverest
ID: 24844679
Hi,

you have the username/hostname reversed!

ftp "myhost.mydomain.com"
myhost.mydomain.com|myuser

<!>

Cheers.
0
 

Author Comment

by:jhamel2
ID: 24845587
Hi,

I figured out after my last post... Now it works!!!

But i also had to do the following in order to active dynamic FTP ports in Windows Firewall

Reference :

http://blogs.iis.net/jaroslad/archive/2007/09/29/windows-firewall-setup-for-microsoft-ftp-publishing-service-for-iis-7-0.aspx

Thanks for your help!
netsh advfirewall set global StatefulFtp enable

Open in new window

0
 

Expert Comment

by:MartinVolkart
ID: 25046058
ok, thanks, it works this way.....

...and now, can anyone tell me, how to logon for example with expression, when the program says, that  the pipe can't be used in the logonname?

thanks for your tipps
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Know what services you can and cannot, should and should not combine on your server.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question