Vista Business 64 "Userinit logon application has stopped working" error after last Windows Update

Hi all,

I am getting a popup after I log on using my password  "Userinit logon application has stopped working" . When you click on the" close program" button you get a black screen. I have no access to any menus, ctrl alt del brings up the task manager.

The processes running are:


I have tried:

1.Restart in safe mode (No luck)
2.Restore to prev point before the last Windows Update(After which the error started) using Vista DVD (Same error)
3. Swopping Hard drives (I use the EZ Backup option on my asus motherboard that keeps an exact copy of my hard drive. The other hard drive gives the same error )
4. The only other similar error I could find was , I accessed the registry via the start new task function and the entries referred to in the registry from the above solution are all there.
5. I have removed the hard drive and scanned it using another pc with Norton 360. The scan found no viruses or malware.

I do not want to reinstall vista and all my other programs as this will take me forever with all the online updates. And i am not sure this error will not happen again once I reach the same windows update.

Please give me some ideas.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

the start new task function try "explorer.exe" see if that pulls up the desktop. You might try "msconfig" to pull a list of startup applications and services and remove unknown/unneeded processes.
*be carefull in the services section, check the box that says "hide microsoft services",
wwagenerAuthor Commented:
Thanks!  function "explorer.exe" has given me access to my menus, I have tried to:

1. Create a new user account and logging on with that  (Still get the same error).
2. Disabling all non microsoft startup tasks and services. (Still get the same error)

What else can i try?
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

can you run "eventvwr" in that same function field. look in the "application" and "system" logs and look for any errors that might be relevent, cut and paste the errors here too.

you can look up "event id's" (kind of like a check engine light code in a car, for windows) at to help you diagnose.
wwagenerAuthor Commented:
Thanks, heres the event

Faulting application userinit.exe, version 6.0.6001.18000, time stamp 0x479195c9, faulting module userinit.exe, version 6.0.6001.18000, time stamp 0x479195c9, exception code 0xc0000005, fault offset 0x0000000000005589, process id 0xbf4, application start time 0x01c9ff3ed081ec7d.

   [ Name]  Application Error  
  - EventID 1000
   [ Qualifiers]  0  
   Level 2  
   Task 100  
   Keywords 0x80000000000000  
  - TimeCreated
   [ SystemTime]  2009-07-07T20:09:20.000Z  
   EventRecordID 3621  
   Channel Application  
   Computer CLONAN  
- EventData
try these tips

there is a "source" from which the event is flagged.... it should be labeled as "Src" in teh event viewer... is that "userinit.exe"? if so the above link applies to your situation.
wwagenerAuthor Commented:
Thanks I'll try the different solutions as soon as I can and I'll let you know!
wwagenerAuthor Commented:

The Source is "Application Error" Event ID 1000 Task Category(100)

Hi I have looked at
The registry entries do not exist in Vista 64, and there were no scripts deployed to this PC as this is a home PC

Is there anything else I can Try?
boy this is a tough one. It appears that an application is crashing on bootup. If thats a windows application (assuming you set everything in msconfig's startup and services tab to off), is it possible to do a repair? Do you have the vista install cd?
that exact error "Event ID 1000 Task Category(100)" is something that is logged when an application 'crashes'. Its more abundant in windows x64, with a 32bit app crashing
wwagenerAuthor Commented:
I've done a repair using the Vista cd "no errors found" I have also disabled all in msconfig with no luck
can you check and make sure your drivers are all up to date? like video, chipset, sound, network. those kind of things? If this doesn't work, then i would think its a curruption with windows. The quickest way would be to do a re-install.
wwagenerAuthor Commented:
I found a workaround,
I ran the  "sfc /scannow" tool from the command propt to fix startup files: It gave the following message

"Windows Resource Protection found corrupt files but was unable to fix some of them."
Details in the CBS.log

The file that could not be repaired according to the log was userinit.exe in the System32 folder.

A quick search found 4 userinit files. I copied the one from the C:\Windows\SysWOW64 folder to the System32 folder.

I could not replace the existing userinit.exe file, so I named the new one userinit2.exe.

I changed the Registry [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion
\Winlogon] value to C:\WINDOWS\system32\userinit2.exe"

On restart all is working!

How do I replace the corrupt userinit.exe?? Access is denied. I would like to reset my registry entry to the original with the new file that works IE.

How do I delete userinit.exe and rename userinit2.exe to userinit.exe??


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
u know.... i've used that system file checker many times in the past... no idea why i didn't even suggest it... good job though! What I'd do is download a linux distro that is a bootable cd, boot into linux, and do your file work that way. Of course you'll probably want to make that registry chage back to original before you reboot and make the file changes. Good luck!
u think maybe we could award points?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.