Solved

Exchange 2003 SP2 Size Limit 18GB Issue

Posted on 2009-07-07
19
540 Views
Last Modified: 2012-05-07
I followed the arrticle here http://support.microsoft.com/kb/912375 to increase my database size limit from 18GB to 25GB. But every night at Exchange database check my information store always dismounts and I get the following error in my even viewer. I tried everything but can't figure out why it keeps happening.

Exchange store 'First Storage Group\Mailbox Store (server)': The current physical size of this database (the .edb file and the .stm file) is 26 GB. This database has exceeded the size limit of 18 GB. However, the logical free space in this database has not yet been evaluated. Therefore, it is possible that this database contains enough free space to bring its logical size below the maximum size limit.

If the logical database size exceeds the maximum size limit, it will be dismounted on a regular basis.
0
Comment
Question by:datzent83
  • 8
  • 5
  • 3
  • +2
19 Comments
 
LVL 20

Expert Comment

by:EndureKona
ID: 24798662
Are you positive Exchange is at SP2?   I would reinstalled Exchange 2003 service pack to be sure something was not off on the first install.
0
 

Author Comment

by:datzent83
ID: 24798704
I am 100% positive that my Exchange 2003 is at SP2. Please see the attached screenshot.
exchange.jpg
0
 
LVL 12

Expert Comment

by:Saakar
ID: 24798709
You have to make sure that you are running Exchange 2003 SP2, only then those registry keys will work for you, and the DB size includes both EDB and STM's.
Try freeing up more space by running a Defrag on the database.
http://www.msexchange.org/tutorials/Defragmenting-Exchange-Database.html
0
 
LVL 20

Expert Comment

by:EndureKona
ID: 24798710
That is telling you SBS 2003 is at SP2 not Exchange...

To check Exchange:

You can open Exchange System Manager => Servers : on the right end side corner you will number servers listed there along with sp installed.
0
 
LVL 20

Expert Comment

by:EndureKona
ID: 24798733
Here is one example

sp2.gif
0
 

Author Comment

by:datzent83
ID: 24798737
Opps! My fault. Here is the correct screenshot.
exchange.jpg
0
 
LVL 20

Expert Comment

by:EndureKona
ID: 24798758
"If the logical database size exceeds the maximum size limit, it will be dismounted on a regular basis."

Yes if your physical drive space is filled the db will dismount.  

If you have enough space on the drives.   I would reinstalled SP2 over the top.

Question...does the event logs indicated when db mounts?   all at the same time?
0
 

Author Comment

by:datzent83
ID: 24798786
I don't have to uninstall Exchange SP2 before reinstalling it?
I have 126GB left on my (C) drive, where my Exchange Server is installed.
I have to manually mount the store every morning.
0
 
LVL 20

Expert Comment

by:EndureKona
ID: 24798836
No just install Exchange SP2 over the top...in the event logs is there a common time were it informs the database has been dismounted?
0
Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

 

Author Comment

by:datzent83
ID: 24798863
I can't find it anywhere in the Event Viewer. Unless I am looking in the wrong place.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24802842
If you are getting the message about 18gb, then you are at SP2. If it was 16gb then it would be service pack 1.

The registry key is very sensitive. If you have made an error like an additional space, anything like that, then it will not be read correctly. Furthermore the change doesn't take effect until you restart the information store service.

Therefore I would check the registry key very carefully, before restarting the information store service.

Simon.
0
 

Author Comment

by:datzent83
ID: 24834956
I reinstalled Exchange 2003 SP2 and I still get the following message. What else can I do?
My registry key is: Database Size Limit in Gb = 36

Exchange store 'First Storage Group\Mailbox Store (APROPOSBS)': The current physical size of this database (the .edb file and the .stm file) is 26 GB. This database has exceeded the size limit of 18 GB. However, the logical free space in this database has not yet been evaluated. Therefore, it is possible that this database contains enough free space to bring its logical size below the maximum size limit.
If the logical database size exceeds the maximum size limit, it will be dismounted on a regular basis.  
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24835183
The key has to be wrong. The fact that you are getting the warning about 18gb means that SP2 is installed correctly - as I stated in an earlier message.
You have to check the key, it is case sensative.

After changing it, restart the information store.

Simon.
0
 
LVL 1

Accepted Solution

by:
realtec earned 500 total points
ID: 24835765
Should look like this, see pic...
reg-pic.JPG
0
 

Author Comment

by:datzent83
ID: 24835815
I had it in "Gb" instead of "GB" but when I changed it I still get the same message!
0
 
LVL 1

Expert Comment

by:realtec
ID: 24835853
Did you restart Information store as per Mestha above ?
0
 

Author Comment

by:datzent83
ID: 24835860
Yes and that didn't work. I am restarting the whole server now.
0
 
LVL 1

Expert Comment

by:realtec
ID: 24835949
Post your image of the registry entry as I have done above.
0
 

Author Comment

by:datzent83
ID: 24835972
I got it working. I was adding the registry key to the public folder instead of the private folder. That goes to teach me to check first :)
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now