Configuring SSL for Postfix without TLS support

I am tying to configure Postfix server to answer email request on any specific port with SSL enable. So far I have gathere that we can configure postfix to use TLS support which requires email client to issue STATRTLS command.

Here are the master.cf of postfix that i am working with

smtp      inet  n       -       -       -       -       smtpd
submission inet n       -       -       -       -       smtpd
#  -o smtpd_enforce_tls=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
smtps     inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
LVL 2
binarykukiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kerem ERSOYPresidentCommented:
Hi,

the settings you've got here is only to ensure that SMTPD to listen on port 587 (submission too). But in order it to establish TLS sessions you also need settins in your main.cf too. Here are the settings. The commented out commands are may be useful for you. Try them too if you need. You can find a tutorial at http://www.postfix.org. You also need to create a self-signed SSL certificate with OpenSSL and put the certificate in your tursted root certificate store if you don't want your email client to nag about it. Or just get a regular one it will cost you between 15 -30 USD.

If you have further questions don't hsitate to ask.

Cheers,
K
# TLS parameters
# smtp_use_tls = yes
# smtp_tls_security_level = may
smtpd_use_tls=yes
# smtpd_tls_security_level = may
# smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_loglevel = 2
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtpd_tls_cert_file=/usr/share/ssl/certs/postfix.crt
smtpd_tls_key_file=/usr/share/ssl/private/postfix.pem
#smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
#smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
# TLS end

Open in new window

0
binarykukiAuthor Commented:
This did not solve the issue. Email client still had to issue STARTLS command to get a secure channel.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kerem ERSOYPresidentCommented:
STARTLS is the required command to start TLS anyway. There's no other way to start encrypted communication. So this is obvious. This renders the way you close the question unacceptable.

I've corectly pointed you out how to enable the use of TLS that you had missing in oyour configuration but as you know there are standards for communication. You can not break them.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.