VMware HA AAM error

I am running into a problem. I have recently changed the IP configuration on my 2 ESX servers and vCenter. I am trying to re-enable HA and it fails after about 3 hours. The error is an INTERNAL AAM ERROR - agent could not start.

I have performed/checked the following:

DNS is functioning properly and the records are correct
Hosts file on both ESX servers are correct
Hosts file on vCenter even edited appropriately
Removed each host from the cluster and added back
AAM IS installed and running on both hosts
Pinging from both ESX and all guests works with IP, Name, and FQDN
Can ping gateway from all hosts and guests
All hosts and guests on same subent
licensing is correct
Who is Participating?
Paul SolovyovskyConnect With a Mentor Senior IT AdvisorCommented:
Did you change the ip address on your hosts from the service console you were modifying or from a different service console?

Changing the DNS server settings
Check DNS server settings, update the nameserver IPs and search domain the /etc/resolv.conf file.

Note: Disable VMware High Availability if you do not want virtual machines to failover during the hostname IP change.

To change the default gateway, click the Routing tab and enter the appropriate value.
Update the etc/opt/vmware/vpxa/vpxa.cfg file to reflect the new settings.
Reboot the ESX host for the changes to take place

Also check

* /etc/hosts
* /etc/sysconfig/network
* /usr/lib/vmware-mui/apache/conf/httpd.conf

Paul SolovyovskySenior IT AdvisorCommented:
Please post the exact error, this should help in troubleshooting
8r0k3n71nXAuthor Commented:
When the IP changes were made, I changed them on the ESX from a rack console (local). The IP change for vCenter was done within vCenter. All of the files above were correct.

I was however able to get it fixed this morning. When looking for the FT_HOSTS file from the path that I was searching, the directory was invalid. Manually navigating to /etc/opt/vmware/aam and looked at the FT_HOSTS file. Sure enough, the file contained both the new and old IP addresses. IMO, it appears that the agent only looks for the first IP  address of the LAN side and then the first IP of the iSCSI and does not look at the additional IP addresses. OR that the error is generated because of the first IP is bombing out and the second (correct IP) doesn't matter. I backed up the FT_HOSTS file and removed the old IP information and it worked. I even contacted my vendor and they did not even know about this file being the possible issue.
Paul SolovyovskyConnect With a Mentor Senior IT AdvisorCommented:
I've had to do that before as well but it is normally removed when removing HA from the cluster.  Another issue that may arise is an issue with the vcp.cfg file


to change above you may need to remove host from VC, rename vpxa.cfg and add back in to create new file
8r0k3n71nXAuthor Commented:
Look at my post about the FT_HOSTS file not being updated for an additional solution.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.