• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 776
  • Last Modified:

SSIS running a scheduled job with the protection level set to EncryptSensitiveWithPassword

Hi Folks,
I am trying to schedule the execution of a package through sql agent. The package call child packages that are falling over because the protection level of the child package is set to EncryptSensitiveWithPassword.

I believe you can pass the password through dtexec but that is not a desirable solution because I would need to hardcode the password in the job. Also I would need to setup a xp_cmdshell proxy for the user I am running the job as to run dtexec or make
that user sysadmin which I am not keen on either.

I have given a tip that I could use a package template  -  (see http://support.microsoft.com/kb/918760 method 5)
does anyone know if this would help my situation and what exactly to do (a pointer to some doco would be fab)

1 Solution
Can the child packages be set to use Windows Authentication?  That way you won't be using encrypted credentials embedded in the packages.  The SQL Agent service account must have permissions on the data sources that the packages access.
david_32Author Commented:
I think I found that answer. By using commandline tab in the step for the integration services job you can specify a /DEC <password> parameter.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now