• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1844
  • Last Modified:

How to restore Public folder

I did this procedure and after this i have public folder mounted but get the following error: --------------------------------------------------------
Microsoft Exchange Error
Action 'Update Hierarchy' could not be performed on object 'Update Hierarchy'.

Update Hierarchy Failed Error:The operation cannot be executed because there is no available public folder database on the server 'CORPEX'.
  • 2
1 Solution
How did you do the restore of the database?? Did you use any backup application for this??

Normally restoring to an allready working Exchange database is not possbile. You actually need to change the setting for the database so you are the only one able to write to it (unfortenately i don;t have an Exchange server at hand). Also, when you restore, you should enable the setting that makes the database accesiable again.. Are you able to mount the database again? If not, what error do you get??

Normally btw, best oractice is to set up either a restore database in which you restore the public folders in or recreate an Exchange server and domain with the same name s the production one and restore inthere...

Your other option (though it's not easy to get it working) is pubmerge fo using as a backup tool. It is the public folder tool that Exmerge is for the Users mailboxes..
bsholkovAuthor Commented:
Thank you very much i found solution and it's work fine :
Open adsiedit.msc.


Select Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group.


Now we were missing the 'Folder Hierarchies' folder - how I still am unsure of. All we had to do was recreate it as follows:


Create the "Folder Hierarchies" under the Exchange Administrative Group


1. Right click on Exchange Administrative Group

2. Select New Object

3. Select msExchPublicFolderTreeContainer for the class and click Next

4. Enter the following for the value: Folder Hierarchies, click Next

5. Click Finish


Create Public Folder Tree Object


1. Right click CN=Folder Hierarchies -> New Object

2. Selected msExchPFTree for the class

3. For the value we entered, "Public Folders" and clicked next

4. Clicked on the "More Attributes" button, selected msExchPFTreeType and set the

value to 1. Note: This is very important that this value is set to a value of 1 as

this tells Exchange that this is a MAPI Tree

5. Click Ok and then finish


Populate msExchOwningPFTreeBL attribute object of the PF Stores in the organization

(Since this attribute is not directly editable, you have to follow the below steps

to do this for each PF store)


1. Get properties of the newly created "Public Folders" Tree object in ADSIEdit.

2. Copy the distinguishedname value to the clipboard and then click cancel.

3. Navigate to the Storage group that contains the Public Folder Store for this

server and get properties of the server.

4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

to the clipboard in step 2. Click OK.

5. Restart the Information Store Service

6. Now try to  mount the PF store and see if we can access it fine now.


After recreating  'Folder Hierarchies' PF working fine.

Perfect, nice to see it is working :)

You can actually place a request on the support forum to get this ticket closed and your points refunded..
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now