Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

How do I allow local machine access to IIS7 when IPv4 restrictions are enabled?

Posted on 2009-07-08
7
2,435 Views
Last Modified: 2012-05-07
Hi

This is driving me mad. I can restrict access to IIS7 websites for external IP addresses but I have no idea how to allow the local machine access. I get this error:

"HTTP Error 403.6 - Forbidden
The IP address from which you are browsing is not permitted to access the requested Web site."

I tried an allow rule :

127.0.0.1(255.255.255.255)
and
192.168.1.1(255.255.255.0)

This doesn't work. When I looked at the website log files I noticed the IPv6 address was being logged. Do I need to allow an IPv6 address access? IIS7 only seems to allow IPv4 restrictions.

Please help
Thanks
Andrew
0
Comment
Question by:j055
  • 4
  • 2
7 Comments
 
LVL 37

Expert Comment

by:meverest
ID: 24810060
Hi,

what do you get when you resolve 'localhost' from the server console?

i.e. c:\>ping localhost

if you access from the local system to http://127.0.0.1 that should force it to connect from the ip4 loopback IP.

cheers.
0
 

Author Comment

by:j055
ID: 24811466
Hi

I played around with it a bit more. I now have IIS to deny unspecified and allow a public IP. This seems to allow the local IP access too (which is what I want). It's a shame the documentation isn't clearer about this. Anyway, thanks for your help.

Cheers
Andrew
0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 24821216
Have you tried setting the DisableLoopbackCheck value in the registry (search the web for the details)
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 25733298
You didn't respond with an answer regarding disabling the loopback check
0
 

Accepted Solution

by:
j055 earned 0 total points
ID: 25737619
Hi

I didn't try changing the DisableLoopbackCheck. As I see it the real issue is that IIS7 doesn't allow you to set IPv6 addresses as restrictions using the IIS GUI. I found out that you can add IPv6 restrictions directly in the configuration file. I downloaded the IIS7 Administration Pack which provides a configuration editor UI.

http://www.iis.net/extensions/AdministrationPack

Thanks
Andrew
0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 25746489
OK, then mark your last comment as the solution and the question will be closed without loss of points.   That will keep the moderators from being involved and lighten their load.
0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 25746494
Note: The reason I don't want this deleted is because your answer is valid and might help someone else.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question