Solved

Windows Explorer FTP looks like web page, no upload/delete. How do I fix it?

Posted on 2009-07-08
9
351 Views
Last Modified: 2013-12-09
On all of my windows systems except for my "Daily driver" when I go to an FTP site in Windows Explorer, it looks like any other explorer window (except I have to specify login parameters, but I even have to do that on the one I think is working incorrectly).

So, on my computer, the FTP site is displayed more like a web page (or site listing) in Explorer, which doesn't allow uploading or deleting.

Did I install something that affected this change? Or did Imaybe change a setting?

Anyone know how to get it back to "regular"???

(I attached an image of what I see, I didn't attach one of what it looks like on other systems. I'm sure you probably all know).

Thanks!!!
FTP.jpg
0
Comment
Question by:mobrien118
9 Comments
 
LVL 1

Expert Comment

by:Joffer
ID: 24803077
Is this for all FTP sites or just 3dftp.com?
0
 
LVL 11

Expert Comment

by:techzter
ID: 24803102
Do you receive an error if you try and drag/drop your files to the web browser?
0
 
LVL 23

Expert Comment

by:savone
ID: 24803105
I think it might be a linux box your connecting to.  


Do you know what kind of machines you are connecting to?
0
 
LVL 1

Accepted Solution

by:
Joffer earned 500 total points
ID: 24803107
Anyway - I think you or your administrator may have turned off "FTP-friendly view".

There are several tweaks you can make to Internet Explorer that will make it more FTP-friendly. First, you can set up IE so that it can browse FTP directories, just as if they were folders in Windows Explorer:

Click      Tools | Internet Options.
Click      the Advanced tab.
Under      Browsing, check the box labeled Enable Folder View For      FTP Sites.
 
Next, if you're on a computer that's behind a firewall, you'll need to set up IE to use passive FTP:  Click      Tools | Internet Options.
Click      the Advanced tab.
Under      Browsing, check the box labeled Use Passive FTP.
 
If you need to upload files to an FTP folder, you must use a special URL in the following format:

ftp://username@ftp.domain.com/directory/ 

This will result in the user being prompted for a password. Once the user supplies the password, a directory comes up, and the user can drag and drop files to and from the FTP window.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 12

Expert Comment

by:ibrahim52
ID: 24803112
Did you tried installing another browser like firefox and check your ftp url
0
 
LVL 1

Expert Comment

by:Joffer
ID: 24803139
Just to have mentioned it, even though you are on IE6. In IE 8, there are a special mode for what you want to do, which IE8 actully tells you about when viewing an FTP site:

To view this FTP site in Windows Explorer, click Page, and then click Open FTP Site in Windows Explorer.
Is there such an option in the menu in IE6? I can't check since I'm on IE8 (even though FF3/35 is my main browser)
0
 
LVL 1

Expert Comment

by:Joffer
ID: 24803149
I forgot in my last post, to suggest you open the ftp site in standard Windows Explorerer, instead of Internet Explorere. Just paste the address into the address field.
0
 

Author Closing Comment

by:mobrien118
ID: 31601081
All of the other "solutions" were irrelevant. You hit it exactly. Bullseye! Thanks for the tip!!!
0
 

Author Comment

by:mobrien118
ID: 24803290
I got my solution, but just to clarify some questions:

1. Yes, it happens on every site. I meant to say that but wasn't clear about it.

2. When I drag a file onto it, it opens the file as if I had double clicked it.

3. It happens on Linux or Windows boxes. No difference.

4. The URLs are not the problem. The site I loaded was just an example I got off of google for "Public FTP".

5. I AM on IE8. Also, as I clearly stated in my question, and should be clear from the picture, this happens in "Windows Explorer" not IE (Although, in many respects, they are one and the same)

Thanks to all for your efforts. I appreciate the quickness of your responses.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Internet Explorer 11.0 crashed. 10 41
Task with PowerShell Script is failing with 0x41301 7 90
Configure FTP Server 3 48
MS-Access 2002 error (Win XP on Win7Pro) 19 50
Several part series to implement Internet Explorer 11 Enterprise Mode
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

30 Experts available now in Live!

Get 1:1 Help Now