Solved

Setting Exchange 2003 individual mailbox size limites and issue a warning when it reaches the limit.

Posted on 2009-07-08
11
860 Views
Last Modified: 2012-05-07
I'm trying to set the limits on a couple of user mailbox's, so that it will issue a warning when it reaches 4megs.  I only want to set the warning limit on a couple of users not everyone. No other limits have been set. I've created a test account and set the mailbox size limit to 4megs and sent 3 emails containing a 3 meg file attachment making the mailbox 9 megs in size, I check the mailbox size and it shows over 9 megs, but I'm not getting a warning message, can anyone tell me what I'm doing wrong?

The mailbox's are in the private not public folder store. Outlook 2003 and 2007 being used on XP Pro client systems.

Thank you,
0
Comment
Question by:dsterling
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
11 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 24803895
The update can take upto 2 hours to go through, if you dismount and remount the information store it should read the new information.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 24803930
You can also look here for how to get exchange to update sooner: http://technet.microsoft.com/en-us/library/bb684892.aspx
0
 
LVL 7

Expert Comment

by:aslamsurve
ID: 24804355
After you configure the mailbox size restriction for a mailbox, that mailbox user can continue to send and receive messages that cause the mailbox to exceed the configured mailbox size. The configured limits are enforced after a period of time, but do not take effect immediately. Restarting the Microsoft Exchange Information Store service causes the configured limits to take effect immediately.

Resolution
=======
This issue occurs because the Microsoft Exchange Information Store service uses the cached mailbox configuration to enforce mailbox size limits. The configuration change does not take effect until the cache is refreshed. The default interval for refreshing the cached mailbox information is two hours.
To resolve this problem, you can change the refresh interval for the mailbox information cache by modifying the Reread Logon Quotas Interval value in the registry for the Microsoft Exchange Information Store service. The Reread Logon Quotas Interval value depends on the Directory Service Access (DSAccess) cache and the mailbox information cache. Therefore, you must configure the CacheTTLUser and Mailbox Cache Age Limit values as well.
0
Office 365 Training for IT Pros

Learn how to provision Office 365 tenants, synchronize your on-premise Active Directory, and implement Single Sign-On.

 
LVL 7

Assisted Solution

by:aslamsurve
aslamsurve earned 100 total points
ID: 24804383
Take a backup of you registry on the Exchange server by typing regedit in run Window
Right click My Computer & click export, save with a file name to the desktop location..

To use the registry editor to configure the mailbox information cache refresh interval for the Microsoft Exchange Information Store service
1.Start the registry editor and connect to the registry of the server for which you want to configure the Microsoft Exchange Information Store service.
2.Locate the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem key.
3.To configure the interval for refreshing the information for mailbox size limits, do the following:
a.Right-click ParametersSystem, select New, and then select DWORD value.
b.Name the new DWORD value Reread Logon Quotas Interval.
c.Right-click Reread Logon Quotas Interval, and then click Modify.
d.For the Base option, click Decimal.
e.In the Value data text box, enter a positive integer specifying the mailbox information cache refresh interval in seconds, and then click OK. The default value is two hours (7200 seconds). The recommended value is 20 minutes (1200 seconds).
4.To change the mailbox information cache age limit value, do the following:
a.Right-click ParametersSystem, select New, and then select DWORD value.
b.Name the new DWORD value Mailbox Cache Age Limit.
c.Right-click Mailbox Cache Age Limit, and then click Modify.
d.For the Base option, click Decimal.
e.In the Value data text box, enter a positive integer specifying the mailbox information cache age limit in minutes, and then click OK. The default value is two hours (120 minutes).
5.Locate the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchange ADAccess\Instance0 key. If this registry key is not present, create it using the following steps:
a.Right-click MSExchange ADAccess, select New, and then select Key.
b.Name the new key Instance0.
6.To configure the DSAccess cache refresh rate, do the following:
a.Right-click Instance0, select New, and then select DWORD value.
b.Name the new DWORD value CacheTTLUser.
c.Right-click CacheTTLUser, and then click Modify.
d.For the Base option, click Decimal.
e.In the Value Data text box, enter a positive integer specifying the cache expiration interval for the user data object in seconds. The default value is 5 minutes (300 seconds).
7.Close the registry editor.
8.Restart the Microsoft Exchange Information Store service.

0
 

Author Comment

by:dsterling
ID: 24806381
Thanks for the comments, but I've been waiting for 3 hours and still no over the limit warning message sent to the test user account email, I've even sent a few more meg's of email to the mailbox and still no message?

Thank you
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 24806436
Are you making the setting in exchange advanced tab under properties of the user in Actuve Directory Users and computers?
You also need to ensure you unchecked use store defaults.

Have tou tried restarting the information store service and also following the instructions in the link I sent?
0
 

Author Comment

by:dsterling
ID: 24806484
I've also restarted the Information Store and still no success? In the user account Properties, Exchange General, Storage Limits...the Issue warning at (KB) is set to 4000, which would be 4 meg's, the mailbox is now showing 29megs and I've restarted the information store and I'm still not getting the warning message?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 24806640
It will be the actual mailbox that has the limit on that receives the message unless you deny receive.

They will only receive the message when they try to send an email and only if you have denied send.  Otherwise to that it will be when the maintenance is rub, on mine at 2am.

0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 400 total points
ID: 24806665
Basically if you want to receive messages you need to disable send or receive when limit is reached or both.  If neither of these are checked the mailbox in question will receive an email from the System when it runs it's maintenance one a day normally in the early hours.
0
 

Author Comment

by:dsterling
ID: 24806779
Thanks for all the comments, I will have to wait and check tomorrow.
0
 

Author Closing Comment

by:dsterling
ID: 31601117
Works, demazter you are correct it took overnight when the system runs its maintenance, do you know how to check that?

Thank you
0

Featured Post

Business Impact of IT Communications

What are the business impacts of how well businesses communicate during an IT incident? Targeting, speed, and transparency all matter. Find out more in this infographic.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question