Solved

Google Apps Email Routing unknown accounts to Postfix - "Relay access is denied (state 14)"

Posted on 2009-07-08
2
909 Views
Last Modified: 2013-11-30
Hello

We're an SaaS provider that uses a lot of SMTP traffic for routing customer-driven information out to our users.  The emails our application sends are not spam or unsolicited (just figured I'd say that right off the bat...)

Our previous configuration was an IMail server hosting both our corporate email and application email as ourcompany.com.  We moved our corporate emails (ourcompany.com, "staff") to Google Apps some time ago, then configured Google Apps to send unknown accounts to our IMail server.  That has been working great.  Now, we're moving our application email from our IMail server to an Ubuntu server running Postfix on a different email domain (applicationemail.net).  The account names are the same, we're just changing the domain names they're associated with.  Since our customers are use to sending to THIERNAME@ourcompany.com for years, I want to configure our current Google Apps email to send unknown addresses to the new Postfix server, but restamp the SMTP envelope with @applicationemail.net address.

I've configured it to do just that.  Now, if I send an email to an account that is not provisioned in Google Apps to an account that exists on the Postifx server, Postfix is bouncing the message back saying:  

Delivery to the following recipient failed permanently:

     ryan.kay@applicationemail.net

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 <ryan.kay@ourcompany.com>: Relay access denied (state 14).

I've found resources all over the place where people are reporting problems going the OTHER way... Postfix to Google Apps gives this error, but I know that this is a configuration issue with Postfix.  Postfix doesn't want anything relayed to it.  I cannot find anywhere how to allow google apps to send TO postfix.

I know that I can configure Postifx to permit IP addresses (it already is doing so), but since Google is so dynamic, I was hoping there was a way to permit their servers by domain name instead....

Any help is appreciated!
0
Comment
Question by:RyanTKay
  • 2
2 Comments
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 500 total points
ID: 24809852
You need to add applicationemail.net to postfix main.cf mydestination= section.

0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 24809856
Don't forget to restart the server after the change.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

New-MailboxSearch Powershell Command and step by step approach to Search and Extract Emails form Exchange 2013 Journaling server.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now