Sluggisg performance accessing documents stored in the IFS on my I5 Server

Hello,

We recently acquired an IBM I5 server model E4a with lots of memory and disk.  It is running V5R4.  The previous system was an Iseries .  I don't remember the model but it was 5 years old, slower and with a lot less memory and disk.

We store documents in the ifs .  On the Iseries, opening and saving documents to the IFS was very fast.  On the I5 server it is very sluggish.  Most times it times out.  My tests were done with file sizes less then 1 meg is size.

Both the I5 and Iseries are connected to the LAN at 100M full duplex.

Has anybody seen this?

Thanks
hockeyhalloffameAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rwardCommented:
I have same model iSeries and V5R4. No IFS issues.

Make sure your TCP settings are optimal for your environment.  use CFGTCP command, then option 3 to modify the TCP Send/Receive buffers sizes.  The default is 8k.  Our box performs well with 64k for the send/receive buffers.  You can set it as high as 8mb.  Changes take effect immediately.

Also in the CFGTCP menu, make sure domain information and DNS settings are correct (option 12)

Lastly, check that you have the latest CUME PTF package installed.  Currently it is # 9104.  You can get the package from IBM's Fix Central site.  http://www-933.ibm.com/support/fixcentral/main/System+i

Rob

 
0
hockeyhalloffameAuthor Commented:
Thank You Rob for the response.

We are at he latest cums for v5r4 ( TL59104).  The buffer size is also set at 8Meg over here.  DNS settings are good ( I have compared them to the old server, they are the same).  I do not have any issues on my 810 model running V5R2.
0
rwardCommented:
I did some more testing on my system and found that large file copies to the IFS share were also running very slow.  I corrected the issue by Stopping the iSeries Netserver service using iSeries Navigator (Network/Servers/TCP/IP)  Once the service was stopped I then used the Reset and Start option (right-click on the service).  I then tested sending my 500mb file.  Instead of getting 1.6mb sec transfer I got a more respectable 60mb sec.

0
hockeyhalloffameAuthor Commented:
Thank you all for your help.  This is what we did, it has eliminated the sluggish performance reading/writing to the ifs

I changed my LIND on the server to 1G full-Duplex and also change the port speed on my Switch.  Performance has been stellar since this change.  Before this change, the performance on batch jobs, 5250 sessions and ODBC connections was stellar.  The performance after this change is stellar on all fronts.

Before making this change, I have verified that the LIND settings for the link speed matched the speed set on the port the server was connected to.  Both were set at 100M Full Duplex.

I will revert back to 100M Fullduplex on both my LIND and the switch tonight and update this note tomorrow. But for now, changing the link speed to 1G full Duplex on the LIND and the port on the switch resolved all issues.



0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.