Solved

Mail is being sent from the wrong ip address.

Posted on 2009-07-08
10
659 Views
Last Modified: 2012-05-07
We have a new SBS 2008 server that was upgraded from SBS 2003.  There are two IP addresses on the server 10.0.0.5 and 10.0.0.7.  We are using 1 to 1 Nat on the firewall. There is a NAT rule in place to route the traffic from x.x.x.158 to 10.0.0.5.    The IP address of the WAN port on the firewall is x.x.x.154.

The issue is that before the upgrade all mail was going out on x.x.x.158.  Now all mail is coming from x.x.x.154 and there for the PTR look-up is failing.  My guess is that the mail is being sent from the 10.0.0.7 address and not the 10.0.0.5 address.  

I have tried:

Set-SendConnector "MySendConnector" -SourceIPAddress "10.0.0.5"

but that didn't do it.    

Is there anyway to specify what IP address mail is going out on?

Any Ideas??
0
Comment
Question by:CommonSenseSolutions
  • 5
  • 4
10 Comments
 
LVL 23

Expert Comment

by:rhandels
Comment Utility
Hey,

Normally the NIC that is being used for sending the mail is the one that is in top prio in the networking part.. I don;t have a 2008 here but can show you were to look.. Also, may i point out that having a mulktihomed DC or Exchange server isn;t really best practice??

1. Click Network in Start.
2. Select Network and Sharing center.
3. Select Manage Network Connections.
4. Press Alt key. The The Advanced menu display on the top.
5. Click Advanced and then Advanced Settings.

Make sure that the nic with the ip address you would like to use for sending e-mail is the firest NIC Microsoft uses to connect to the network.

Also, you can do a route print within a dos box to see which NIC has the lowest metric. Make sure that the one ytou would like to send the e-mails with has the lowest metric..
0
 

Author Comment

by:CommonSenseSolutions
Comment Utility
I neglected to mention that IP addresses are assigned to the same NIC.   The server is not multi-homed. The other IP is being used for internal FTP.
0
 
LVL 23

Expert Comment

by:rhandels
Comment Utility
Ok then... What is the primary ip address you added to the machine?? Is it the one that needs to send out the mails or the one that is serving as the FTP server?? You set up the FTP server using IIS?? And made sure that it is set to this specific ip address rather than to the one you need to send the e-mails with??

What did the route print say, i'm mostly interested in the default gateway setting, this is the first line in your route table..
0
 

Author Comment

by:CommonSenseSolutions
Comment Utility
The primary ip of the machine should be  10.0.0.5  and that is the one that mail should go out on.  The FTP is setup in IIS  and is using the 10.0.0.7 ip address.

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       10.0.0.1       10.0.0.5     15
          0.0.0.0          0.0.0.0       10.0.0.1      10.0.0.42      5
       10.0.0.0    255.255.255.0         On-link        10.0.0.5    266
       10.0.0.0    255.255.255.0         On-link       10.0.0.42    261
       10.0.0.5  255.255.255.255         On-link        10.0.0.5    266
       10.0.0.7  255.255.255.255         On-link        10.0.0.5    266
      10.0.0.42  255.255.255.255         On-link       10.0.0.42    261
     10.0.0.255  255.255.255.255         On-link        10.0.0.5    266
     10.0.0.255  255.255.255.255         On-link       10.0.0.42    261
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link       10.0.0.42    261
        224.0.0.0        240.0.0.0         On-link        10.0.0.5    266
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link       10.0.0.42    261
  255.255.255.255  255.255.255.255         On-link        10.0.0.5    266
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
          0.0.0.0          0.0.0.0       10.0.0.1       5
0
 
LVL 23

Accepted Solution

by:
rhandels earned 250 total points
Comment Utility
Euhm, something seems to be wrong with what you are telling me.. As i can see the routing table you have 2 ip addresses, 1 being 10.0.0.5 and the other one being 10.0.0.42.. For as far as i can see now the 10.0.0.42 address will be used to send anytrhing out of the server, because it's Metric is lowest.. The 10.0.0.5 address will only be used when the 10.0.0.42 address in not working..

I would try to find out were that .42 address is coming from.. Cause this address is casuing the isseus..
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 4

Expert Comment

by:reubstr
Comment Utility
I would also be looking at you firewall device. Make sure it has the right pointer and SPF records and see if there are any settings to configure any static routes. From this IP to This IP.
0
 

Author Comment

by:CommonSenseSolutions
Comment Utility
I totally missed that.  The 10.0.0.42 address for the Virtual Server.  I guess that because it was a virtual server I didn't think it would be a factor.
0
 

Author Comment

by:CommonSenseSolutions
Comment Utility
I changed the routing metric in the table and that fixed the issue.
0
 
LVL 23

Expert Comment

by:rhandels
Comment Utility
Prefect, so now your able to send the e-mails??

If so, nice to know it works :) Please accept one of the answers if it did help you out with resolving this :)
0
 

Author Closing Comment

by:CommonSenseSolutions
Comment Utility
That was it I changed the metric to higher number and emails went out on the correct IP.   Thank you very much for all of your help rhandels.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now