Certificate problem

I have a working Exchange 2007 system here in the States. I build a new Ex2k7 system in Europe and imported a wildcard cert. When my users log on locally, they get a certificate error. Shouldn't a wild card cert cover the server there?
simpson-itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NpatangCommented:
What is the SCP URL set on the CAS box  and what is the domain name mentioned in the cert .. That should match..
YOu can check the INternalUri by running
Get-ClientAccessServer |fl
0
simpson-itAuthor Commented:
Here is my output. The 46 site is my European site. All reference to 29 is my US stie. Only my US site hosts OWA.


accessserveroutput.txt
0
NpatangCommented:
Your Wild card cert should cover this server as well.
Try accessing this URL https://46caht1.simpsonmfg.com/Autodiscover/Autodiscover.xml from the client and see if you are able to browse it or not. You should some kind of CODE (600).
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

simpson-itAuthor Commented:
<?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="20:06:59.7648473" Id="2084522505">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>
0
NpatangCommented:
When you get the CERT error what is the URL it is reffering Also at the same time click on view certificate and see which certificate is showing there.
0
NpatangCommented:
Also check the URL on Virtual directory it hsould match with your SCP value.
For help see the Article http://support.microsoft.com/kb/940726 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
simpson-itAuthor Commented:
Should it match the OWA gateway for the organization then?
0
NpatangCommented:
All your internal URl on the virualdirectory should match to https://46caht1.simpsonmfg.com/ (asper the article) as your SCP value is set to the same FQDN
0
simpson-itAuthor Commented:
Right, but my actual OWA address filters through another server. Does that matter?
0
NpatangCommented:
That must be for etxernal I guess. we just need to change the internal url's.. or I am quite not understanding that ...
0
simpson-itAuthor Commented:
I'm not certain that I quite understand either. I have a CAS/HT server and MB Server in each location. Here in the states, I have a CAS/HT NLB Cluster. All of my external clients access OWA through https://secure.simpsonmfg.com/exchange which routes to 29cahtc (my CAS/HT cluster). I obviously needed a CAHT server in each AD Site, so I added 46caht1. 46caht1 should only be a cas proxy to my 29 site. That being said, I used a wildcard cert for *.simpsonmfg.com for the 46caht1 server ONLY for internal SSL connections to 29cahtc. Does that help to explain the problem at all? Sorry about not spilling all this out originally. :)
0
NpatangCommented:
Thats fine you can try what was suggested earlier.

All your internal URl on the virualdirectory should match to https://46caht1.simpsonmfg.com/ (asper the article) as your SCP value is set to the same FQDN on 46aht server. You can use the article 940726 for further understanding
0
simpson-itAuthor Commented:
Ok, i applied these changes and now when I try to access https://46caht1.simpsonmfg.com/exchange, I get the login screen and then this:

Outlook Web Access is not available. If the problem continues, contact technical support for your organization and tell them the following: There is no Microsoft Exchange Client Access server that has the necessary configuration in the Active Directory site where the mailbox is stored.
0
NpatangCommented:
Did you chnage  any url for OWA Vdir .. of yes we don't have ,, settings the URL as per the article willnot effect OWA
0
simpson-itAuthor Commented:
I changed all three VDirs as described in the article.
0
lastlostlastCommented:
Let me understand the scenario first...

We have 2 sites: US and Europe.
You had an E2k7 CAS,HUB,MBX setup in US site.
You now have setup E2k7 CAS, HUB,MBX in the Europe site.

You then exported the wildcard certificate from the US CAS server to the EUROPE CAS Server.

Now when your users who have Mailbox in the Europe site are connecting with Outlook, they get a certificate error.

Now if you click on the 'View Certificate' option, what certificate shows up?
Also if you run Test Email Auto Configuration, what results does it give. Check the URL's that it returns for OAB, EWS and autodiscover.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.