dashboard commands

I have been able to tunnel x11 securely through using cygwin on more than one platform.  I have been able to do both 'kde start' and 'gnome-session' to connect to those dashboards.  I would like also, to know what the commands are for connecting to other dashboards such as the ones here http://distrowatch.com/dwres.php?resource=major .  In this way, I can better script a menu with those choices.
rtod2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
Like what? kind of works like you describe.
Xming has more visual connect options.
0
rtod2Author Commented:
The only connection to the dashboard I have been able to make using xming has been via xdmcp.  We can't use xdmcp due to security issues.  With cygwin the steps to type are.

1. xinit
2. ssy -Y username@servername
3. gnome-session

This gets you directly into the gnome-session securely, bypassing xdmcp.  This works for any box.  If the box is HPUX or Debian, SUN Solaris, or an off-brand that might use a desktop other than GDM or KDE, I don't know what to type.  If I go through xdmcp then yes, obviously log-in and you are there.  I'd rather avoid xdmcp all together.
0
gheistCommented:
Xming Xlaunch ... start a program ... ssh, xsession
Thats it.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

gheistCommented:
Xming Xlaunch ... start a program ... ssh, xsession
Thats it.
0
rtod2Author Commented:
gheist,  Thanks for your help.  The steps I took are as follows using xming per your suggestion:
  • install xming again
  • xlaunch.exe
  • multi-window
  • start a program
    • xsession
    • using ssh
    • servername
    • username
  • point to ssh.exe contained within xlaunch install path
I get a blip of a black window and nothing after that.

0
rtod2Author Commented:
gheist,  Thanks for your help.  The steps I took are as follows using xming per your suggestion:
  • install xming again
  • xlaunch.exe
  • multi-window
  • start a program
    • xsession
    • using ssh
    • servername
    • username
  • point to ssh.exe contained within xlaunch install path
I get a blip of a black window and nothing after that.

0
gheistCommented:
So - X11 forwarding is not enabled in your SSH server.
0
rtod2Author Commented:
I can do it from cygwin via ssh per the commands above.  Would I be able to if x11 forwarding wasn't enabled?  The box I was trying to reach is a CentOS 5 with GDM.
0
gheistCommented:
Xming X server does not accept unauthenticated connections by default.
cygwin is very insecure in this part.

edit /etc/ssh/sshd_config to enable and /etc/init.d/sshd restart to enable
0
Kerem ERSOYPresidentCommented:
@RTOD: Since you've successfully tunneling now it is the time to close the old question about it ;-)

Then please note that you are :
- Connecting the remote system.
- Executing the command to start a display manager over the remote system.
- Your SSH setup only tunnels it to your local PC. So it is merely responsible to transfer with the server sends it on your screen.

As you see what command you will use on HP-UX or AIX depends on what is available on the target system.

But as a rule of thumb most commercially available systems use CDE as X desktop. On these systems you generally start with dtlogin. Commands like startx and xinit might help depending on the X manager installed.

So the answer is there are no defined X managers for all systems. It depends on the Vendor, Brand, Model, Version etc.

Cheers,
K.
 

0
rtod2Author Commented:
I've not been able to get this to work.  So to re-clarify...
I am trying to follow the recomendations of gheist.  Since I ran out of time on this project, it had to be put on hold.  I'm sorry for not closing it.  I can close it now and re-open but have tried so many others suggestions with no luck.  Gheist seems to be on to something and I would prefer to follow this some more.  Again, please accept my appologies on this for not closing the question.
I am now trying to connect to Suse 11 Enterprise Server to see if I would get the same error there on a fresh install and that has been confirmed.  On Suse 11, I am getting the same blip of black that I was getting in the sixth (6th) post above (#24824570).  The suggestion to enable x11 forwarding and I am not sure how to do that within the Suse 11 platform?
The path I am following within the xming program is:
1. xlaunch.exe  
2. multi-window  
3. start a program  
4. xsession  using ssh  servername  username
5. point to ssh.exe contained within xlaunch install path
This is where I get the blip of black, and window dissapears.

Thanks again Gheist, for any additional attention you can give to this.


 
0
Kerem ERSOYPresidentCommented:
@rtod2:

> I am trying to follow the recomendations of gheist.  Since I ran out of time on this project, it had to be
> put on hold.  I'm sorry for not closing it.  I can close it now and re-open but have tried so many others > suggestions with no luck.  Gheist seems to be on to something and I would prefer to follow this some > more.  Again, please accept my appologies on this for not closing the question.

No problem just take your time. It was just a reminder.

> 2. multi-window  

Remember this behaviour from the old question ? It had caused many windows without a desktop? This is the same thing.

Anyway if this does not work for you '1ll be waiting to help you with CygWin.

Cheers,
K.
0
rtod2Author Commented:
Fantastic kereme.  I really appreciate it.  Xming is more "portalizable".  With cygwin, it works but the errors are really ugly.  I sure hope I can get Xlaunch to do it.
0
Kerem ERSOYPresidentCommented:
Yeah Xming seems easier at first but since it is somehow a limited implementation there can be future constraints. I hope it works for you though. I'll be trying to help you here too.


Cheers,
K.
0
rtod2Author Commented:
How do I enable x11 forwarding in Suse 11 w/GDM ?
0
Kerem ERSOYPresidentCommented:
Same way as you did with other X systems.
- Launch your X server
- ssh -Y user@host

This is it.

Cheers,
K.
0
rtod2Author Commented:
The path I am following within the xming program is:
1. xlaunch.exe  
2. multi-window  
3. start a program  
4. xsession  using ssh  servername  username
5. point to ssh.exe contained within xlaunch install path

This is where I get the blip of black, and window dissapears.  I've been told that X11 forwarding needs to be enabled and to add
X11Forwarding yes
X11DisplayOffset 10
to the /etc/sshd_config file

I've done that and it isn't working.
0
gheistCommented:
.. sshd_config change must be followed by "/etc/init.d/sshd restart"
0
Kerem ERSOYPresidentCommented:
> This is where I get the blip of black, and window dissapears.  I've been told that X11 forwarding needs
> to be enabled and to add
> X11Forwarding yes
> X11DisplayOffset 10
> to the /etc/sshd_config file

This will enable the X11 forwarding. But it won't be active if not explicitly requested by the ssh client. So your step 4 should involve the Y switch.

Cheers,
K.
0
Kerem ERSOYPresidentCommented:
You might as well modify your ssh_config at the Xming side

ForwardAgent yes
ForwardX11 yes

Adding these parameters will do.
0
rtod2Author Commented:
This is a difficult question to close because much help was given.   I have a solution on the xming side of things here http://www.experts-exchange.com/OS/Linux/Distributions/SuSE/Q_24625912.html
0
Kerem ERSOYPresidentCommented:
Yep but you just did the same thing that was suggested here in a different way.

I was suggesting you to use the local SSH which would work at the local Xterm. But your solution is to launch a remote xterm and run ssh -Y in it.

You can use either:
- You can use PuTTY and create connection and enable X11 forwarding.
- You activate your Xming
- Then start xterm in PuTTY sessin then it will display in Xming.
- You can SSH in Xming Dislayed Xterm session now.

Or

- You launch Xming
- Get external program ssh over Xterm
- Start SSH there.


What both solutions in common are:
- You're launching an X Server locally
- Then you use X Display redirection using SSH
- Then launching ss port redirection in the remote displayed xterm session.

So though implemented differently they are actually doing the very same thing.

Cheers,
K.
0
Kerem ERSOYPresidentCommented:
Yep but you just did the same thing that was suggested here in a different way.

I was suggesting you to use the local SSH which would work at the local Xterm. But your solution is to launch a remote xterm and run ssh -Y in it.

You can use either:
- You can use PuTTY and create connection and enable X11 forwarding.
- You activate your Xming
- Then start xterm in PuTTY sessin then it will display in Xming.
- You can SSH in Xming Dislayed Xterm session now.

Or

- You launch Xming
- Get external program ssh over Xterm
- Start SSH there.


What both solutions in common are:
- You're launching an X Server locally
- Then you use X Display redirection using SSH
- Then launching ss port redirection in the remote displayed xterm session.

So though implemented differently they are actually doing the very same thing.

Cheers,
K.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kerem ERSOYPresidentCommented:
Also let me remind you that the question has been started as a different one. But then it was gone another direction.

May be we the experts should have warned you and suggest you to close this question first. in the end we're here.

Cheers,
K.
0
Kerem ERSOYPresidentCommented:
It was nice to work with you :) your lasting sense of humor and using a nice rich English made it real fun. Take care.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.