Solved

2003 server, static IP issue

Posted on 2009-07-08
9
180 Views
Last Modified: 2012-05-07
I have a win2003 server, member server in a domain, 2 network cards, and i want to set them on static IP. I can do that, but as soon as I go back into the settings it looks like it is on DHCP.
If I do ipconfig looks ok but rebooting sometimes makes it lose the static I gave it and that is a pain. I setup the server few months back and had no issues, I don't know what caused this problem now.
I haven't seen a windows server not keeping the IP settings before, not sure what to do??

Thank you,
Dan
0
Comment
Question by:jeffbourassa
  • 6
  • 3
9 Comments
 
LVL 1

Expert Comment

by:fastrad
ID: 24812492
What IPs are you trying to use for the NICs?  Are they bridged?  Why do you want 2 enabled nics in member server?  How many networks will this server be on?  What changed?
0
 

Author Comment

by:jeffbourassa
ID: 24814451
One NIC goes to the LAN and the other NIC to a SAN that is located in a sepparate network where there is no DHCP server.
It used to be static on SAN NIC and dynamic on LAN
Any change I do there
....if I put SAN NIC on static and go back into the settings it shows as if it is on dhcp
....if I put LAN NIC on static...the same
it simply doesn't keep the settings...although if I do a ipconfig/all it shows the addresses corectly...until I reboot and I lose connectivity

Not sure where to start .... I would avoid reinstalling from scratch if possible
0
 

Author Comment

by:jeffbourassa
ID: 24814480
...and it worked just fine until ercently (I am certain), I don't know exactly when this problem appeared, I noticed it as I wanted to change the IP on the SAN NIC
0
 
LVL 1

Expert Comment

by:fastrad
ID: 24820159
This is a strange result to have IP addresses not stick when looking at the windows GUI.  

Just for the sake of troubleshooting run through these steps:
1. Disable SAN nic in control panel/network connections
2. Assign or make sure the LAN nic is showing and holding the correct IP (eg. 192.168.0.10)
3. Make sure clients comm with server and server comm with clients and internet.

If that works then you can troubleshoot the SAN nic and SAN connectivity.

I would like to know how you are using your SAN.  You must be creating the shares on the server and connecting your clients to the SAN via the server shares, true or false?

If that is how you are sharing the SAN disks then try to use a different network for the SAN nic.  (eg. 192.168.1.10)

Make sure the nic on the SAN device is using something like 192.168.1.11.

Also something I just though about that isn't so important; are you using a switch for the SAN or cross over cable?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Author Comment

by:jeffbourassa
ID: 24823730
This is a strange result to have IP addresses not stick when looking at the windows GUI.  
---YES, it is strange

Just for the sake of troubleshooting run through these steps:
1. Disable SAN nic in control panel/network connections
2. Assign or make sure the LAN nic is showing and holding the correct IP (eg. 192.168.0.10)
3. Make sure clients comm with server and server comm with clients and internet.

If that works then you can troubleshoot the SAN nic and SAN connectivity.

I would like to know how you are using your SAN.  You must be creating the shares on the server and connecting your clients to the SAN via the server shares, true or false?
--- The SAN is iSCSI, completely different network and different netwrok address. The server has DISKS from the SAN and exopeses those disks to clients (by sharing folders on those disks)

If that is how you are sharing the SAN disks then try to use a different network for the SAN nic.  (eg. 192.168.1.10)
---The network address is completely different, of course

Make sure the nic on the SAN device is using something like 192.168.1.11.

Also something I just though about that isn't so important; are you using a switch for the SAN or cross over cable?
--- YES, I have a swithch as several servers are connected the same way to the SAN as this one
0
 

Author Comment

by:jeffbourassa
ID: 24824168
1- disabled the SAN NIC
2- setup LAN NIC on static
3- ipconfig/all shows it correctly (on static)
4- went back into LAN NIC settings (shows like dynamic!!!!!)
0
 

Author Comment

by:jeffbourassa
ID: 24824195
5- enabled SAN NIC (that used to be on static before disabling according to ipconfig but not to GUI)
6- ipconfig shows SAN NIC 169.x.x.x address
7- went into settings, put it on manual
8- ipconfig looks right and I have SAN conenctivity
9- went into SAN NIC settings and it shows like on dynamic
0
 

Accepted Solution

by:
jeffbourassa earned 0 total points
ID: 24849977
???
0
 
LVL 1

Expert Comment

by:fastrad
ID: 24850450
Do they act like dynamic addresses?  If you ping the LAN nic from workstation do you get a response?  At what point does the ipconfig /all command show the default address 169.254.x.x?

Have you tried reinstalling NIC from device manager and/or reinstalling network protocols and services from the server?
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Article by: rfc1180
The Maximum Segment size (MSS) is an important consideration when troubleshooting connectivity via the Internet/Intranet. As the packets are routed via the Internet/Intranet, the packets must traverse through multiple routers in the path between two…
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now