Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 367
  • Last Modified:

Can not ping an internal ip address

Have a computer running xp pro sp3. The rest of the network is fine. This computer can browse to other file shares on the network and can browse the internet just. No connectivity issues from this one to others. Can no ping this one from others. Can not browse to it.
It has a static address and the DNS is all correct.
I get the error  "\\name is not accessible. You mihgt not have permissions to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found.

I have verified that remote access is allowed and that all domain users are allowed to connect.
There is no firewall running.
0
rtlaw
Asked:
rtlaw
1 Solution
 
Andres PeralesCommented:
can you ping the machine using it's FQDN? example:  machinename.mydomain.com
 
0
 
Kyle AbrahamsSenior .Net DeveloperCommented:
no firewall running on the internal machine, but what about between the PCs themselves?

Confirming you can't ping the static IP from another machine?
0
 
Adam RayCommented:
You mentioned that no firewall is running on the computer.  I assume this means you have not installed any third party firewalls, but have you also checked to verify that built-in Windows Firewall is turned off and/or has the service disabled?

Also make sure there is no TCP/IP filters that may be dropping the desired connections and make sure the adapter is bound to the "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks":

Control Panel --> Network Connections --> Right click your [Ethernet Adapter] --> Properties

Ensure that "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks" are both installed and enabled (have a check mark)

Click on "Internet Protocol (TCP/IP) --> Click Properties --> "Advanced" --> "Options" Tab --> Click "Properties"

Ensure TCP/IP Filtering is disabled (no check mark) or that it is set to "Permit All" TCP Ports, UDP Ports, and IP Protocols if you have filtering enabled for another reason.
0
 
rtlawAuthor Commented:
I can not ping the FQDN.
They are on a switched network.
Can not ping the static from another box.
No TCP/IP filtering is on.
Ethernet Adapter is correctly configured.
NetBIOS is enabled. WINS server is correct.

Just found out that some one installed SP3 the other day and then it broke.
0
 
Adam RayCommented:
The simplest thing to do would be to uninstall SP3 and see if the problem goes away.  I half remember some problem like this that was related to a particular DLL in SP3--obviously it only affects a small number of computers.

Is this a computer part of a domain?  If so I would assume it's not a problem with the domain's group polices in general as it would likely affect more than one computer.  Though it could be the local security policy, you might try reseting it to defaults (there is a command line utility from Microsoft that will do that.)  It's the shotgun to kill a fly (that you're not even sure is there) approach, but if you've made no intentional modifications to the local security policy it's generally a pretty safe operation--and then the domain controller will over wright the defined parameters on the next gp update.  Note: this is mainly to address the inability to browse the computer from the network, as it's possible it has a separate solution from getting the computer to respond to ping.

If you're more concerned with getting the problem fixed than finding the root cause you can uninstall the network adapter from device manager, shut down the computer, remove the network adapter (or disable it in BIOS), reboot a time or two, then reinstall/re-enable it.  This will reset some of the Windows settings/configurations associated with the adapter.

I've seen malware cause this kind of behavior on some rare occasions, you may try a through malware scan using several different utilities (including hijackthis)  And/or take a look at your Winsock 2 LSP and make sure it is correct. http://www.cexx.org/lspfix.htm  (This is a long shot, I know, just throwing out ideas here.)

From other computers can you resolve the correct IP address via DNS (by using nslookup for example)?  Also be sure that the other computers are resolving the correct MAC address, dump the ARP table using the command "arp -a" from another computer and be sure the affected computer's IP matches up with its MAC address.

What kind of switches/hubs do you have on your network?  Try moving what port the affected computer is connected to to a known good location/route.  It's possible to block this type of traffic on some managed switches on a port by port basis.

If you have another 5-port "consumer" switch lying around you might try plugging the affected computer and a working computer together and give them IP (and the proper subnet mask) on a _different_ private range.  (Which these two computers the only devices on the switch.) -- Just trying to isolate for certain where the problem lies.

Are there any suspicious errors in the event logs of either the broken computer or a different computer trying to access it?
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now