Trying to configure Moodle with MS SQL 2005 (screenshot attached)

Can someone please take a look at the below. I got this working ok with MS SQL 2008 but now I am trying to setup using MS SQL 2005 and no luck.

Can someone please take a look at the screenshots to see what I am doing wrong.

thanks
screenshot1.jpg
screensot2.jpg
LVL 1
jtiernan2008Asked:
Who is Participating?
 
jtiernan2008Connect With a Mentor Author Commented:
no solution
0
 
St3veMaxCommented:
In Management Studio Express, Expand Databases, Expand Security and add the account running Moodle in at that level.

HTH
0
 
jtiernan2008Author Commented:
Thanks a million for the quick response.

However I already done that
screenshot3.jpg
0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
St3veMaxCommented:
No Worries. From what You've said - you've not actually done that...

You've created the SQL User account/password and set it's default database.

You need to expand 'Databases', Expand 'Moodle', Expand 'Security' and then ensure the account in there has 'dbo' permissions to begin with.

Give that a go and see how you get on.

Steve

p.s. off to bed now as 2230 over here and need my beauty sleep! - no doubt another expert will be able to assist should the above not work.
0
 
jtiernan2008Author Commented:
hmmm, ye... I see dbo under users

:(
screenshot4.jpg
0
 
wiljeCommented:
Yes, the user is mapped to the database but what privileges does that user have?  Double-click on the user and check to see whether or not that user is db_owner.  If not, make the user db_owner.
0
 
jtiernan2008Author Commented:
Hi Wilje,

ye, it seems to be alright, see screenshot below.
screenshot5.jpg
0
 
wiljeCommented:
Okay, that user owns the database and appears to have the right privileges.  So, what I would try next is changing the Type option - if there is another type for SQL Server.
You could also try the following for the Host Server:
.\SQLEXPRESS
localhost\SQLEXPRESS
[JUSTIN-PC]\SQLEXPRESS
I am just guessing here.
0
 
jtiernan2008Author Commented:
none work :(
0
 
wiljeCommented:
And the only error you are getting is that you cannot connect?
0
 
wiljeCommented:
Are you logging into SSMS with this account?  Or are you logging in with your Windows account, or sa?
Have you verified that SQL Authentication is enabled?  I know we went through this for the 2008 setup - but thought I would ask anyways.
0
 
St3veMaxCommented:
Try creating an ODBC Connection on the machine with the credentials you created and see if that works.

0
 
jtiernan2008Author Commented:
The strange thing is I have MS SQL 2005 and 2008 installed. 2008 says that the database is located in Justin-PC as opposed to Justin-PC/SQLEXPRESS in 2005 and when I enter this, it works fine. I have tried looking at the database securuty properites side by side and cannot see anything.
0
 
St3veMaxCommented:
Try [Justin-PC\SQLExpress]

I would also check that Moodle supports SQL Instances.
0
 
jtiernan2008Author Commented:
nope....

It does support SQL instances as it works fine with MS SQL 2008
0
All Courses

From novice to tech pro — start learning today.