• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2188
  • Last Modified:

Asterisk / FreePBX + FollowMe

Maybe some Asterisk experts can help me out here.

I am running an AsteriskNow v1.5.0 box which has FreePBX on it. Everything configured on the server is fairly simple and straightforward. There's an IVR, and a few extensions. My outbound route goes through an IAX2 trunk provided by my Voip service provider.

Now the tricky part. I setup a custom extension in /etc/asterisk/extensions_custom.conf. My IVR has a menu item that goes to that custom extension. The custom extension does some processing, plays some messages, then it DIALS extension SIP/7300. All of that works fine.

I setup FollowMe on ext 7300 using the FreePBX web administration panel. When I dial extension 7300 directly from a softphone like X-lite, it will also cause ext 7301 and 7302 to ring simultaneously. And, an outbound route to my cell phone rings as well.

The problem is the custom extension I setup. It still dials SIP/7300. When I go through the IVR menu only extension 7300 rings, and none of the others. The followme is NOT performed.

What can I do in my extensions_custom.conf so that I can execute the FollowMe for extension 7300? So that all the phones ring like I expect them to?

Attached is my extensions_custom.conf, if anybody cares:
# Extension picks up the line
exten => 2000,1,Answer
exten => 2000,n,Playback(custom/please_wait_for_assistant)
# Do some pre-processing
exten => 2000,n,AGI(KCS-callin1|param1|param2)
# Turn on call recording
exten => 2000,n,MixMonitor(/record/calls/call${NEWPBXCALLID}.wav|b)
# Transfer call to ext 7300
exten => 2000,n,Set(CALLERID(num)=${CALLERID(num)})
exten => 2000,n,Set(CALLERID(name)=${CALLERID(name)}-${NEWPBXCALLID})
exten => 2000,n,Dial(SIP/7300,30,rig)
# Behavior depending on if transfer was successful or not
exten => 2000,n,GotoIf($["${DIALSTATUS}" = "ANSWER"]?finished:failed)
exten => 2000,n(failed),Goto(kcs-callback-ask,6001,1)
exten => 2000,n(finished),AGI(KCS-callout|${NEWPBXCALLID}|param2)
exten => 2000,n,Playback(custom/thank_you_for_using_us)
exten => 2000,n,Playback(custom/you_can_callback_anytime)
exten => 2000,n,Playback(custom/goodbye)
exten => 2000,n,Hangup

Open in new window

1 Solution
Frosty555Author Commented:
The trick was to not use FollowMe, instead use ringgroups.

I added the "Ring Groups" module to FreePBX. Then set up a ringgroup named "600" which dialed everyone I needed to dial.

Then in my custom extension I could dial it like this:

exten => 2000,n,Dial(Local/600@ext-group)

The "ext-group" is the name of the context that the ring group resided in. It's a bit of a hack, probably not a good idea to refer to contexts that were autogenerated, but it works.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now