Remote Desktop won't connect on second IP address

Have a second IP address on NIC card that we use for a specific application on the server.  After a server reboot, we can still RDP into the first IP address, but the second one no longer works.  Have tried  <telnet IP Address 3389> and get no connection.  The error message says "This computer can't connect to the remote computer."  Can ping the second IP address with no problem.  Running <netstat -an> shows the first ip address listening to RDP port 3389, but not the second one.  Is there a way to get the second ip address working with RDP again?
LVL 4
rstorm1Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ahmad2121Connect With a Mentor Commented:
ok something changed your connection then.

go to Administrative Tools > Terminal Services Configuration > Connections > Right click on the connection > Properties > Network adapters > All network adapters

If that doesn't work, delete it and create a new one.
0
 
ahmad2121Commented:
its a mistake in the first place that RDP is only listening on that one IP.

did you restart the computer after you added that IP?

or you could disable remote desktop and enable it again (computer > properties > remote)
0
 
rstorm1Author Commented:
I have tried both restarting and disabling/re-enabling remote desktop with no effect.
0
 
rstorm1Author Commented:
There were actually 2 connections in the Connections window.  Had to delete them both and recreate the RDP-TCP connection.  I deleted them both, rebooted the server, then recreated the connection and rebooted again.  That seems to have it back up and working.  Thanks for your help!
0
All Courses

From novice to tech pro — start learning today.