Solved

Problem Configuring Sun one HTTP Server with IBM Application Server for Load Balancing

Posted on 2009-07-09
4
661 Views
Last Modified: 2013-12-11
Target: Load Balancing of IBM Application servers with Sun one Web server

Scenario: I had two machines MachineA and MachineB. I have installed IBM WebSphere Deployement Manager and Application server on MachineA and installed another Application server and Sun one web server on MachineB.

I am trying to form a cluster with these two application servers and configure it to Sun one web server. (i am done with creation of cluster and facing problem with configuring it with Sun one Web Server)

Things Done for Creation of the cluster:
i created two (managed)nodes for two application server in Deployment manager admin console, after that created one cluster and added these two nodes under that cluster.

Deployment :
now i deployed one .ear file in Install new application menu.

Post Deployment :
Now, as i installed Sun one web server on MachineB i have installed IBM Http Plugins on Machine B by selecting Sun one web server(considering the remote option and have provided MachineA as hostname for Application server and the http port is 80 )

After installation of Sun one web server :
i have created one (unmanaged)node for the addition of sunone http server
after that i have added this webserver under webservers option which is under servers menu in Deployement manager Admin console.

After Webserver got added under webservers option:
went to installed application (where i have deployed the .ear file) and clicked on the installed application and clicked on manage modules and said apply by selecting all the available nodes.

Now, i am able to generate the plug-in by checking the webserver1 under webservers and clicked on generate-plig-in. But, it is not doing anything when i clicked on propagate plug-in.

now, when i tried to open the application using the http server link it is not able to open it.

So, Please let me know how to configure this sun one server with IBM application servers so that i can achive load balancing of two app servers
0
Comment
Question by:siddamreddy
  • 2
4 Comments
 

Author Comment

by:siddamreddy
ID: 24812572
Its very urgent for me. Can any one help me in resolving the issue.
Please let me know if you guys need any further information.

thanks
Siddamreddy
0
 
LVL 57

Expert Comment

by:giltjr
ID: 24819939
Does IBM document that their plug-in will work in the Sun One server?  I know that is written to run under IBM's HTTP server, which is really Apache and so it will work under Apache.
0
 
LVL 4

Accepted Solution

by:
dipinci earned 250 total points
ID: 24833997
For a remote Web server installation  the Web server plug-in configuration service propagates the plugin-cfg.xml file automatically for IBM HTTP Server only.

For all other Web servers, propagate the plug-in configuration file manually. Copy the plugin-cfg.xml file from the profile_root/ config/ cells/ cell_name/ nodes/ web_server_name_node/ servers/ web_server_name directory on Application Server. Paste the file into the plugins_root/ config/ web_server_name directory on WebServer Plugin.

In your case please check any configuration is updated on the magnus.conf and obj.conf files with the Plugin file location and check the plugin logs to see it has loaded properly with the WebServer.

Also Please provide the version of WebSphere Application Server/Sun one webserver and operating system
0
 

Author Closing Comment

by:siddamreddy
ID: 31601500
Thanks alot dipinci.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange 2010 email being lost to one external domain 7 44
Office 365 Migration and MX entry 7 71
Sending mail to invalid recipient address 7 60
Zimbra opensource backup 10 43
Nearly six years ago I was hired by a company to be their senior server engineer. One of my first projects was to implement Exchange Server 2007 on a Windows Server 2008 Single Copy Cluster for high availability. That was the easy part; read on to l…
Resolve DNS query failed errors for Exchange
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now