Manual installation of PHP

I have read the instructions in the PHP manual to set up php manually.
There are many problems:

First when i download the zip file, the extracted contents does not contain php5isapi.dll file which needs to be added in the ISAPI extension filters.

Second  I am stuck up in the following line in manual:

PHP may be installed as a CGI binary, or with the ISAPI module. In either case, you need to start the Microsoft Management Console (may appear as 'Internet Services Manager', either in your Windows NT 4.0 Option Pack branch or the Control Panel=>Administrative Tools under Windows 2000/XP). Then right click on your Web server node (this will most probably appear as 'Default Web Server'), and select 'Properties'.

I think I need to right click IIS and then Properties. Am I right? or something else?

Last when I click on HomeDirectory and then click on Configuration and then click on Add to Add/Edit Application Extension Mapping and then select the php5isapi.dll file and fill up the extension as .php,
Then the OK button is disabled and I cannot proceed.

Please help.
LVL 2
puneetdudejaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BrianMMCommented:
The other issue you will face is gettiong MySQL working...

I reccomend this guide ... http://www.artfulsoftware.com/php_mysql_win.html
0
BrianMMCommented:
Oh.. only one error in that guide... php.ini wants to be copied into C:\Windows - REMEMBER THAT!!!!! - if installing php manually.
0
puneetdudejaAuthor Commented:
BrianMM: You are wrong. We can put php.ini file anywhere as said by the following line in the manual:
PHP searches for php.ini in the locations described in The configuration file section. Read the link <The Configuration File> in the manual.
0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

puneetdudejaAuthor Commented:
BrianMM: And I am not talking about other issues. First I want these issues to get solved.
0
Beverley PortlockCommented:
The simplest way to quickly and suiccessfully install PHP is to use either WAMP or XAMP

http://www.apachefriends.org/en/xampp.html

or

http://www.wampserver.com/en/download.php

In general, accept the defaults and it takes about 2 minutes.
0
Beverley PortlockCommented:
I should point out (since you mention IIS) that after installing Apache via either of these two, if you move Apache to listen on port 81 then IIS can still use port 80
0
BrianMMCommented:
@bportlock he is'nt lookign for that, he's wanting to tell IIS to use php... so he's (probably) done the rest.

@puneetdudeja, if you read through the link i posted anyway, you will find it has step-by-step guide on IIS 4, 5, 6 and 7.. so I know your answer is in there as I am using IIS and PHP installed with the aid of this.

Any problems finding what you need in the guide, give a shout.
0
Beverley PortlockCommented:
"...he's wanting to tell IIS to use php"

OK - I misunderstood the post. Thanks.
0
puneetdudejaAuthor Commented:
Nobody is reading the problems I have written.
Ok, atleast please help me solve the following issue:

When I right click on DefaultWebSite and then on Properties and then
click on "HomeDirectory Tab" and then click on "Configuration Button" and then click on "Add" to Add/Edit Application Extension Mapping and then select the php5isapi.dll file and fill up the extension as .php,
Then the OK button is disabled and I cannot proceed.
0
gr8gonzoConsultantCommented:
1. What version of Windows / IIS are you running?

2. Can you take a screenshot of the "Add/Edit Application Extension Mapping" popup where you're seeing the problem?

Normally, the OK button is enabled as long as there is something in the Executable field, so if it's not enabling at all, then there's something else missing.

Also, are you on any sort of network domain that might have group policies enabled, and are you logging in as an administrator on that computer?
0
gr8gonzoConsultantCommented:
Also, this is a really old hack so it probably won't work, but after you select the executable, try clicking inside the Executable textbox itself and see if the OK button enables at that point.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
puneetdudejaAuthor Commented:
gr8gonzo:

I have Windows XP SP2 and IIS 5.1 and I am installing PHP 5.3.0
Also I am not logging as an administrator and also on a network domain but don't know whether group policies are enabled.
0
gr8gonzoConsultantCommented:
In that case, there's a chance that the hack I mentioned might work. I believe it applied to IIS on XP machines.
0
puneetdudejaAuthor Commented:
I am at home right now. I will try that hack tomorrow and come back if I have any problem. Thanks for your help.
0
puneetdudejaAuthor Commented:
gr8gonzo:

Your hack has worked for me absolutely fine.
But I have other problems if you could please help me.

They are saying in the manual that the PHP ZIP package for php 5.3.0 you download contains the following files which are required for installing:

php5isapi.dll
php.ini-dist
php.ini-recommended

But I don't have these files in the zip package I download.
Instead I have these:
php5nsapi.dll
php.ini-development
php.ini-production

Can I download these the previous files separately from net? Will it work?
0
puneetdudejaAuthor Commented:
I have downloaded php5isapi.dll separately and have used php.ini-development as php.ini and performed the other steps in the manual.

I stopped the IIS by using:
net stop iisadmin

But when I start the IIS again by using:
net start w3svc

I get an error which is shown in the attached screenshot:
Screenshot.JPG
0
gr8gonzoConsultantCommented:
It's usually not a good idea to try to download pieces of PHP and use them together with an existing installation. You can never be sure how the other piece was compiled.

I'm not quite sure how much 5.3.0 has changed, but for now, I'm just using PHP 5.2.x - it should come complete with the php5isapi.dll file. Delete (or archive) the 5.3.x version you have and download 5.2.x and use that instead.
0
puneetdudejaAuthor Commented:
g8gonzo:

Yes, You are right.
Php 5.2.x package is complete on www.php.net, but 5.3.x is not, its missing the files listed in the manual.

Php 5.2.x is successfully installed on my PC.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.