Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

What are these Characthers I am getting from my com1 serial port??

Posted on 2009-07-09
14
Medium Priority
?
247 Views
Last Modified: 2012-05-07
I do have a machine which has a communication port the communication protocol is RS422.I did connect to the machine through my Laptop's serial port using a MOXA RS422 to RS232 converter.I did download a few software from various locations which are basically all just com 1 port monitors.All good so far.They all work so I am getting data.
My problem is that the data I get looks very strange to me I'll give you an example:

" .¬.ÿ@....h?....%e_... Ô÷?B....9....."x.....ð?....âÂ....Â÷..îpÿ..dú..@º®...¬B.......¬... ..@....@`.ِ..&..LLÄÀ.`.0...`°Ð<¬ÀÐÀ.........@Ì.ûÐÐÐÀ@·Ý·¬ÞÍ6Ú°9Èmh>.
.X\p.`p..a,.<
..°~9...4’....`...9’
!..9Ãó’`EÍ Ì! Îþ¬ð@¬.Ã>pP.........¬¬..@.....@..IH.É...ÈADÁ...80.
7¬ÀÀ.....¶...ÐÀØÛÙÚÚ-.Ü.,.¡|
.\x.&...9’.`E.}!Ï<ÃÃÃç±Âà ·3ëÇa·ÿ.ð ¬.<>.........¬........Æ...I..¬".hD..Üd.,0.À`°Ü`` ....¶.¬Øh´.¬.¸ì6°ØØ.lh.
6.p’, .&
&.9.’..ÃÃE!!ÁÅáÇÃÃÍ£ÅáF#Åó¬ð¬¬.x?...............@.@@@ 0.II..".3`À`A`..(..hHà$........Æ.ÐÈl²à3ûºz;,ìxZX.....
 .4...&.Å `L!Ì.ø ¬.Â>.........¬.......D..H.$ .".D. @ÆÌb`.h .
hØH6À.......¿ÀÚÐÐ`Ùùþ.ø
l.9`p.,2,.


Å&\!`Ã9.!Å!&.à...p? ..........@..¬......H.IH"...d.DÆ`ÀÆ.0.0ØØÀ-´À......Û...d¬Ü.°ð.a.;Ø.X...`.
°&....!R&.Å.Å Ïe’’ÃÃ×ãc×ãÅcÇÃá.ø@...>...............¬@.@..¬.¬I¬..3..DeÊÆ...H..ØÀ.¬¬à.....¬Ø.@.ÀØÛÙll..X.<,°.`’.>.<
4.,`Å ÇR ÃÃÃÃÃÃÃÃGó×óÿ.ð¬....à.. ....þ.¬..ð.`.........¬.@...@HI..@2..d..¬ÀÆ...@`¸Ø`.А........Ù.`.ØÚÐßßZl..\...,.<0.hÁ..}.`’E ..’xÅ.ˏAÃÇà ǣƬ×ãa Ãÿ.ବ
¬.ÿ...............@@D.....H:0d."À..Ã..,°.h`4À¬....¶..@. ÐÐØh°ÌèvØ.Ø..`.
...`..0’’!.aÅ 9 !×’ÃÃ~}Ç.ãÂc!3£ÍÅaE3iÎãs³ó÷¬ø¬¬.Â.ü`...............@@.....I.¬0.D."ÿø.ÿ....¬.¬¬....¬..¬..IÙ0 ..L.À.....°.l. À¬.....¬.·øùÙÛlhh6Ø.Ø.....]..’.&.’`’9Ã’E÷Å£ÃQÃãËãÅãà káý.ø.¬.<.{,....­.ýà¬. ... ................DƁ.@À0. @dEb0..( .H`0¬àà.......Àh¶ÀØÚØ..mz..
.04r...9...’.’Å }ÇG!Ã.ÃÃÅãÃÃÏ£ÃScaçCAó¬øÀ..fÇ. ............¬...@..¬.H0.d.C. 4.ÐÐà.¬.......·Àn}üÌlrX`.Í.ÿ.....¬........D ........ÌAa"..À@¬à.Û..³À. ÚÚÀh°X.`...à.
8’9’ÃG}R 9.â}·£Ãà ÇCcas&23aóaó"

Which as you can see does't make too much sense to me.I should get numbers separated by a comma I think.I just have no ideea why the machine outputs these characthers and I have no ideea what to do next.Any hint of what my next step should be would be greatly appreciated.
0
Comment
Question by:Latzi_Marian
  • 7
  • 3
  • 2
  • +2
14 Comments
 
LVL 4

Expert Comment

by:blaaze
ID: 24812785
its coz your serial port is overrided by another driver, just uninstall all other drivers for the specific port that you dont want

hope it works

0
 

Author Comment

by:Latzi_Marian
ID: 24812845
Same story.I did uninstall everything which might of gotten hold of the bserial port and tried again.Exactly the same story.
I also tried froma different computer and still getting the above gibberish.
0
 
LVL 2

Expert Comment

by:metableta
ID: 24812903
Maybe you should try adjusting a bitrate of your RS232 port.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Latzi_Marian
ID: 24813129
I've got the port settings from the machine I am connecting myself to.I did adjust the the connection settings in the software I am using.Are you saying to actually adjust the rate of the physical port itself in windows device manager?I 'll try.
0
 

Author Comment

by:Latzi_Marian
ID: 24813148
No luck.The same still.I just don't understand what those ugly looking characters are coming from.Simply don't get it.I know that the machine itself is ok as I saw data collected from the machine with a vb5 application and the application interface was showing the numbers and letters comiung from the machine.Unfortunately I don't have the source code for that program.So I have to figure out a way to get intelligible data from the machine.
0
 
LVL 2

Expert Comment

by:metableta
ID: 24813167
Yes, this is what I mean. Please let us know about effects.
0
 
LVL 2

Expert Comment

by:metableta
ID: 24813204
Converter could be a problem. Did you try it somewhere else?
0
 

Author Comment

by:Latzi_Marian
ID: 24813381
no i didn't try the converter in another situation.I will try it and let you know of the results.unfortunately I must finish for today as it is almost midnight and I am a bit tired.I might miss the obvious.2morrow morning I start again looking into this as this is first priority for me.thanx for now and I'll update
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 24813477
Portmon for Windows
http://technet.microsoft.com/en-us/sysinternals/bb896644.aspx

See if you can get a process name of the app that might be causing this.....


 
0
 
LVL 12

Expert Comment

by:atrevido
ID: 24817579
This is a typical indication of a baud rate mismatch.  What baud rate is the RS422 sending at?  And what did you set your terminal emulator to receive at?  If you don't know for sure the host speed, then play with your emulator speed
0
 

Author Comment

by:Latzi_Marian
ID: 24819658
Guys,

Baud rate the machine sending the data at is 1200.My PC's serial port baud rate is 1200 and the software I am receiving the data with is 1200 as well.Com 1 is not used by anything else and the RS422 to RS232 converter is not faulty as I did try with another brand new converter.I have no other means to try that converter as I have no other machine which "talks" RS422.
So summa summ arum : No idea still what is wrong but the really bad thing is that I am running out of ideas completely.
0
 

Author Comment

by:Latzi_Marian
ID: 24819834
to johnb6767 I did download portmon and run it and the only process using the port is the application I am using to read from the port.So that is good no interference from another application.
0
 
LVL 12

Expert Comment

by:atrevido
ID: 24824351
OK, so for 1200 baud or any baud rate for that matter, there is also stop bits and parity.
A common setting is 1200 baud, 8 bits, None (no parity) and 1 stop bit. -- aka 12008N1
But seriously, are you really sure its 1200?  Try 2400.  Try 12007E2, try them all.  Your characters are extremely indicative of a mismatch, whether that mismatch is parity, stop bits or baud rate.
0
 

Accepted Solution

by:
Latzi_Marian earned 0 total points
ID: 24828442
Hi Gents,

I've got it finaly.It wasn't baud,parity or stop bits but the bloody protocol.The machine electronics schematic said RS422 and ideed I had 5 wires coming from the port.I know that RS232 can have 5 wires as well but it's less likely.Even the printed circuit board was saying port1 RS422.What I didn't realize is that the conversion to RS232 is done on the printed circuit board itself through a specialized CIP which is not the original CIP.So whoever did that forgot to update the drawing or put a label on the circuit board stating RS232.
That's it quite silly I didn't try earlier but as soon as I removed the converter and reconnect the cables to RS232 everything became perfect.Thanks for your help.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When posting a question about a Cisco ASA, Cisco Router or Cisco Switch, it can aid diagnosis if a suitably sanitised copy of the config is provided. It is much better to leave as much of the configuration as original as possible, as it could be tha…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Suggested Courses

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question