Solved

Backup Jobs timing out on Pre/Post command

Posted on 2009-07-09
29
885 Views
Last Modified: 2013-12-01
I have a series of backup jobs that go from server to tpae. They keep failing with an error of "pre/post command timeout". I have the timeout window set for 90 minutes. I'm using qindows 2003 server and backup exec 12.
0
Comment
Question by:mhmservices
  • 15
  • 14
29 Comments
 
LVL 10

Expert Comment

by:Datedman
ID: 24812949
what are the pre/post commands? :)
0
 

Author Comment

by:mhmservices
ID: 24813052
start.cmd and stop.cmd
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24813077
Need to look in those files and see what is holding things up, no?
0
 

Author Comment

by:mhmservices
ID: 24813096
what exactly am i looking for?
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24813212
Well, they are files of commands like .BAT files.  It seems something (likely in the "pre" command, right?) is taking too long to complete.  
If you open the pre file with notepad you will see the commands...can see if there is an echo off and if so put REM in front of it (with space after REM) and then execute the file and see what hangs up?  
0
 

Author Comment

by:mhmservices
ID: 24815423
Here are the contents of the start.cmd file


net start rxrsa /y
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24817597
Right, it's the stop.cmd file that's timing out I think?  That's the pre-command right?

Is this a Continuous Protection Server?  Sounds like this article maybe:
http://seer.entsupport.symantec.com/docs/288626.htm

I think you need to run the series of commands in the pre-command file and see which one times out.  (Then run the post file so you don't leave things stopped ofc.)
0
 

Author Comment

by:mhmservices
ID: 24817728
The contents of the stop.cmd aren't too helpful I'm afraid. It's the same command with stop instead of start.

0
 
LVL 10

Expert Comment

by:Datedman
ID: 24817755
Did you look at that URL?  Is this a CPS server?  If not you can probably just take out the pre- and post-command files from the backup job.
0
 

Author Comment

by:mhmservices
ID: 24817778
Yes, it is a cps server but these jobs are what copies the the files to tape. The cps jobs are fine. I'm looking at the url now.
0
 

Author Comment

by:mhmservices
ID: 24832484
Datedman,


I followed the instructions at the link you provided to create the batch files mentioned. I've allowed 2 nights to test and I'm still getting timeouts.
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24832995
That was not my intent...I pointed you at the link because it looked like those were batch files like you were using.

The idea is this:

**Execute the stop.cmd file manually.  See where it times out!
 (If necessary remove echo off at the top of the file or insert echo on so you can see what's going on.)
0
 

Author Comment

by:mhmservices
ID: 24848694
Looks like it's timing out on RxRSA
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24849417
Are all CPS services patched up to date?
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:mhmservices
ID: 24850829
We are using BUE 12 and 12.5 is out. As far as individual services how would i check?
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24851709
I don't know I haven't implemented CPS but I would update everything to 12.5.
0
 

Author Comment

by:mhmservices
ID: 24852120
That seems like a good idea but given the absolute hell I went through to upgrade from 11 to 12 I would like to see some type of documentation that points to a specific fix.
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24852315
really?  what was tough?  that might have something to do with it...but 12 to 12.5 might not be so bad.  Also, might be worth a call to BE support now that you know what the problem is so they can tell you to upgrade LOL. (actually it's probably a known issue)
0
 

Author Comment

by:mhmservices
ID: 24862677
They ended up having to reinstall all the client BUE items and redo alot of backup jobs. I'm told it was a total mess.

I've been working with symantec support for the last couple days. What we have figured out is that the stop and start command files run if executed by themselves but for some reason won't execute at the time of the backup to tape job. I'm told I've been escalated to advanced support and am waiting on a call back from them.
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24862769
>> Looks like it's timing out on RxRSA

That's not happening anymore?
0
 

Author Comment

by:mhmservices
ID: 24863002
Depends on what context. if I run the stop.cmd file everything runs ok but when the job runs it times out. I don't understand what the difference is. Last nighhts backup job to tape errored out with the pre/post command timeout and the job has a time of 3 hours and 20 minutes.
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24863191
Hmm what else is scheduled then?  You have Exchange?  Sure it's the same STOP.CMD?
0
 

Author Comment

by:mhmservices
ID: 24863358
That is the only job running at the time. We have cps so all of the cps jobs are finished before going to tape so we have the most recent data. It's the same stop.cmd I have verified the path.
0
 

Author Comment

by:mhmservices
ID: 24877927
After working with symantec support I'm past the pre/post command timeout error but now I get a snapshot cleanup error. Any ideas here?
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24877945
Have not seen that one.

Might need to look at why it was such a hassle to upgrade last time?
0
 

Author Comment

by:mhmservices
ID: 24877970
Difficult to do that since nobody who did that upgrade is still with the company.
0
 
LVL 10

Expert Comment

by:Datedman
ID: 24877995
Eek.  What's the exact error?
0
 

Author Comment

by:mhmservices
ID: 24878030
Error category    : System ErrorsError             : e0009413 - An error occurred during the snapshot cleanup, or could not locate a snapped volume from which to back up.
For additional information regarding this error refer to link V-79-57344-37907
0
 
LVL 10

Accepted Solution

by:
Datedman earned 500 total points
ID: 24878235
Take a look at this:
http://www.experts-exchange.com/Storage/Backup_Restore/Backup_Exec/Q_23460446.html
Lots of other info on google if you just punch in V-79-57344-37907
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
Are you looking to recover an email message or a contact you just deleted mistakenly? Or you are searching for a contact that you erased from your MS Outlook ‘Contacts’ folder and now realized that it was important.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now