Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 419
  • Last Modified:

Validation Not working

Ajax validation not working , i have a Couple of validation summary and Bulleted list on my page . These Controls will show me the Validation messages and custom database error messages on the page

These works fine on my Development , once i deployed the code in server the validation fires and message but the custome message which needs to come on Bulleted list dosent show up . ( This happens only if i click a LinkButton on the re4spective page , it works fine if i click the Buttons)

 i have enclosed the code snippet for more information


<asp:UpdatePanel ID="updatePanel" runat="server" UpdateMode="Always" >
	<ContentTemplate >
	        </ContentTemplate> 
        </asp:UpdatePanel>
	
	        <div class="PageHeading"><asp:Label ID="PageHeadingLabel" runat="server" /></div>
	        <br />
	        <table>
		        <tr>
			        <td align="left">
			            <asp:ValidationSummary ID="ValidationSummary1" ValidationGroup="CanBeSaved" runat="server"   />
			            <asp:ValidationSummary ID="ValidationSummary3" ValidationGroup="CanSubmit" runat="server"   />
			            <asp:ValidationSummary ID="ValidationSummary2" runat="server" />
				        <asp:BulletedList ID="bulletedErrorList" runat="server" ForeColor="Red"  />
 
				        <asp:Label ID="lblSuccessMessage" runat="server" CssClass="ValidationSuccess" />
				        <div class="CustomError">
					        <asp:Label ID="lblNoRecords" Text="There are no details to view." runat="server" Visible="false"></asp:Label>
				        </div>
			        </td>
		        </tr>
	        </table>
			<asp:PlaceHolder ID="DynamicControlPlaceHolder" runat="Server"></asp:PlaceHolder>
    
 
</asp:Content>

Open in new window

0
P_Ramprathap
Asked:
P_Ramprathap
  • 3
3 Solutions
 
shahprabalCommented:
asp:Label ID="lblNoRecords" Text="There are no details to view." runat="server" Visible="false">
0
 
shahprabalCommented:
basically you have to specify the id property of the linkbuttons explicitly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now