sp3 failed

Hi Folks,
I had sp3 fail on me today. Apparently I was supposed to pause mirroring and that is why it failed. Everything seems fine coming back up except I have a database now called temp_MS_Agent_signing_Certificate_database and when the instance restarted and also every instance has the error:

The SQL network interface library could not register the service principal name (spn) fo the sql server service (error 0x2098) - I am working in a domain for both client and server.

Do I really need to reinstall the instances?
Who is Participating?
rob_farleyConnect With a Mentor Commented:
I'd say it's your last resort. I would start by removing mirroring completely, and working on getting rid of the error.

http://support.microsoft.com/kb/909801 may help... but I'm not really sure.

Mark WillsTopic AdvisorCommented:
Hi, are you by chance bodhilove ?

Not exactly sure how to fix your error, but have seen quite a bit of commentary around the traps...

Have you seen this : http://blogs.msdn.com/sql_protocols/archive/2005/10/12/479871.aspx bit old, but still shows some insights...

And step 3 in : http://support.microsoft.com/default.aspx?scid=kb;EN-US;319723

sometimes caused by insufficient privileges with your account - according to one "fix" you need SeDebugPrivelege security privilege and run the install again.

Hope some of that helps you...
david_32Author Commented:
yes I am bodhilove have we met on another forum ?
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Mark WillsTopic AdvisorCommented:
Probably :)

And would most definitely listen to Rob_Farley - he is pretty good ya know.

And an all Aussie thread - yay :)
Haha... I've never actually come across this particular error before though.
Mark WillsTopic AdvisorCommented:
Seen it before, but not sure of the fix...

Probably would be best to remove the mirror, and try to get the main server up and running. Check the security, maybe register new spn. Then would check those permissions (including the various folders and file systems per ; http://support.microsoft.com/kb/918357) and try to apply the patch again as a starting point.

david_32Author Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.