Cisco 1805 hwic-cable-modem-d-2 basic configuration for residential cable

Hey folks,
I got my hands on a Cisco 1805 integrated services router with hwic-cable-modem-d-2 that I want to use at my house.

I have some experience with Pix firewalls and basic switch configuration for both IOS and CatOS, so I figured I should be able to get this 1805 up and running but I'm beyond lost when it comes to the configuration on this guy.

I called Comcast and got them to plugin the mac address for the cable-modem, it's pulling down an IP address and I'm able to ping some external stuff from the router console.  I tried configuring one of the fast ethernet interfaces, adding a route and plugging a laptop into FE0/0 but it doesn't appear to be routing.

I've looked at various configuration examples and, like I said...I'm lost.  What's even more confusing is that the cable modem seems to have two seperate mac addresses and I'm not sure how this factors into the config.  If anyone can point me in the right direction to get this thing working, I'd appreciate it.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

miswhoiAuthor Commented:
I tried playing around with that config and I didn't have much luck with it.  It looks like fastethernet 1 provides internet connectivity and fastethernet0 is configured for the lan...that's my best guess.  In my case I think I would want to replace the commands for fastethernet1 with cable-modem0/0/0

it also looks like LAN/FE0 is natting inside and INTERNET/FE1 is natting outside.  I'm not sure I understand the command "ip address dhcp client-id FastEthernet0"  IP address dhcp sets the interface to automatically pull an IP from a dhcp server but what is the client-id fastethernet0 part?  is that something to identify the interface to the DHCP server?

When I plugged in the config however; I used 10.10.255.x in lieu of 192....and I started getting ip address conflict from somewhere...didn't quite understand where this was coming from.

yeah I'm lost.
miswhoiAuthor Commented:
also I wonder if I must assign an "inside" address to the cable modem in order for routing.  Really the information on the hwic-cable-modem is pretty scarce from what I can find.
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

miswhoiAuthor Commented:
there might be some typos in this because I couldn't copy/paste from console so I had to type it out long hand.

As it stands, I'm able to ping the DNS servers from the router, I can ping FastEthernet0/0 from a workstation but I can't traverse the router from the workstation...not sure what I'm missing.

Version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname fubar
enable secret 5 $1sux0r@c15c0
enable password myPassword
no aaa new-model
no ip dhcp use vrf connected
ip dhcp excluded-address
ip dhcp pool LAN
import all
ip cef
no ip domain lookup
ip domain name
ip name-server
no ipv6 cef
multilink bundle-name authenticated
log config
Interface FastEthernet0/1/0
Interface FastEthernet0/1/1
Interface FastEthernet0/1/2
Interface FastEthernet0/1/3
Interface Cable-Modem0/0/0
description Comcast-Link
bandwidth 4500
ip address dhcp
ip access-group 100 in<------I've taken this line out
no ip redirects
no ip unreachables
non ip proxy-arp
ip nat outside
ip virtual-reassembly<-------I've taken this line out also
no cdp enable
arp timeout 30
Interface FastEthernet0/0
Description LAN
ip address
ip access-group sdm_fastethernet0_out out<------I've taken this line out
ip nat inside
ip virtual-reassembly<------I've taken this line out
duplex auto
speed auto
no mop enabled
Interface FastEthernet0/1
no ip address
duplex auto
speed auto
Interface Vlan1
no ip address
ip forward-protocol nd
ip route cable-modem0/0/0
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
access-ist 1 permit
no cdp run
line con 0
line aux 0
line vty 0 4
password password
scheduler allocate 20000 1000
webvpn cef
miswhoiAuthor Commented:
I got it figured out.  I'll post up the configuration later for reference purposes.
Great..sorry for the late response
miswhoiAuthor Commented:
I had a considerable difficulty getting this device working with Comcast residential.  At one point I was pulling a public DHCP address from the provider, but I was confined to their walled garden.  I was unable to get out, and something occured that made me dump the config and start from scratch.  I went round-and-round in circles with the provider until I finally lost the desire to get it working and shelved the unit.

Within a month I received a BILL from Comcast telling me to return the device with the mac address that matched my HWIC-Cable-Modem-D-2.  I called them and got that issue resolved.

A couple of weeks ago I got the desire to try getting the 1805 working again, and this time it's rock solid.

First I configured the device with the attached code.
Next I called the provider and was completely honest about the device and what I was trying to do.  After spending 40 minutes on the phone with the representative, I was told that the device would not work on their network under any circumstances.

I then logged onto the provider's website and looked at their list of supported and approved modems.  The HWIC was not listed but one Cisco Systems device was.
I logged into chat and told the representative that I owned the supported Cisco.  I gave them the mac address of my device and I swapped the cable over to the HWIC and life has been grand since.

1.  no ip dhcp use vrf connected   
2.  ip dhcp excluded-address   
3.  !   
4.  ip dhcp pool $LAN$   
5.  import all   
6.  network   
7.  default-router   
8.  !   
9.  !   
10. ip cef   
11. !   
12. no ipv6 cef   
13. multilink bundle-name authenticated   
14. !   
15. !   
16. archive   
17. log config hidekeys   
18. !   
19. !   
20. Interface FastEthernet0/1/0   
21. switchport access vlan 10   
22. !   
23. (interface FE0/1/1 FE0/1/2 & FE0/1/3 in shutdown)   
24. !   
25. Interface Cable-Modem0/0/0   
26. description Comcast-Link   
27. ip address dhcp   
28. no ip redirects   
29. no ip unreachables   
30. ip nbar protocol-discovery   
31. ip nat outside   
32. ip virtual-reassembly   
33. random-detect dscp-based   
34. no cdp enable
   no shutdown
35. !   
36. !   
37. Interface FastEthernet0/0   
38. (management int)   
39. ip address   
40. speed auto   
42. no mop enabled   
43. !   
44. !   
45. Interface FE0/1   
46. shutdown   
47. !   
48. !   
49. Interface Vlan1   
50. no ip address   
51. shutdown   
52. !   
53. !   
54. interface Vlan10   
55. description $LAN$   
56. ip address   
57. ip nat inside   
58. ip virtual-reassembly   
59. no mop enabled   
60. !   
61. !   
62. ip forward-protocol nd   
63. ip route Cable-Modem0/0/0   
64. !   
65. !   
66. ip nat inside source list 1 interface Cable-Modem0/0/0 overload  
67. !   
68. access-list 1 permit   
69. !   
70. !   

Open in new window


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.