Web control (ascx page) will not position correctly on master page

Greetings,

I have a control which is called by a master page.  The control is an editor with an info section above it  as seen in the picture.  These two objects are separate but should stay together.   The editor has a 'full screen' button or mode (circled in red).  When this button is selected, the editor will expand out nicely.  However, in actuality it is expanding out so far that it covers the master page section on the top and the information section of the editor goes away into la, la land.  

The master page section is directly above the editor info section and can be identified by the 'expander' line and the title called 'Label'.

As seen in the bottom picture, after the full screen mode is shut off, the editor goes out of it's boundry or won't go back into it's hole for lack of a better term.  Ok, it won't go back to it's righful position.

Anyone have any idea why this is happening?  Let me know what code you need to see......

Thanks
editor-before-full-screen.JPG
editor-after-full-screen.JPG
John500Asked:
Who is Participating?
 
Bob LearnedCommented:
Ok, so you have a content page, and an editor that is on all the pages.  

Position=relative, overflow=auto

Relative vs. absolute positioning:  the control will change depending on the other controls with relative, and won't move with absolute.
0
 
Bob LearnedCommented:
Are you working with 3rd party controls, <div> elements, Panels, etc.?  What does the HTML look like?
0
 
John500Author Commented:
Hello,

The master page code is directly below which calls the conrol with 'EditorEntityNotice1'
--------------------------------------------------------------------------------------------------------------------------------
<%@ Page Language="VB" MasterPageFile="~/BF-MasterPage.master" AutoEventWireup="false" CodeFile="Editor_EntityNotice.aspx.vb" Inherits="Editor_EntityNotice" title="Untitled Page" %>
<%@ Register src="EditorEntityNotice.ascx" tagname="EditorEntityNotice" tagprefix="ucen1" %>

<asp:Content ID="Content1" ContentPlaceHolderID="head" Runat="Server">
</asp:Content>
<asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">

<div style="position:relative;width:100%;height:100%;overflow:auto">

<ucen1:EditorEntityNotice ID="EditorEntityNotice1" runat="server" />

</div>

</asp:Content>
--------------------------------------------------------------------------------------------------------------------------------

The code for the ASCX file is pretty long.  Which part of it are you interested in?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
John500Author Commented:
So in other words, I needed to try changing to 'absolute' - right?

I tried this but when it came time to switching out of full screen mode, the bottom of the page got extended and the top still wouldn't show the information box.  You can see by the picture below the top portion of the editor remains in full screen and won't go back to it's original position.

How about that 'overflow' setting?  Does have anything to do with this?

Thanks
editor-after-absolute-positionin.JPG
0
 
Bob LearnedCommented:
Is the "information box" on the master page, or content page?
0
 
John500Author Commented:
Thanks again.  The 'absolute' positioning was key but when I removed the 'overflow' altogether it worked as I would hope....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.