Solved

DNS Replication : Windows DNS (Prim) and Linux Bind (Sec)

Posted on 2009-07-09
5
1,674 Views
Last Modified: 2013-12-15
Hi,

I have a primary DNS server running on Windows Server 2008 (Windows DNS) and i have a secondary DNS server running on BIND 9 (Debian Linux).

First of all, i set up a first zone on my secondary DNS (Bind) :
xxx.xxx.xxx.in-addr.arpa

Everything is good and replicating correctly with my primary Windows DNS.

But then, i try to set up additionnal zones with exactly the same settings and i have :
client XXX.XXX.XXX.XXX#55468: received notify for zone 'xxxxx.xxx': not authoritative

I have exactly the same settings for all my zones on my Windows DNS as well.

Why does it works for my reverse zone and not for standard forward zones?

Bonus question :  In Windows DNS Parameters, do i have to check the "Bind Secondaries" option? I have red that its for older version of Bind that doesnt support "notify" or something like that...  Is it ok to leave unchecked with Bind 9??

Thanks.
0
Comment
Question by:jhamel2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 78

Expert Comment

by:arnold
ID: 24825506
Did you add the forward zone to the named.conf file similar to the reverse zone?

The error says that bind received a notification of a change in xxxxx.xxx, but it is not authoritative for the zone.


0
 

Author Comment

by:jhamel2
ID: 24825731
Hi,

I add my zones in named.conf.local

Yes, i did add my standard forward zone in that files exactly like i did for the reverse zone.
0
 

Author Comment

by:jhamel2
ID: 24825926
Heres is my named.conf.local file :


//
// Do any local configuration here
//
 
// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";
 
 
zone "XXX.169.209.in-addr.arpa" {
        type slave;
        file "/etc/bind/zones/XXX.169.209.in-addr.arpa.db";
        masters { 209.169.XXX.XXX; };
};
 
 
zone "mydomain.com" {
        type slave;
        file "/etc/bind/zones/mydomain.com.db";
        masters { 209.169.XXX.XXX; };

Open in new window

0
 
LVL 78

Accepted Solution

by:
arnold earned 500 total points
ID: 24827839
run rndc status, how many zones does it show that it knows about 2,3?
run also rndc reconfig and check the /var/log/messages for any entries.
Is the Bind server referenced in the zone with an NS record?
0
 

Author Comment

by:jhamel2
ID: 24835026
Hi,

Ok i found what i did wrong :

I commented "directory "/var/cache/bind" in named.conf.options since it was not my working directory (etc/bind)

All zones are transferring correctly now.

Thanks a lot !
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question