Solved

Cisco Pix to ASA - Site to Site VPN not coming up

Posted on 2009-07-09
5
431 Views
Last Modified: 2012-05-07
I am attmepting to setup a second site to site VPN tunnel on a Cisco Pix 501.  I am having trouble with it.  This is first time where the destination fiewall (cisco ASA) subnet is not a private subnet and I believe this is throwing me off.

The ASA's firewall IP is 204.xxx.xx8.249, whereas its subnet that I need to communicate with is 204.xxx.xx9.0.  The local subnet on the Pix is 192.168.73.x.

I turned on the logging and this is the only thing I am seeing.

IPSEC(sa_initiate): ACL = deny; no sa created

The pre-existing vpn tunnel is working just fine.

Curent config of the Pix is below.  Any ideas?

Thanks!
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname bugsfw
domain-name uncovr945
fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
no fixup protocol http 80
no fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
no fixup protocol sqlnet 1521
no fixup protocol tftp 69
no names
access-list inbound permit icmp any any echo-reply
access-list nonat permit ip 192.168.73.0 255.255.255.0 10.214.30.0 255.255.255.0
access-list nonat permit ip 192.168.73.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list nonat permit ip 192.168.73.0 255.255.255.0 204.xxx.xx9.0 255.255.255.0
access-list split permit ip 192.168.73.0 255.255.255.0 10.214.30.0 255.255.255.0
access-list 102 permit ip 192.168.73.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 101 permit ip 192.168.73.0 255.255.255.0 204.xxx.xx9.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 71.xxx.xxx.248 255.255.255.0
ip address inside 192.168.73.254 255.255.255.0
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool uncrpool 10.214.30.1-10.214.30.254 mask 255.255.255.0
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 71.xxx.xxx.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set uncrset esp-3des esp-md5-hmac
crypto ipsec transform-set uncrus_ca esp-3des esp-md5-hmac
crypto ipsec transform-set uncrus_ihs esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 14400
crypto dynamic-map uncrdyna 90 set transform-set uncrset
crypto dynamic-map uncrdyna 90 set security-association lifetime seconds 7200 kilobytes 4608000
crypto map uncrmap 1 ipsec-isakmp
crypto map uncrmap 1 match address 102
crypto map uncrmap 1 set peer 75.xxx.xxx.249
crypto map uncrmap 1 set transform-set uncrus_ca
crypto map uncrmap 1 set security-association lifetime seconds 28800 kilobytes 4608000
crypto map uncrmap 2 ipsec-isakmp dynamic uncrdyna
crypto map uncrmap 3 ipsec-isakmp
crypto map uncrmap 3 match address 101
crypto map uncrmap 3 set peer 204.xxx.xx8.249
crypto map uncrmap 3 set transform-set uncrus_ihs
crypto map uncrmap 3 set security-association lifetime seconds 3600 kilobytes 4608000
crypto map uncrmap interface outside
isakmp enable outside
isakmp key ******** address 75.xxx.xxx.249 netmask 255.255.255.255 no-xauth
isakmp key ******** address 204.xxx.xx8.249 netmask 255.255.255.255
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption 3des
isakmp policy 30 hash md5
isakmp policy 30 group 2
isakmp policy 30 lifetime 3600
vpngroup test8-2312 address-pool uncrpool
vpngroup test8-2312 dns-server 192.168.73.2 208.180.42.100
vpngroup test8-2312 wins-server 192.168.73.2
vpngroup test8-2312 i58-Bn31 split-tunnel split
vpngroup test8-2312 idle-time 3600
vpngroup test8-2312 password ********
ssh 192.168.73.0 255.255.255.0 inside
ssh timeout 15
management-access inside
console timeout 0
terminal width 80

Open in new window

0
Comment
Question by:aiscom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 24816303
What version PIX code are you running?  

Are you licensed for more than 1 peer?  

Make sure the nonat on the far side of VPN matches exactly the nonat on this unit.  

0
 

Author Comment

by:aiscom
ID: 24816860
The Pix is running 6.3.5.  
If you mean IKE peers, that is showing we are licensed for 10.
The ASA on the other side is using something like this, but I dont know how to implement this on the Pix since I am going to have multiple tunnels.

nat (inside) 0 access-list 101

Can this command be entered multiple times for different access lists?
0
 

Author Comment

by:aiscom
ID: 24822829
Friendly bump.  :)
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 24823804
When I use a nat 0 for multiple tunnels, I've always just added the source and dest to the same nat0 acl.   I don't think you can have multiple Nat 0 on the same interface since it would probably mess with how the ACLs are processed, which ACL would be applied 1st, etc...  

BTW, having a non-private range as the destination of a VPN tunnel makes no difference.   Your firewall doesn't care, it will match the destination to the ACL and nonat it, or catch it in the crypto match....  

Everything looks ok to me.  Any chance we can see the code or some logs on the far end of this tunnel
0
 

Accepted Solution

by:
aiscom earned 0 total points
ID: 24865704
We were able to get this working.  I had the config on the ASA rebuilt and the tunnel then came up.  Thanks for the help!
0

Featured Post

Ready to trade in that old firewall?

Whether you need to trade-up to a shiny new Firebox or just ready to upgrade from whatever appliance you're using now, WatchGuard has the right appliance for you! Find your perfect Firebox today with appliance sizing tool!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
Let’s face it: one of the reasons your organization chose a SaaS solution (whether Microsoft Dynamics 365, Netsuite or SAP) is that it is subscription-based. The upkeep is done. Or so you think.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month7 days, 16 hours left to enroll

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question