Solved

Urgentttt webservice

Posted on 2009-07-09
39
699 Views
Last Modified: 2013-12-14
Look at the pictures webservice's config file as added code
<?xml version="1.0"?>

<!-- 

    Note: As an alternative to hand editing this file you can use the 

    web admin tool to configure settings for your application. Use

    the Website->Asp.Net Configuration option in Visual Studio.

    A full list of settings and comments can be found in 

    machine.config.comments usually located in 

    \Windows\Microsoft.Net\Framework\v2.x\Config 

-->

<configuration>
 
 

  <configSections>

      <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">

        <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">

          <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

          <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">

            <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />

            <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />

            <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />

            <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />

          </sectionGroup>

        </sectionGroup>

      </sectionGroup>

    </configSections>
 

  <appSettings>

    <add key="ConnectionString" value="server=localhost;database=ilansehri1;uid=ilansehri1;password=131120041042;Pooling=false;Connect Timeout=45;"/>

  </appSettings>

    <connectionStrings/>

    <system.web>

      <customErrors mode="Off"/>

        <!-- 

            Set compilation debug="true" to insert debugging 

            symbols into the compiled page. Because this 

            affects performance, set this value to true only 

            during development.
 

            Visual Basic options:

            Set strict="true" to disallow all data type conversions 

            where data loss can occur. 

            Set explicit="true" to force declaration of all variables.

        -->

        <compilation debug="false" strict="false" explicit="true">
 

        <assemblies>

            <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

            <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

            <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

            <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

        </assemblies>
 

        </compilation>

        <pages>

          <namespaces>

            <clear />

            <add namespace="System" />

            <add namespace="System.Collections" />

            <add namespace="System.Collections.Generic" />

            <add namespace="System.Collections.Specialized" />

            <add namespace="System.Configuration" />

            <add namespace="System.Text" />

            <add namespace="System.Text.RegularExpressions" />

            <add namespace="System.Linq" />

            <add namespace="System.Xml.Linq" />

            <add namespace="System.Web" />

            <add namespace="System.Web.Caching" />

            <add namespace="System.Web.SessionState" />

            <add namespace="System.Web.Security" />

            <add namespace="System.Web.Profile" />

            <add namespace="System.Web.UI" />

            <add namespace="System.Web.UI.WebControls" />

            <add namespace="System.Web.UI.WebControls.WebParts" />

            <add namespace="System.Web.UI.HtmlControls" />

          </namespaces>
 

          <controls>

            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

          </controls>
 

        </pages>

        <!--

            The <authentication> section enables configuration 

            of the security authentication mode used by 

            ASP.NET to identify an incoming user. 

        -->

        <authentication mode="Windows" />

        <!--

            The <customErrors> section enables configuration 

            of what to do if/when an unhandled error occurs 

            during the execution of a request. Specifically, 

            it enables developers to configure html error pages 

            to be displayed in place of a error stack trace.
 

        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">

            <error statusCode="403" redirect="NoAccess.htm" />

            <error statusCode="404" redirect="FileNotFound.htm" />

        </customErrors>

        -->
 
 

      <httpHandlers>

        <remove verb="*" path="*.asmx"/>

        <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

        <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

        <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>

      </httpHandlers>

      <httpModules>

        <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

      </httpModules>

      <webServices>

        <protocols>

          <add name="HttpGet"/>

          <add name="HttpPost"/>

        </protocols>

      </webServices>

        

    </system.web>
 

    <system.codedom>

      <compilers>

        <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4"

                  type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">

          <providerOption name="CompilerVersion" value="v3.5"/>

          <providerOption name="WarnAsError" value="false"/>

        </compiler>

        <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4"

                  type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">

          <providerOption name="CompilerVersion" value="v3.5"/>

          <providerOption name="OptionInfer" value="true"/>

          <providerOption name="WarnAsError" value="false"/>

        </compiler>

      </compilers>

    </system.codedom>

    

    <!-- 

        The system.webServer section is required for running ASP.NET AJAX under Internet

        Information Services 7.0.  It is not necessary for previous version of IIS.

    -->

    <system.webServer>

      <validation validateIntegratedModeConfiguration="false"/>

      <modules>

        <remove name="ScriptModule" />

        <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

      </modules>

      <handlers>

        <remove name="WebServiceHandlerFactory-Integrated"/>

        <remove name="ScriptHandlerFactory" />

        <remove name="ScriptHandlerFactoryAppServices" />

        <remove name="ScriptResource" />

        <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode"

             type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

        <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode"

             type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

        <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

      </handlers>

    </system.webServer>
 

    <runtime>

      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">

        <dependentAssembly>

          <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>

          <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>

        </dependentAssembly>

        <dependentAssembly>

          <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>

          <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>

        </dependentAssembly>

      </assemblyBinding>

    </runtime>
 

</configuration>

Open in new window

hata1.jpg
hata2.jpg
hata3.jpg
0
Comment
Question by:CahitEy
  • 21
  • 14
  • 2
39 Comments
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
Also my dns recordss page
hata5.jpg
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
Also my webservice has no proxy, antivirus or firewall
i have my own exclusive ip
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
alson couldnot resolve the mysql host on web server but there is no problem on server's dns system
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
I think if i could dns record to web config it will be resolved but how?
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
excuseme if im wrong but, just in case, did you change your ConnectionString before publish your webservice?
it points to localhost.

I havent check anything else. sorry.
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
yes while i am trying to connect to mysql i do it localhost if i change it to the ilansehri.com it is not workin

no such host found error it gives...

additionally

the code as seen below returns this answer on localmachine






www.google.com : 216.239.59.99

www.google.com : 216.239.59.147

www.google.com : 216.239.59.103

www.google.com : 216.239.59.104
AddressFamily: InterNetworkAddress: 216.239.59.99 AddressFamily: InterNetworkAddress: 216.239.59.147 AddressFamily: InterNetworkAddress: 216.239.59.103 AddressFamily: InterNetworkAddress: 216.239.59.104
ns5.sayfa.net : 91.205.173.77
AddressFamily: InterNetworkAddress: 91.205.173.77
www.ilansehri.com : 91.194.90.38
AddressFamily: InterNetworkAddress: 91.194.90.38
webservices.ilansehri.com : 91.194.90.38
AddressFamily: InterNetworkAddress: 91.194.90.38
www.3dyumurcaklarsinifi.com : 78.129.146.114
AddressFamily: InterNetworkAddress: 78.129.146.114



AND ON THE SERVER


www.google.com : 72.14.221.104

www.google.com : 72.14.221.147

www.google.com : 72.14.221.99

www.google.com : 72.14.221.103
AddressFamily: InterNetworkAddress: 72.14.221.104 AddressFamily: InterNetworkAddress: 72.14.221.147 AddressFamily: InterNetworkAddress: 72.14.221.99 AddressFamily: InterNetworkAddress: 72.14.221.103
ns5.sayfa.net : 91.205.173.77
AddressFamily: InterNetworkAddress: 91.205.173.77
www.ilansehri.com :
System.Net.Sockets.SocketException: The requested name is valid, but no data of the requested type was found at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6) at System.Net.Dns.GetHostByName(String hostName) at Default2.bilgi_al(Object adres) in Q:\vhosts\ilansehri.com\subdomains\panel\httpdocs\Default2.aspx.vb:line 23
[DoResolve] Exception: System.Net.Sockets.SocketException: The requested name is valid, but no data of the requested type was found at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6) at System.Net.Dns.GetHostByName(String hostName) at Default2.IPAddresses(String server) in Q:\vhosts\ilansehri.com\subdomains\panel\httpdocs\Default2.aspx.vb:line 42
webservices.ilansehri.com :
System.Net.Sockets.SocketException: The requested name is valid, but no data of the requested type was found at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6) at System.Net.Dns.GetHostByName(String hostName) at Default2.bilgi_al(Object adres) in Q:\vhosts\ilansehri.com\subdomains\panel\httpdocs\Default2.aspx.vb:line 23
[DoResolve] Exception: System.Net.Sockets.SocketException: The requested name is valid, but no data of the requested type was found at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6) at System.Net.Dns.GetHostByName(String hostName) at Default2.IPAddresses(String server) in Q:\vhosts\ilansehri.com\subdomains\panel\httpdocs\Default2.aspx.vb:line 42
www.3dyumurcaklarsinifi.com : 78.129.146.114
AddressFamily: InterNetworkAddress: 78.129.146.114
Imports System.Net

Imports System.Net.Sockets
 

Partial Class Default2

    Inherits System.Web.UI.Page
 

    Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
 

        bilgi_al("www.google.com")

        IPAddresses("www.google.com")

        bilgi_al("ns5.sayfa.net")

        IPAddresses("ns5.sayfa.net")

        bilgi_al("www.ilansehri.com")

        IPAddresses("www.ilansehri.com")

        bilgi_al("webservices.ilansehri.com")

        IPAddresses("webservices.ilansehri.com")

        bilgi_al("www.3dyumurcaklarsinifi.com")

        IPAddresses("www.3dyumurcaklarsinifi.com")

    End Sub

    Private Sub bilgi_al(ByVal adres)

        Try

            Dim returnvalue = ""

            Dim he As IPHostEntry = Dns.GetHostByName(adres)

            Dim ip_addrs As IPAddress() = he.AddressList
 

            'he.AddressList.SetValue("91.194.90.38", 0)

            Response.Write("")

            Dim ip As IPAddress

            For Each ip In ip_addrs

                Response.Write("<br/ >" & adres & " : " & ip.ToString() & "<br/>")

            Next ip

        Catch ex As System.Exception
 

            Response.Write("<br/ >" & adres & " : <br/>" & ex.ToString() & "<br/>")

        End Try

    End Sub

    Private Sub IPAddresses(ByVal server As String)

        Try

            Dim ASCII As New System.Text.ASCIIEncoding()
 

            ' Get server related information.

            Dim heserver As IPHostEntry = Dns.GetHostByName(server)
 

            ' Loop on the AddressList

            Dim curAdd As IPAddress

            For Each curAdd In heserver.AddressList
 

                ' Display the type of address family supported by the server. If the

                ' server is IPv6-enabled this value is: InternNetworkV6. If the server

                ' is also IPv4-enabled there will be an additional value of InterNetwork.

                Response.write(("AddressFamily: " + curAdd.AddressFamily.ToString()))
 

                ' Display the ScopeId property in case of IPV6 addresses.

                If curAdd.AddressFamily.ToString() = ProtocolFamily.InterNetworkV6.ToString() Then

                    Response.write(("Scope Id: " + curAdd.ScopeId.ToString()))

                End If
 

                ' Display the server IP address in the standard format. In 

                ' IPv4 the format will be dotted-quad notation, in IPv6 it will be

                ' in in colon-hexadecimal notation.

                Response.write(("Address: " + curAdd.ToString()))
 

                ' Display the server IP address in byte format.

                Console.Write("AddressBytes: ")
 
 
 

                Dim bytes As [Byte]() = curAdd.GetAddressBytes()

                Dim i As Integer

                For i = 0 To bytes.Length - 1

                    Console.Write(bytes(i))

                Next i

                Response.write(ControlChars.Cr + ControlChars.Lf)

            Next curAdd
 

        Catch e As Exception

            Response.write(("[DoResolve] Exception: " + e.ToString()))

        End Try

    End Sub

End Class

Open in new window

0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
for the mysql prolem try to pass the IP instead of the domain name.
for the webservice problem. pass the webservices address programatically. change it when you publish the webservice.

try to connec to you rlocal machine from server. As you mention it works from local MySQL, test if you can access your local copy of MySQL from Server (use your IP in the connection string)

you may have some permisions conflict between MySQL databases.
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
it is not a big problem to connect mysql when i use localhost on server it is connecting i add it to show the dns problem of the system
the actual problem as you could see on the latest post of me
server could not resolve my domain's  dns names as you could see that is why it could not find webservices.ilansehri.com while i am trying to connect from myserver
but when i try to connect from outside of server there is no problem with it
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
ok what I understand is that
1.Webservice is on your machine as the same as one Mysql DB.
2.You create the webapplication and when debugging it works ok from you same local machine.
3.you want to publish the webapplication to another webserver but maintain the connection to the DB and WebService to the original development machine.(your local copy)
4.Server cannot see your machine using the domain name.

you obviously can see the server as you are publishing the application to it by network but Server cannot  connect back to your web service nor DB.

tell me if im right.

if that the case, just test if server can see you on netowrk by IP or, when you connect by share folders, what IP do the server see as yours.

check if the IP that server see from you is the same as you see for your self.

you can go in the server to Control Panel->Administrative Tools->Computer management->shared Folders->Sessions to see the IP server see as your IP.

let me know your results.


0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
2.You create the webapplication and when debugging it works ok from you same local machine.
additionally also when i am connecting to webservice from localhost site to remote server webservice youcould check :
http://webservices.ilansehri.com/Genel_Islemler.asmx
and you could try to add your application my webservice there is no problem

but when i upload my site to same machine with my webservice (To my server) it is not working

also i am using exclusive ip

my problem is only any of web applications when doing an internal operation like connecting myqsl or webservice inside the server could not resolve the domain names

but there many sites on this server for example
www.3dyumurcaklarsinifi.com

it could resolve its name as you see on my last post

my applications couldnt resolve only mysite names from dns
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
have you tried to use that exclusive ip number instead of domain name?

and no, i cannot see your webservice. it throws Host not found which is good since there is not good idea to let everyone know your exclusive IP in forums.

so it looks like your webservice is not yet public,
check this link to get some advice on make your DB public (similar process to make your webservice public):
http://www.d3scene.com/forum/wow-private-server-info-help/3277-making-your-server-public-my-guide.html

you cal also check your public IP here:
http://whatsmyip.org/

Once you manage to know your IP configuration and setup everything to work for Public IP access you should have no more problems.
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
sorry wrong link... let me search the right one.

0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
and no, i cannot see your webservice. it throws Host not found which is good since there is not good idea to let everyone know your exclusive IP in forums.

thid made my mind complicated because i am connecting :

http://webservices.ilansehri.com/Genel_Islemler.asmx

this link from my house computer
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
could you please also look at the images added to the question and wild card image
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
Also you could see the internal name resolving results from :

http://panel.ilansehri.com/default2.aspx
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
sorry wrong link...

check this one

      
http://quick-help.net/Host-Own-Domain
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
this link returning empy page check it pls.
0
 
LVL 1

Expert Comment

by:thermalsun
Comment Utility
here the error what i see...
just for reference.
errormsg.JPG
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 1

Author Comment

by:CahitEy
Comment Utility
but also this is not solve my problem in my opinion ...
0
 
LVL 1

Expert Comment

by:thermalsun
Comment Utility
try updating code against the IP for the site.
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
I have managed to Open http://de2.sayfa.net/default2.aspx
which is the reversed DNS from the ip of your host file

try using that doman name. (if the address is correct)
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
yes this is the error already my all system is working from webservices and when you try to connect manually :


http://webservices.ilansehri.com/Genel_Islemler.asmx

it has no error on public .

my host could not resolve my domain name and my sub domain names inside the server try to add this webservice to your application it will work from your computer and from other hosts it is not working on the server locally because couldnot resolve dns for only my host and its subdomains

as the same problem when i write for mysql host www.ilansehri.com it is not working but when i write another site name on the server for example

www.3dyumurcaklarsinifi.com

it is working i could only connect on server to mysql with localhost option

but i could connect to mysql on server from my home with:
www.ilansehri.com and www.3dyumurcaklarsinifi.com  

as you could see the problem is in my host it could not solve my subdomain and domain names inside the server
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
yes but this is www.ilansehri.com's reserved dns how could i find webservices.ilansehri.com's reserved name? or filestorage.webservices.com there are many many webservice on my sistem as this they were working until yesterday they got this error suddenly
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
I cant  either...

also check the results from the DNSof your IP exclusive IP 91.194.90.38:

http://www.dnsstuff.com/tools/ipall/?tool_id=67&token=&toolhandler_redirect=0&ip=91.194.90.38

that shows that your doman is de2.sayfa.net not www.ilansehri.com

try to connect your webapplication to de2.sayfa.net  and see if it works.
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
but this connects the direct httpdocs folder

but my webservices working on subdomains
for example:
subdomain/webservices/httpdocs/gene_islemler.asmx

if they were on the www.ilansehri.com instead of webservices.ilansehri.com i could connect them directly from ip but this will not a solution because they are on subdomains and it could not resolve my subdomains

could you look at my wild cards i have an internal director  cname as

*.ilansehri.com to ilansehri.com all the subdomains if they have no real folder is handling by www.ilansehri.com for example adasdsdf.ilansehri.com will open you www.ilansehri.com i do not know if this occurs this problem but it was working until last night
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
ok if it was working please recheck this list:

***    How do I host my own domain? ****
1-First thing is first, you need your own domain name. You can go to any registrar and get one (e.g Network Soultions, Register.com, registerfly.com, godaddy.com, etc.) I personally use registerfly.com because their control panel beats the pants off anything I've every seen, and they are affordable at $9.99 or sometimes less whn they hold a SALE!

2-You need to sign up with a "custom dns "service like www.dyndns.org or www.no-ip.org (I think that's their name) Follow their instructions, and they provide domain registration also if you want to roll those two processes together.

3-Point your registrar's system to the DNS services' "domain name servers" or "DNS servers" and that if done correctly will propagate in about 48 hours max (be diseminated through the Internet.)

4- Get a "DNS client" to run on YOUR server, this little app communicates back to the DNS service and let's them know what your'e current IP is if it is dynamic so they will know what to point to so your www.yourdomain.com will resolve at the right place. (You can skip this if you have a static ip and only one machine with no router/firewall-which is bizzarely unsafe.) Your DNS Client should be set to be one of your "login items" so it auto-launches at every restart.

5-If you do have a router/firewall you have to configure "port forwarding" so traffic hitting your router on port 80 (html port) will be passed on to your server's IP on your internal LAN. If your ISP blocks port 80 then you will need to route it to another port (e.g. 8080 and make sure your sever has tha port open in "network port configurations") or consult the DNS service's FAQ's they usually have a workaround.

source :http://www.oreillynet.com/cs/user/view/cs_msg/8023
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
but i do not want to make my computer as my web server i already have a vps
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
sorry if I cannot help to much, please wait a moment for some else more experienced than me to help you.
All that i can say is that your neither domain nor sub domains are accessible from my computer, so they are not public and because of that your server is also having problems to access it.
I know this dont help to much but its the most I can do for you.
Hope you find a solution soon.
Regards.

0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
im just wondering, can you try to send the dns records to the administrator for the webapplication server network?

this may speedup the changes of your configuration on  the webserver.

regards.
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
i tryed they seems no error inside the system :S
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
i looked deeply but seems no error also there were no error log at when i see first error i am installing all system again from the beginning
0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
maybe to late but did you tried to update the host file on the webserver?
%SystemRoot%\system32\drivers\etc\hosts

actually im not sure if it has something to do but give it a try.

check if this line help:
91.194.90.38 ilansehri.com
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
it is too late i looked it was also there now i am building all site again thanks for your help i will tell the result in a few hours
0
 
LVL 1

Author Comment

by:CahitEy
Comment Utility
it is still not working :S
0
 
LVL 1

Accepted Solution

by:
CahitEy earned 0 total points
Comment Utility
the problem was found

it cause of the wild card dns

cname
*.ilansehri.com
ilansehri.com

0
 
LVL 4

Expert Comment

by:pepepaco
Comment Utility
we where very close since the beginning, sorry for not be able to help you sooner.

Regards.
0

Featured Post

New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

Join & Write a Comment

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now