Crystal Reports Server Failed to load database information

I have a Crystal Report that works just fine as designed in Crystal XI connecting to my Oracle database.  I have installed and configured Crystal Reports Server and uploaded the report to the CMC into a new folder.  When I try to run or preview the report, I get the message "Failed to Load Database Information".  In the process/database settings I have tried both using the original database login information from the report, supplying the correct username and password and I have also tried using the custom settings for Oracle.  Both return the same error.  I have Oracle 9i client installed on my Crystal Server (Windows Server 2003) and can connect without a problem to my Oracle database using SqlPlus.  Please help me in finding why my report will not run via Crystal Server.  I am trying to get it to run so that I can schedule this report to run on a daily basis.  I have read other questions and answers on Experts Exchange but they either do not pertain to my issue or I tried the resolution provided but it did not help.  Thanks in advance.
LRI1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LinInDenverCommented:
The only thing I can think of - is the ODBC connection created on the CE Server, and named the same as the machine the report was built on? You mentioned you have the ability to connect on it through SQL Plus, but I can't remember if that means your ODBC is set (I've been away from Oracle for 1.5 years now).

Even though your ODBC connections will display in the CMC on the Database properties (which in the past made me think I didn't have to do anything!) you still need to create an ODBC on the actual CE server.

Hope this helps some how - good luck!
Lin
0
LRI1Author Commented:
Hi,

I am not connecting with ODBC on the report so I should not need it on the CE server.  I connect via the Oracle Server connection packaged with Crystal Reports.  However, yesterday I did set up an ODBC connection from my CE server and chose that in the process/database properties of the report.  Same error.  Thanks for trying.  Anyone else have any insight?
0
mlmccCommented:
Did you install the Oracle database driver from Crystal on the server?

mlmcc
0
LRI1Author Commented:
Not quite sure what you mean.  The Oracle driver was installed when I installed Crystal Reports Server.  It shows that I have the Oracle driver as an option under custom database login information.
0
LRI1Author Commented:
I was able to get it to work!  For anyone else who has this issue, try the following.

From the Crystal Server. Go to Start-->Programs--> Business Objects-->Crystal Report Server-->Central Configuration Manager.

Now for Crystal Reports Job Server and Crystal Reports Page Server right click and select properties. Both the accounts should be running under an admin account and not LocalAdmin. I changed them to run under my domain admin account since my domain admin has full access to my Oracle Database server.

That worked for me!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.