Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

SERVER 08 32x TASK MANAGER shows 3gb memory

Posted on 2009-07-09
4
329 Views
Last Modified: 2012-05-07
I have a HP server being used as a terminal server. I recently noticed that in the Task manger it only shows  3325MB yet in the server manager it shows 8gb. It also looks like it is only using 3gb
0
Comment
Question by:UDTExchange
  • 2
  • 2
4 Comments
 
LVL 58

Expert Comment

by:tigermatt
ID: 24816557

A 32-bit system can ONLY address 4GB of RAM MAXIMUM due to architectural limits caused by the CPU. The 4GB can be dimished by up to a gigabyte or more as you add other devices to the system. This effect is commonly referred to as the "PCI hole": http://en.wikipedia.org/wiki/PCI_hole.

On a 32-bit system, it is common for you to see RAM being used of anywhere between 2.75GB and 3.5GB. I have seen SOME servers report all 4GB is in use, but this only applies in particular circumstances and hardware configurations.

You have 2 options:

Because you are running the Enterprise Edition of Server 2008, there is no SOFTWARE limitation of 4GB RAM. If your CPU supports PAE, you can enable this function in your boot configuration. PAE extends the CPU to a 36-bit CPU, which can support a maximum of 64GB of RAM.

If the CPU is 64-bit capable (most new CPUs are), reinstall the server with the 64-bit edition of Windows Server 2008. This will give you native support for more RAM than could ever be addressed by any of today's server hardware.

-Matt
0
 
LVL 58

Accepted Solution

by:
tigermatt earned 500 total points
ID: 24816570

As an adendum to my previous comment, the procedure for enabling PAE can be found at http://support.microsoft.com/kb/929580.

-Matt
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24826291
Adding /PAE as above mention will address all 8Gb of your memory. Here is the simple instruction of how to do it:
Open command line and type the following command:
cd \
Make sure you are at C:\  then type

edit boot.ini
Click on Search and Find then type fastdetect. You then add /PAE as the following:
.... /fastdetect /PAE
Done.

K
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24826304
Forgot to mention that make sure you save your edit (File --> Save) then Done.

K
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question