We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Help with event id 1526 "Windows did not load your roaming profile

The_Spaz
The_Spaz asked
on
Medium Priority
4,703 Views
Last Modified: 2012-05-07

We are running Presentation Server 4.5 with now almost 50 machines in our farm.

We get this in the event log (randomly) and sometimes 20 users in a day and sometimes just 5. Event ID: 1526

Windows did not load your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Windows did not load your profile because a server copy of the profile folder already exists that does not have the correct security. Either the current user or the Administrator's group must be the owner of the folder. Contact your network administrator.

 

We have tried using the xcacls from http://www.brianmadden.com/forums/t/26502.aspx for all users on the tsprofiles server and then deleting their profile on all 50 servers in \documents adn settings\%username% and that works for that user for a day, or even a week and then it starts over again.  Any ideas as to how to finally make this go away for good.  This is really getting annoying in farm of almost 50 servers and 2500 users.  

We do have a GPO that is setup as

 Administrative Templateshide
Policy definitions (ADMX files) retrieved from the local machine.System/Group Policyhide
Policy Setting Comment
User Group Policy loopback processing mode Disabled  

System/User Profileshide
Policy Setting Comment
Delete cached copies of roaming profiles Enabled  

Windows Components/Terminal Services/Terminal Server/Connectionshide
Policy Setting Comment
Set rules for remote control of Terminal Services user sessions Enabled

and also a redirect policy for the users with:

Windows Settingshide
Folder Redirectionhide
Documentshide
Setting: Basic (Redirect everyone's folder to the same location)hide
Path: \\meanserver\Private$\%USERNAME%\MyDocs
Optionshide
Grant user exclusive rights to Documents Disabled
Move the contents of Documents to the new location Disabled
Also apply redirection policy to Windows 2000, Windows 2000 server, Windows XP, and Windows Server 2003 operating systems Enabled
Policy Removal Behavior Restore contents

Musichide
Setting: Follow the Documents folder
Pictureshide
Setting: Follow the Documents folder
Videoshide
Setting: Follow the Documents folder

if that helps.  Please help! thanks!

Comment
Watch Question

Are you running UPHClean on your servers?  If not, give that a shot.  Sometimes a profile will not delete itself as it may have a handle open.  UPHClean closes those handles allowing the profile to delete itself upon user logoff.  
Robin CMSenior Security and Infrastructure Engineer
CERTIFIED EXPERT

Commented:
Yes use UPHClean always (even if you're not getting this problem).
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=1b286e6d-8912-4e18-b570-42470e2f3582

How are you setting the location to store the roaming profiles?
Group policy or via the user account configuration in active directory?
Check permissions on that folder/share.
Are any profiles being saved back?
Could be AV scanning on the file server used to hold the roaming profiles locking one of the files and preventing the terminal server copying it at user logon. Try temporarily excluding the profiles folder. Check for locked files on the file server and see what has them locked (probably use process explorer).

Author

Commented:
Sorry forgot to mention that
yes. We are already running UPHClean on all machines and the setting for roaming profiles is in Active Directory.  Also, incase you are going to ask if the place for the profile and the tsprofile are in different places that answer is also yes (as recommended by Citrix).

Robin CMSenior Security and Infrastructure Engineer
CERTIFIED EXPERT

Commented:
ok:
Are any profiles being saved back?

Could be AV scanning on the file server used to hold the roaming profiles locking one of the files and preventing the terminal server copying it at user logon. Try temporarily excluding the profiles folder. Check for locked files on the file server and see what has them locked (probably use process explorer from sysinternals (free)).
Is it a Windows server holding the romaing profiles?

Author

Commented:
We have verified the AV server is not Holding the profile(s) and yes all 50 (almost) are running Windows Server 2003 with the latest patches with Presentation Server 4.5.

Keep bringing the suggestions this way, please...
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Robin CMSenior Security and Infrastructure Engineer
CERTIFIED EXPERT

Commented:
Check the permissions on the folder that is shared out for the roaming profiles (i.e. e:\data\tsprofiles).
Should be:
Administrators: full control
Creator Owner: full control
Users: Special (list and create folders only)
This assumes your users are a member of domain users, and domain users is a member of the local users group no the server hosting e:\
There is a policy setting you should apply to your terminal servers to give admins access to profiles:
Computer configuration, administrative templates, system, user profiles:
Add the Administrators security group to roaming user profiles
You might also like to use the Delete cached copies of roaming profiles policy, and if you get it all working also turn on the Do not log users on with temporary profiles policy. I have all three on and have no problems. The latter is handy as it doesn't confuse your users with wierd looking desktops - though it assumes that your profiles share is pretty highly available.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.