Solved

PDF file won't automatically open in IE Browser, tries to do a "File Download" instead?

Posted on 2009-07-09
11
428 Views
Last Modified: 2012-05-07
Hello,

I am having a real issue with a web site where I click the link and I want the PDF to automatically associate it with my Adobe reader on my machine and open in the IE browser window.  What I get instead is a "File Download" dialog box and then I have to click "Open" to make it work.

Please help me understand if this is an IE issue or a problem with the way the web site coded this PDF to work with IE.

Capt
0
Comment
Question by:capt_morgan
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 7

Expert Comment

by:nikhilmenon
ID: 24816994
To configure Internet Explorer to use Adobe Reader or Acrobat as a helper application:

1. Start Internet Explorer, and choose Explorer > Preferences.

2. Under Receiving Files, click File Helpers.

3. In the File Helper Settings pane, select Portable Document Format, click Change, and then click OK.

4. If Portable Document Format isn't listed, click Add, and then proceed with the following steps:

a. In the File Type text box, type PDF and type a space after the "F".

b. In the Creator text box, type CARO.

c. In the Encoding section, select the following options:

-- Select Binary

-- Use For Incoming

-- Use For Outgoing

d. In the Download Destination section, choose the location in which to save PDF files from the Download menu.

e. In the Handling Section, choose View with Application from the How to Handle menu.

f. If the Acrobat product name doesn't appear next to Application, click Browse, select the Acrobat application file, and then click Open.

g. Click OK.

5. Restart Internet Explorer.
0
 

Author Comment

by:capt_morgan
ID: 24817160
None of those settings are in IE as you mentioned.  

There is no "Explorer > Preferences" settings in Internet Explorer that i can see.  I do have the Tools > Options settings.

?
0
 
LVL 7

Accepted Solution

by:
nikhilmenon earned 250 total points
ID: 24817270
My apologies.. I had the wrong version up.

Try this:

Go to Tools -> Internet options

There, select the 'Programs tab' and click on Manage Add-ons

Click on the 'Toolbars and extensions' section.

To the lower left, you will find a 'Filters' drop down. Click on that and select 'All add-ons'

Then ont he section to the right you will find under 'Adobe systems incorporated' the Adobe PDF reader link helper.

Enable it.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 18

Assisted Solution

by:chuckyh
chuckyh earned 250 total points
ID: 24817588
What version of Adobe reader do you have installed?
Open Adobe reader, click on Edit - Preferences.
Choose Internet and make sure "display PDF in Browser" is checked.
0
 

Author Comment

by:capt_morgan
ID: 24825751
nikhilmenon:
     The option you mentioend 'Adobe Reader Link Helper' was already checked but the problem still exists.

0
 

Author Comment

by:capt_morgan
ID: 24825758
chuckyh:

I will try that option and let you know what happens.
0
 

Expert Comment

by:KNBsysteembeheer01
ID: 24876945
Capt Morgan, did you find a solution? I have this problem also!
I have this only with one user who receives a newsletter with hyperlinks in it.
when she clicks on a link it's redirected to an external webpage with pdf's in it.
Normally it show the pdf immediately in the browser but on her pc she gets the message to download the file
0
 

Author Comment

by:capt_morgan
ID: 25118157
None of these options you mentioned have worked for me.  

1 .  Manage Add-ons and Adobe PDF Link Helper was there and enabled but that failed to help.
2.   The option for "Display PDF in a Browser" and that did not help either.  

Anyone have anything else I can try?
0
 

Expert Comment

by:KNBsysteembeheer01
ID: 25168275
Capt. Morgan did you install Adobe reader 9.0 or Adobe Acrobat 9.0? It seems it had something to do with that version. Because I upgraded 2 users from Adobe Acrobat 7.0 and on both their pc's I have the same problem as you do.
0
 

Expert Comment

by:KNBsysteembeheer01
ID: 25175215
this is my problem, hopefully someone can help us (text is in dutch)
downloadmessage.bmp
0
 

Author Closing Comment

by:capt_morgan
ID: 31601778
Never really got a answer that worked.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Reocurring Mac pop up message 7 95
Video won't play 5 64
Firebug on Firefox 50 2 139
disclaimer when opening internet 2 40
How many times have you been browsing the internet, with multiple tabs open, and closed the wrong one? Have you ever clicked 'Close all tabs' instead of 'Close current tab' ? Internet Explorer 8 now brings to you, what Firefox has had for a wh…
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question