Solved

Exchange 2007 Global address list

Posted on 2009-07-09
24
517 Views
Last Modified: 2012-05-07
I have a new Exchange 2007 server installed that was migrated from an exchange 2000. Everything is working fine except for 1 issue. The Domain comntroller is sitting on a 2003 server as well as the GC. When we add a new mailbox using the exchange 2007 managment console the new user will show up in the Global catalog as long as you log into outlook web access but the Outlook clients on the network do not see the new users. How do I force the clients on the network to update their global catalog?
0
Comment
Question by:joshrosen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 7
  • 6
24 Comments
 
LVL 8

Expert Comment

by:Npatang
ID: 24817449
See if your Outlook is in cached mode. Try checking the same in online mode.. If thats work try downloading the OAB ......OAB doesn't seems to be updating
0
 

Author Comment

by:joshrosen
ID: 24817481
How do you download the OAB?
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24817508
In outlook fo to Tools> Send Recieve > Download Address Book..
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 65

Accepted Solution

by:
Mestha earned 250 total points
ID: 24817623
Outlook in cached mode uses the OAB. The OAB is only updated once a day by default. Outlook then downloads the OAB automatically once every 24 hours.
Therefore it can take up to 48 hours for a change to be seen by the clients.

You can force it by updating the OAB on the server

get-offlineaddressbook| update-offlineaddressbook

After 10 - 15 minutes, download the OAB through Outlook, Tools, Send/Receive, Download Address Book.

Simon.
0
 

Author Comment

by:joshrosen
ID: 24817637
If I take a client and remove cached mode it starts working. I tried this on 1 client out of 250. On anouther client I tried the update address book and it did not work. There must be anouther way to update all cached mode clients besides going around to 250 workstations. Any thoughts?
0
 

Author Comment

by:joshrosen
ID: 24817667
When I re enable cached mode all new uers go away again.
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24817682
So it is sure issue with your OAB which is not updating?  
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24817714
Also check if there any Erros you can see in the App log
0
 

Author Comment

by:joshrosen
ID: 24817752
Process MSEXCHANGEADTOPOLOGY (PID=1604). The site monitor API was unable to verify the site name for this Exchange computer - Call=DsctxGetContext Error code=8007077f. Make sure that Exchange server is correctly registered on the DNS server.
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24817759
For better understanding oF OAB check http://msexchangeteam.com/archive/2006/11/15/431502.aspx 
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24818113
The OAB update issue is something that you will have to live with.
While it is possible to have the OAB update more often, by changing the generation schedule, you cannot change the behaviour of Outlook when it comes to downloading a new copy of the OAB.
For most companies this isn't a problem because new users are not created that often.
Where there is a high turnover and no laptop use, then the OAB can be turned off. However if you have laptop users then it isn't advised.

Simon.
0
 

Author Comment

by:joshrosen
ID: 24818154
I do not understand if users have been using the GC for years in 2000 2003 why would things change. Does this mean that by upgrading to 2007 users must go to outlook 2007? How do you change the Generation schedule?
0
 
LVL 8

Expert Comment

by:Npatang
ID: 24818237
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24818285
The behaviour hasn't changed since Exchange 5.5, if you are using Outlook 2003 or higher in cached mode. Cached mode is basically offline folders on steroids - offline folders have been around in every version of Outlook ever.

I cannot comment on how you had your Exchange 2000 server setup, but by default it would be the same for Outlook 2003 and higher in cached mode - OAB generation once a day, downloaded automatically once a day or when Outlook is restarted. Nothing has changed in Exchange 2007.

If you were seeing changes to the GAL immediately then I have to doubt that you were using cached mode. You cannot see GAL changes live in cached mode unless the OAB functionality is disabled. That is an Outlook setting, not an Exchange setting, therefore would still apply after a migration.

Simon.
0
 

Author Comment

by:joshrosen
ID: 24818605
Simon I created a user 6 days ago and the GAL was not updated only when I uncheck cahched mode.
all users are on chached mode. The client on all workstations is 2003 outlook.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24818995
You are incorrect - the GAL was not updated when you turned off cached mode. That is like saying your car was fixed after an accident because you bought a new car.

When you disabled cached mode you switched from using the Offline Address Book to using live information.

If the user was created six days ago then it sounds like the OAB is not updating correctly.
Did you follow the Microsoft guide for removing Exchange 2000 - including moving things like the OAB generation server and replicating the public and system folders?

Simon.
0
 

Author Comment

by:joshrosen
ID: 24819568
Yes I did and they all said replicated. Followed step by steb by kb articles.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24825736
Run

get-offlineaddressbook |fl

verify that every server in the results is valid. It should be pointing to your Exchange 2007 server and to a domain controller.

Simon.
0
 

Author Comment

by:joshrosen
ID: 24871551
Mestha when I do a get-offlineaddressbook it shows my current 2007 server no others.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24871593
If you run the command I provided above, then wait, and then look in the event viewer, does that show any errors related to the OAB?
Have you run the best practises tool from the toolbox?

Simon.
0
 

Author Comment

by:joshrosen
ID: 24871722
The only error message I get in the APp log is the one I have posted above. The BP analyzer comes back clean in the Health Check.
0
 

Author Comment

by:joshrosen
ID: 24871729
Process MSEXCHANGEADTOPOLOGY (PID=1604). When updating security for a remote procedure call (RPC) access for the Exchange Active Directory Topology service, Exchange could not retrieve the security descriptor for Exchange server object TTOPSCORP16 - Error code=8007077f.
 The Exchange Active Directory Topology service will continue with limited permissions.

and


Process MSEXCHANGEADTOPOLOGY (PID=1604). The site monitor API was unable to verify the site name for this Exchange computer - Call=DsctxGetContext Error code=8007077f. Make sure that Exchange server is correctly registered on the DNS server.
0
 

Author Comment

by:joshrosen
ID: 24871768
I ran the BPA on the exchange server itself and got under Non-Default settings the following

Default Global Adress List Changed:

The 'purportedSearch' attribute of the default Global Address List 'Default Global Address List' has been changed. Default: '(& (mailnickname=*) (| (&(objectCategory=person)(objectClass=user)(!(homeMDB=*))(!(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=user)(|(homeMDB=*)(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=contact))(objectCategory=group)(objectCategory=publicFolder)(objectCategory=msExchDynamicDistributionList) ))'. Current: '(& (mailnickname=*) (| (&(objectCategory=person)(objectClass=user)(!(homeMDB=*))(!(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=user)(|(homeMDB=*)(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=contact))(objectCategory=group)(objectCategory=publicFolder) ))'.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24883795
I would correct the GAL back to what it should be and also resolve any other issues the best practises tool says.

The earlier error is a little more of a concern and would tend to indicate a problem with the domain. Ensure that the Exchange server is only using the domain controllers for DNS - no external DNS servers.

Simon.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Outlook 2016 - Operation has failed 11 114
profile account in outlook problem 3 45
active directory, exhange 12 62
Exchange server take over 4 57
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question