Solved

iNotes login page

Posted on 2009-07-09
28
2,519 Views
Last Modified: 2013-11-17
We have just recently switched to session authentication (single server). Attached to this are two pictures, the first is what I see, and the second is what I should see. I have setup the server as per the instructions given by IBM, however I still only see what's in first image.
I have created domcfg.nsf and added a mapping to the correct database and form.

Any suggestions?
1.jpg
2.jpg
0
Comment
Question by:zerogeek
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 16
  • 10
  • 2
28 Comments
 

Author Comment

by:zerogeek
ID: 24822858
None of the listed links above helped in my situation. I am not having issues with the logo, it is not showing the default page. I have no idea where this other sign-on is coming from.
0
 
LVL 20

Expert Comment

by:brwwiggins
ID: 24822949
I'll shoot for the obvious...did you add an entry in the ACL for anonymous reader access to the database?
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:zerogeek
ID: 24823708
Yes.
0
 
LVL 20

Expert Comment

by:brwwiggins
ID: 24824872
are you using internet site documents for these servers? If so, is anonymous access in the TCP authentication section set to "yes"

What you are seeing is a default login page if you do not configure a page. My guess is that anonymous access is not enabled and the server and showing you the login prompt to get to your custom form
0
 

Author Comment

by:zerogeek
ID: 24824965
We are running Domino 8.5. I have setup iNotes Redirector and that is the default homepage. When you visit the homepage, it gives you the form as shown in the first picture. When you login thru that form it directs you to your iNotes email. All of that is fine, it is just that I have been asked to put the company logo on that page.

Load internet site documents is disabled. (With that enabled it disables session authentication)
Could that be my problem? If that needs to be enabled, how can I modify an internet document to allow session authentication?
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24825355
Hi there zerogeek,,,,

In Fact, in my first post I just wanted to give you some similar examples . However,, you have mentioned the following

>>> I have created domcfg.nsf and added a mapping to the correct database and form.<<<
Please make sure that you have configured it similar to the one shown in the attachemnt
by defining the formname as the " DWAloginForm"
Please have a look and make it exactly similar then update me if you still need some help .

Good Luck




DWA.JPG
0
 

Author Comment

by:zerogeek
ID: 24825469
My domcfg.nsf does not have a DWALoginForm. The application I created, inotesredirector.nsf, does tho. That is what it is linked to and it does not work.
0
 

Author Comment

by:zerogeek
ID: 24825959
Where is the form I am seeing located? If I knew that I could just add the logo to it...
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24827263
Hi there zerogeek,,,,

Thank you very much for this clarification. However, to my knowledge that in order to have the page you were asking for  you have to create and configure a Domino Web Access redirect page and here is how to do it :

http://blogs.3sharp.com/timr/archive/2009/04/29/5049.aspx

Then you have to make the configuration of the DWAloginForm . In Fact this is what I am doing in 5 Domino Web Servers of mine


Good Luck  
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24827273
Remember to make the configurations for the Server Document ==> Internet protocol and Http .
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24829680
Hi there zerogeek,,,

You can refer to the following
http://200.40.51.220/help/help7_admin.nsf/f4b82fbb75e942a6852566ac0037f284/8943cef571045030852570610054c2a7?OpenDocument

And for the configuration of the server please have a loot at the red boxes on the attached snaps


serverconfig.JPG
serverconfig1.JPG
0
 

Author Comment

by:zerogeek
ID: 24839223
Thank you for the replies. However, I have my server setup appropriately for all comments listed above, and I had previously followed the instructions listed. It just seems that I am missing something.

ACL on iwared.nsf
-Default-
Access: Author - Write pub docs, replicate or copy docs, read pub docs, create docs

Anonymous
User Type: Person group
Access: Reader - Write pub docs, replicate or copy docs, read pub docs

Are these correct? I found these on an IBM tutorial. This could be holding me back.
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24839677
Hi there Zeroqeek,,,

Practilcally in the DWAs I am using,,, Here are the settings .


ACL on iwared.nsf
-Default-
Access: Author -  create documents and Replicate or copy documents only

Anonymous
User Type: Unspecified
Access: No Access - Read public documetns and Replicate or copy documents only

But still I highly recommend you to take in to consideration the "DWALoginForm" .


Good Luck



0
 

Author Comment

by:zerogeek
ID: 24839726
I have it setup to go to the DWALoginForm. However, nothing happens.
It is mapped like so:

DB: iwared.nsf
Form Name: DWALoginForm


Still nothing different happens.
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24839849
Did you set the ACL as I mentioned above ????
On the console run the following command please ( tell http restart ) Then try and update me .

Good luck


0
 

Author Comment

by:zerogeek
ID: 24840162
I changed the ACL settings and restarted the HTTP server. Still having the same issue.
0
 

Author Comment

by:zerogeek
ID: 24840215
I just noticed that after changing to that ACL, it now makes me sign in twice. Once to open the iwared.nsf then again once iwared.nsf locates my mail file.
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24840497
zerogeek,,,,,,

Please check the following :

1- click the Iwared.nsf database
2- click " Setup"
3- click " Server Settings"
4- in " Please select Redirection Type" make sure that the dark one " Selected One " is ( Fixed )
5- Please make sure that in the  filed of :
" Please enter ther server name to use
i.e., http://mail.lotus.com ( or use https//to use SSL)"

There is nothing at all ... Dont put any thing ,,,, check it like this

Good Luck.


0
 

Author Comment

by:zerogeek
ID: 24840601
The redirector now only prompts once, but I am still seeing the same login.
0
 

Author Comment

by:zerogeek
ID: 24841789
Are there some other settings I am missing?





note: please see http:#a24873338 for a replacement file for this comment
4.jpg
0
 
LVL 15

Accepted Solution

by:
akhafaf earned 500 total points
ID: 24842257
0
 

Author Comment

by:zerogeek
ID: 24842332
Yes. I just realized what it was though. I did not have my ACL's setup properly on the domcfg.nsf
0
 

Author Comment

by:zerogeek
ID: 24842344
Even though they are now setup, I cannot view the images on the DWALoginForm page...
0
 

Author Comment

by:zerogeek
ID: 24842419
It is now working.
0
 

Author Closing Comment

by:zerogeek
ID: 31601815
Thanks for all the help.
0
 
LVL 15

Expert Comment

by:akhafaf
ID: 24843141
You are most welcome zerogeek :)
0
 

Author Comment

by:zerogeek
ID: 24873338
Posting picture to replace file "3.jpg" in http:#a24841789
5.jpg
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data‚Ķ
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question