Solved

How to stop RDP connection from creating another user session

Posted on 2009-07-09
2
699 Views
Last Modified: 2013-11-21
I have a hosted session of Windows 2003 Server.  I RDP into it and install a LogMeIn client then I connect with LogMeIn and discover that it is running like its in a Terminal Service session.  How do I make the two desktops the same?  Is it possible?  
0
Comment
Question by:Todd710
2 Comments
 
LVL 58

Accepted Solution

by:
tigermatt earned 500 total points
ID: 24818496

Impossible via RDP.

LogMeIn interacts with the 'Console' session. It allows you to directly control what you would see if you were sat in front of the server. Anyone sat next to the server could watch the monitor and observe what you were doing.

Using Remote Desktop, a separate session is created to connect to by default. You can connect to the console session by running mstsc with the /console switch (mstsc is the Remote Desktop Client utility), BUT doing so will simply lock the console session to anyone watching the monitor on the server - which includes LogMeIn.

This is the nature of RDP and there is no way of changing it - it is for security reasons.

The only routes you have to change this would be using perhaps LogMeIn in conjunction with VNC - both access the console session but don't lock the screen.
Alternatively (and I have never used LogMeIn beyond basic remote access for 1 user on the Free version) there MAY be some mode which allows multiple users to connect to one desktop in LogMeIn, or some equivalent software. That would also work.

-Matt
0
 

Author Comment

by:Todd710
ID: 24840220
Thanks Matt,

You answered my question indirectly.

I am not trying to connect multiple users to the same machine I am just trying to avoid multiple instances running at the same time.  For instance if I log into the desktop and launch an application with LMI(LogMeIn) and then log in with RDP and launch the same application I now have 2 instances running.  If both RDP and LMI were using the console I would see the one running and not launch it again.  

I have tried to force RDP to the console and it does not appear to work.  This is a hosted solution I am working on with Amazon web services.  I may need to get Amazon involved to see if they are not allowing the console mode in RDP.

I am not sure this is a big a problem I once thought.  RDP will only be used on the inital connection and in an emergency.

Todd
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Boot PC and press F10, select storage options and change the compatibility from “AHCI” to “IDE”, save and exit 2. Boot PC and press F12 3. Upon PXE display of searching for DHCP server, press Pause break to obtain MAC address 3. Open Configu…
My previous article  (http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/A_4466-A-beginners-guide-to-installing-SCCM2007-on-Windows-2008-R2-Server.html)detailed one possible method to get SCCM 2007 installed an…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

832 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question