Solved

Disable Remote Session Printers on Terminal Server

Posted on 2009-07-09
3
2,172 Views
Last Modified: 2013-11-21
I have a terminal server that MANY people use from remote locations. We have a list of network printers that they are to use. These printers are deployed to the terminal server through a GPO for each user.

Some users have local printers or have a connection to one or more of the network printers already on their local machine. These printers are displayed in the "Printers and Faxes" section on the termninal server with the name of the server and then the Session information beside it.

I know I can disable the printers from appearing by modifying the remote desktop connection properties. What I want to do is to have the server reject these printer session connections. There are too many connections in too  many locations for me to do this manually to each remote desktop connection. Is there a GPO of somesort for the Terminal Server where I can specify "Disable Session Printer Connections" or something of the sort?

*note* The Terminal Server is 2003 and our Active Directory is 2008

Thank you.
TSprinters.png
0
Comment
Question by:respawn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 

Expert Comment

by:NeilDBlackburn
ID: 24819112
You can turn off printer mapping in Terminal Services Configuration, its on the client settings tab
0
 
LVL 20

Accepted Solution

by:
EndureKona earned 500 total points
ID: 24822891
1.  Administrator Tools | TS Configuration | Connections, right click RDP-Tcp and choose properties | Client Settings.
2.  Uncheck 'Use connection settings from user settings'
3.  Uncheck  'Connect client printers at login'

Or
 
Use the local Group Policy Editor like so:  Click Start, and then click Run.
In the Open box, type gpedit.msc, and then click OK.

Computer Configuration - Windows Components - Terminal Services - Client/Server data redirection - "Do not allow client printer redirection"

Set it to Enabled.
0
 

Author Comment

by:respawn
ID: 24823496
I believe this did the trick. Thank you!!


1.  Administrator Tools | TS Configuration | Connections, right click RDP-Tcp and choose properties | Client Settings.
2.  Uncheck 'Use connection settings from user settings'
3.  Uncheck  'Connect client printers at login'
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Auditing domain password hashes is a commonly overlooked but critical requirement to ensuring secure passwords practices are followed. Methods exist to extract hashes directly for a live domain however this article describes a process to extract u…
A hard and fast method for reducing Active Directory Administrators members.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question