Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Routing Traffic Through IPSec Tunnel on Cisco ASA

Posted on 2009-07-09
11
Medium Priority
?
3,121 Views
Last Modified: 2012-05-07
This on is for the ages!   I would give a million points if I could if someone figures this one out.

I have a Cisco ASA 5510, I am initiating a VPN tunnel to a vendor who has a NetScreen FW on teh other end.  The tunnels, not a problem, get those intitiated with no problem.  The problem comes when I try to pass SCTP (protocol 132) over the VPN....the firewall just doesn't see it as interesting traffic.  This is NOT a config issue, I have had both the vendor AND Cisco say my config is fine....

Ultimately the problem Cisco said is they do nto support SCTP.  It turns out we cannot wrap it in TCP?UDP, etc.  So my qustion is, can I just route through the ASA without packet or protocol inspection?  Or any other creative ideas people my have out there....please I am desperate to figure this out!!!
0
Comment
Question by:authentify
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
11 Comments
 
LVL 28

Expert Comment

by:asavener
ID: 24819714
Does the vendor have other clients using an ASA as the VPN endpoint?

Can you post your config anyway?
0
 
LVL 8

Expert Comment

by:pgolding00
ID: 24819831
if your config has a permit entry for proto 132 in the acl used in the match address statement of the crypto definition, this should work fine. you can verify that the asa is trying to do the right thing by "sh access-l <list name>" and you will see a counter at the end of each line, indicating matching traffic. look at the line with proto 132 to verify that much is right.

next, "sh cry ips sa peer <netscreen public address>" will show if an sa has been established for this traffic, plus encrypted and decrypted traffic count. if both of these show other than 0, you should be in business.
0
 
LVL 1

Author Comment

by:authentify
ID: 24819970
Yeh I did the sh access-list thing with both the Cisco tech and the the vendor.  Here is what happens....

I can initiate a tunnle by doing a simple ICMP (Ping) request from a node on the network that is supposed to go over the VPN Tunnel.  When I packet sniff those ICMP requests, I see it hit the interface, translate and end up ESP traffic over the tunnel and back....the vendor verify he sees the pings on the other end....no problem......I do a SCTP request from that same node, I see it hit the interface, not get translated and then egress the outside interface....clearly not headed for the VPN tunnel.....for whatever reason the FW does not see it as interesting traffic.....I have specified Proto 132 and the hit count remains "0".  In the packet sniff I can clearly see in the IP header Proto:SCTP
0
Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

 
LVL 1

Author Comment

by:authentify
ID: 24819972
asaevener,

They say they do but to what capacity they do not specify...so are they passing SCTP?  Who knows...I can post my config but it will have to be tomorrow......
0
 
LVL 28

Expert Comment

by:asavener
ID: 24820211
Sounds like the SCTP traffic gets picked up by NAT.  (Cisco devices have an order of operations; NAT takes place before crypto.)

Make sure you have a "nat (inside) 0 access-list <ACL-name>" command, and that the SCTP traffic is listed in the access list.
0
 
LVL 1

Author Comment

by:authentify
ID: 24820306
So I created access-list 199...allowed 192.168.1.x to any Destination and defined the 132 protocol with an object group....I can't apply the NAT because it says "access list 199 contains a protocol or port"

If I list ip, that doesn't seem to natively cover 132 for some reason.
0
 
LVL 28

Expert Comment

by:asavener
ID: 24822611
OK, try "nat (inside) 0 192.68.1.0 255.255.255.0".
0
 
LVL 28

Expert Comment

by:asavener
ID: 24824462
Er... Should be "192.168.1.0"
0
 
LVL 1

Author Comment

by:authentify
ID: 24824869
Yeh no nat is not going to work....from my understanding...my crypto map is from 66.54.x.x to the destination on the other end...my static nat is from 192.168.x.x to 66.54.x.x...no nat means no traffic is sent to the crypto map ACL....so when I put a no nat statement in no traffic goes over the vpn...

So it looks from packet sniffs that the nat works in getting it to the outside interface it is just ignored by the crytpo map as uninteresting traffic.
0
 
LVL 28

Accepted Solution

by:
asavener earned 1500 total points
ID: 24825872
So, does a "show xlate" display the SCTP traffic as being NAT'd correctly?

Still kinda flying in the dark here, without a config to peruse.
0
 
LVL 1

Author Comment

by:authentify
ID: 24836973
Hey all sorry to go dark there for a little bit....the truth is that setting up the VPN through thye ASDM is not rocket science, so it was clear that the acl and ace's were all correct, especially since ICMP traffic would clearly use the correct crypto map ACL....the problem is with the SCTP traffic specifically.  

It clearly does not like being NAT'd...this goes back to the ASA's having no native support for SCTP.  When i set up the vpn tunnel as a direct connect network....menaing the other end accepting traffic directly from the nodes and not translating the address, it worked fine.  

asavener, you were correct in the nat was the problem, but it is further than that just a bit.  The ASA does not want to translate addreses when the protocol is SCTP and Cisco has confirmed that.....very disappointed in Cisco though, this protocol is not that new....
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question